irssi hangs/freezes (tmux related?)

Bug #871723 reported by Caspar Clemens Mierau on 2011-10-10
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
irssi (Ubuntu)
Undecided
Unassigned

Bug Description

On a current Ubuntu Oneiric Irssi shows the same behaviour of hanging several times a day. Hanging means: The user interface completely freezes. You cannot switch between windows. If it comes back up again all entered keystrokes haven't been lost and are "replayed".

Most times I can unfreeze Irssi by issuing a "pkill -1 irssi" which leads to "reloaded configuration" and responsive interface.

It seems the behavoir is related to laggy connection. Please note, I use Ipv6 and SSL in order to connect to a freenode server.

Two other irssi instances run on the same machine (one with the xmpp plugin, one with the silc plugin), so far not having this issues.

It might be of interest, that irssi runs inside tmux. I read about related issues:

http://<email address hidden>/msg00673.html

They it is said they are fixed.

I saw the behaviour already on a server with an earlier Ubuntu version.

I just noticed, the lag seems to occur during packet losses on the connection towards the irc server.

It is, of course, reasonable the chat lags then irc does not show new content, but I expect the user interface to be responsive.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in irssi (Ubuntu):
status: New → Confirmed
Eric Rucker (bhtooefr) wrote :

This bug affects me on Lucid, using screen instead of tmux. Usually happens whenever the internet connection is poor, even when the connection to the machine itself is fine, and screen is responding perfectly. I'm guessing it's unrelated to either screen or tmux.

pi-rho (pi-rho) wrote :

I can't confirm. I run irssi in tmux and maintain SSL connections with multiple servers including freenode and oftc. What does your memory usage look like when this happens? Are you running any scripts with irssi (i.e. aspeller)?

Mek Karpeles (3-m-f) wrote :

I'm experiencing the same issue, with tmux, specifically when I press C-s (was attempting to press C-a). This seems to impact others as well http://bugs.irssi.org/index.php?do=details&task_id=69

John Maguire (jmaguire2013) wrote :

C-q freezes output on screen until you press C-s. Here's why: http://en.wikipedia.org/wiki/XON/XOFF

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers