Ubuntu

[FFe] Sync irrlicht 1.7.2+dfsg1-1 (universe) from Debian unstable (main)

Reported by Oibaf on 2011-02-09
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
irrlicht (Ubuntu)
Wishlist
Unassigned

Bug Description

Related branches

tags: added: upgrade-software-version
Oibaf (oibaf) wrote :

Is this a problem? On 10.10 there aren't packages depending on libirrlicht1.7 and on natty 1.7.2 is highly recommended due to 1.7.1 bugs with supertuxkart 0.7 (crash, graphic corruption, keyboard not working on full screen).

It might at least break anything locally build using the 1.7.1 package. The breakage itself is in theory easy-ish to fix -- just patch the handfull of *virtual* destructors back in -- it's just not really rewarding and I have a lot of other stuff to do. Might appear soon or not at all depending.

Don't think making a exception now and let the broken ABI slip in is wise in long term.

ftr: no reaction on the upstream bug isn't a good sign and there's certainly no-one willing to fix it for every other upstream release or ignore it "because we made a exception now"

going now with a custom soname probably -- just too much pain working around the added struct members and stuff.

Changelog entries since current natty version 1.7.1+dfsg1-1:

irrlicht (1.7.2+dfsg1-1) unstable; urgency=low

  * New upstream release (LP: #715700)
  * Debian specific new soname
  * Bump Policy version to 3.9.1 -- no changes

 -- Christoph Egger <email address hidden> Sun, 20 Feb 2011 14:38:31 +0100

summary: - Please update irrlicht to version 1.7.2
+ Sync irrlicht 1.7.2+dfsg1-1 (universe) from Debian unstable (main)
Download full text (5.4 KiB)

Build log at http://wwwcip.cs.fau.de/~siccegge/irrlicht_1.7.2+dfsg1-1_i386.build

Install:

(natty-i386-sbuild)root@faui49p:/# dpkg -i libirrlicht1.7a-dbg_1.7.2+dfsg1-1_i386.deb
(Reading database ... 14657 files and directories currently installed.)
Unpacking libirrlicht1.7a-dbg (from libirrlicht1.7a-dbg_1.7.2+dfsg1-1_i386.deb) ...
dpkg: dependency problems prevent configuration of libirrlicht1.7a-dbg:
 libirrlicht1.7a-dbg depends on libirrlicht1.7a (= 1.7.2+dfsg1-1); however:
  Package libirrlicht1.7a is not installed.
dpkg: error processing libirrlicht1.7a-dbg (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libirrlicht1.7a-dbg
(natty-i386-sbuild)root@faui49p:/# dpkg -i libirrlicht1.7a_1.7.2+dfsg1-1_i386.deb
(Reading database ... 14665 files and directories currently installed.)
Unpacking libirrlicht1.7a (from libirrlicht1.7a_1.7.2+dfsg1-1_i386.deb) ...
dpkg: dependency problems prevent configuration of libirrlicht1.7a:
 libirrlicht1.7a depends on libgl1-mesa-glx | libgl1; however:
  Package libgl1-mesa-glx is not installed.
  Package libgl1 is not installed.
 libirrlicht1.7a depends on libjpeg62 (>= 6b1); however:
  Package libjpeg62 is not installed.
 libirrlicht1.7a depends on libx11-6; however:
  Package libx11-6 is not installed.
 libirrlicht1.7a depends on libxxf86vm1; however:
  Package libxxf86vm1 is not installed.
dpkg: error processing libirrlicht1.7a (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 libirrlicht1.7a
(natty-i386-sbuild)root@faui49p:/# apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following extra packages will be installed:
  libexpat1 libgl1-mesa-dri libgl1-mesa-glx libjpeg62 libx11-6 libx11-data libxau6 libxcb1 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxxf86vm1
Suggested packages:
  libglide3
The following NEW packages will be installed:
  libexpat1 libgl1-mesa-dri libgl1-mesa-glx libjpeg62 libx11-6 libx11-data libxau6 libxcb1 libxdamage1 libxdmcp6 libxext6 libxfixes3 libxxf86vm1
0 upgraded, 13 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 2491 kB/3848 kB of archives.
After this operation, 19.8 MB of additional disk space will be used.
Do you want to continue [Y/n]?
Get:1 ftp://debian.informatik.uni-erlangen.de/ubuntu/ natty/main libgl1-mesa-dri i386 7.10.1~git20110215.cc1636b6-0ubuntu2 [2491 kB]
Fetched 2491 kB in 0s (11.4 MB/s)
debconf: delaying package configuration, since apt-utils is not installed
Can not write log, openpty() failed (/dev/pts not mounted?)
Selecting previously deselected package libxau6.
(Reading database ... 14671 files and directories currently installed.)
Unpacking libxau6 (from .../libxau6_1%3a1.0.6-1_i386.deb) ...
Selecting previously deselected package libxdmcp6.
Unpacking libxdmcp6 (from .../libxdmcp6_1%3a1.1.0-1_i386.deb) ...
Selecting previously deselected package libxcb1.
Unpacking libxcb1 (from .../libxcb1_1.7-2_i386.deb) ...
Selecting previously deselected package libx11-data.
Unpacking libx11-data (from .../libx11-data_2%...

Read more...

Reason for sync request: fixes random crashes in applications using libirrlicht

summary: - Sync irrlicht 1.7.2+dfsg1-1 (universe) from Debian unstable (main)
+ [FFe] Sync irrlicht 1.7.2+dfsg1-1 (universe) from Debian unstable (main)
Iulian Udrea (iulian) wrote :

Ack. Approved.

Changed in irrlicht (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Iulian Udrea (iulian) wrote :

Sync ack. Subscribing ubuntu-archive to process it.

Didier Roche (didrocks) wrote :

[Updating] irrlicht (1.7.1+dfsg1-1 [Ubuntu] < 1.7.2+dfsg1-1 [Debian])
 * Trying to add irrlicht...
2011-03-11 08:47:32 INFO - <irrlicht_1.7.2+dfsg1.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2011-03-11 08:47:33 INFO - <irrlicht_1.7.2+dfsg1-1.dsc: downloading from http://ftp.debian.org/debian/>
2011-03-11 08:47:33 INFO - <irrlicht_1.7.2+dfsg1-1.debian.tar.gz: downloading from http://ftp.debian.org/debian/>
I: irrlicht [universe] -> libirrlicht-dev_1.7.1+dfsg1-1 [universe].
I: irrlicht [universe] -> libirrlicht-doc_1.7.1+dfsg1-1 [universe].

Changed in irrlicht (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.