Ubuntu

irqbalance classifies network interfaces with custom/renamed interfaces as class other

Reported by Daniel Jared Dominguez on 2012-04-05
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Medium
James M. Leddy
Precise
Undecided
James M. Leddy
Quantal
Medium
James M. Leddy
irqbalance (Ubuntu)
Medium
James Page
Declined for Precise by Chris Van Hoof
Quantal
Medium
James Page

Bug Description

The irqbalance daemon classifies network interfaces with non-eth* names as class "other" instead of class "network". In particular, this affects any machine with biosdevname enabled (NICs named em* and p*p*).

I have verified this in Precise beta 2. I run "irqbalance --debug" and grep for the interrupt using "grep em1 /proc/interrupts". grep shows:

  79: 2397 2660 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-0
  80: 180 181 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-1
  81: 250 1 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-2
  82: 249 0 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-3
  83: 182 3 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-4
  84: 449 1595 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-5
  85: 343 1319 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-6
  86: 26 14 0 0 0 0 0 0 0 0 0 0 0 0 0 0 IR-PCI-MSI-edge em1-7

irqbalance --debug shows:

Interrupt 84 (class other) has workload 2
Interrupt 80 (class other) has workload 1
Interrupt 86 (class other) has workload 0
Interrupt 85 (class other) has workload 0
Interrupt 83 (class other) has workload 0
Interrupt 82 (class other) has workload 0
Interrupt 81 (class other) has workload 0
Interrupt 79 (class other) has workload 0

The issue is resolved in the latest upstream of irqbalance using the following patch (commit from September 2011):
http://code.google.com/p/irqbalance/source/detail?r=32a7757a031445a48be70e0e815e710b5c54c88e

Related branches

Ameet Paranjape (ameetp) on 2012-04-05
Changed in irqbalance (Ubuntu):
milestone: none → ubuntu-12.04
Changed in oem-priority:
importance: Undecided → Medium
Changed in irqbalance (Ubuntu):
importance: Undecided → Medium
James M. Leddy (jm-leddy) wrote :

We should get debian to rebase to something more recent. Debian unstable is at version 0.56, and the latest upstream version is 1.0.3 .

tags: added: rls-mgr-q-tracking
tags: added: rls-incomming
removed: rls-mgr-q-tracking
Chris Van Hoof (vanhoof) on 2012-06-25
Changed in irqbalance (Ubuntu):
milestone: ubuntu-12.04 → ubuntu-12.10
Changed in irqbalance (Ubuntu Quantal):
status: New → Confirmed
James M. Leddy (jm-leddy) wrote :

Since I wrote comment #1, Debian has rebased the version to something 1.0.3 or later, so if we just take that we'll get the fix.

tags: added: rls-q-incoming
removed: rls-incomming
Ursula Junque (ursinha) on 2012-08-01
tags: removed: rls-q-incoming
tags: added: rls-q-incoming
Ursula Junque (ursinha) wrote :

James, IIRC, according to the rls-q-incoming process, the tag should be added only if the bug isn't targeted to the current dev release, which this bug is. That's why I removed the tag! :)

James M. Leddy (jm-leddy) wrote :

I see, sorry for the confusion. LP doesn't have the milestone in the history so it wasn't clear to me.

tags: removed: rls-q-incoming
James Page (james-page) wrote :

@James

How important is this for quantal? We are now past feature freeze and this is a seeded package so syncing the new upstream release over from Debian will required a Feature Freeze Exception.

Just determining whether this needs some focus now or next release.

James M. Leddy (jm-leddy) wrote :

This is pretty important. We're finally offering biosdevname for people that want to try it. It would be a bit of a black eye for us to not have a working irqbalance. Irqbalance is important for enterprise use cases, especially as we see 10gE become more mainstream, and the irqbalance we have currently is horribly out of date.

Additionally, while we're past feature freeze now, I'd like to point out that the bug has been open since 04-05, and we've had a debian package since at least 06-25, which is over 2 months ago.

irqbalance 0.56 was released in June 2010, and 1.0.3, which Debian Wheezy has, was released in December of last year. I've looked at the 1.0.3 package in Debian and Quantal's 0.56, and the only changes necessary are updating debian/control (XSBC-Original-Maintainer, Maintainer, and Standards-Version fields). All other changes from Ubuntu's 0.56 have been incorporated by Debian's package. I've even successfully built and used Debian's irqbalance 1.0.3 on Precise without problems.

Version 1.0.4 was released on August 27th and contains some bug fixes.

The attached .debian.tar.bz2 with the irqbalance 1.0.4 source builds irqbalance on Precise and runs without problems.

Kent Baxley (kentb) wrote :

I'd like to second the importance of having a working irqbalance now rather than later now that biosdevname is available in 12.10. I think it'd be worth it to try and get a feature freeze exception for this.

James Page (james-page) wrote :

@jm-leddy - the fact that this was missed pre-freeze is not lost on me...

We might not need a freeze exception as the new version does resolve this and other bugs - leave it with me.

Changed in irqbalance (Ubuntu Quantal):
assignee: nobody → James Page (james-page)
status: Confirmed → In Progress
Dave Walker (davewalker) wrote :

As discussed with James Page. This has a FFe ACK, on the condition that jm-leddy/vanhoof help validate it doesn't regress, and support the resolution of any fallout that is missed.

James suggested that this could be done via a PPA. If that route is taken, i'd like to see it in the archive by 14th September, or this ack should be re-reviewed. Thanks.

James Page (james-page) wrote :

@jm-leddy

I've uploaded the version from debian to ppa:james-page/junk for quantal.

Its in the build queue - please could you test once its built and validate that its working OK.

I'll then sync to the main archive.

Thanks

Kent and I tested your package on a couple systems. We discovered that the package is missing libnuma-dev from its Build-Depends so does not correctly work on a NUMA system (such as the PowerEdge R820). I had previously missed this because of the system I was running it on. :-( Adding this dependency and recompiling resolves the NUMA problem. I've submitted a bug report to Debian as well.

With the libnuma-dev dependency, 1.0.3 detects the em1-em4 as ethernet devices. I tested 1.0.4 on Quantal Beta1 as well, and it is working as well. Could we get 1.0.4 instead since it includes other important bug fixes (as listed below)?
- Fixed a divide by zero bug
- Fixed a memory corruptor when items are not assigned to a specfic numa node
- Improve rescan ability to catch a timing race early in irqbalance setup

The Debian bug for the libnuma-dev build-dep is http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=686986

James Page (james-page) wrote :

Daniel/Kent

Thanks for doing the testing - LGTM aside from the issues you raised.

I'll re-sync with Debian and add the missing Build-Depends on libnuma-dev. We can then take a look at the 1.0.4 release as a bug-fix only release.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package irqbalance - 1.0.3-1ubuntu1

---------------
irqbalance (1.0.3-1ubuntu1) quantal; urgency=low

  * Resync with Debian testing and fix compatibility with NUMA
    based systems (LP: #974450).
    - d/control: Add libnuma-dev to Build-Depends.

irqbalance (1.0.3-1) unstable; urgency=low

  * New upstream release 1.0.3
    Closes: #677669
  * Update irqbalance.init - Create PID file
    Closes: #598185
  * Homepage is http://code.google.com/p/irqbalance/
  * Update debian/watch
  * DH compatibility level is 9
  * Enable hardened build flags

irqbalance (0.56-2) unstable; urgency=low

  * Standards version is 3.9.3
  * Fix debian-rules-missing-recommended-target
  * Fix debconf to enable/disable irqbalance at boot time
    Patch by Jürgen Kreileder
    Closes: 580330
    LP: #573657

irqbalance (0.56-1.1) unstable; urgency=low

  * Non-maintainer upload.
  * Fix pending l10n issues. Debconf translations:
    - Dutch; (Jeroen Schot). Closes: #654756
    - Danish (Joe Hansen). Closes: #659470
    - Polish (Michał Kułach). Closes: #663453
    - Turkish (Mert Dirik). Closes: #664416
 -- James Page <email address hidden> Tue, 11 Sep 2012 14:20:10 +0100

Changed in irqbalance (Ubuntu Quantal):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.