Ubuntu

Not stoppable/restartable via initctl

Reported by Jürgen Kreileder on 2010-05-14
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
irqbalance (Ubuntu)
Medium
Chuck Short
Nominated for Lucid by Clint Byrum

Bug Description

Binary package hint: irqbalance

[irqbalance_0.55+20091017-3ubuntu2 on lucid]

irqbalance can not be stopped by upstart. 'stop irqbalance' just says 'Unknown instance'.

Note the different PIDs in the log below: 'start irqbalance' says 26320, while the actual running daemon has PID 26321

# stop irqbalance
stop: Unknown instance:
# ps auxw | grep [i]rqbalance
root 26991 0.0 0.0 11276 640 ? Ss 16:28 0:01 /usr/sbin/irqbalance
# kill 26991
# ps auxw | grep [i]rqbalance
# start irqbalance
irqbalance start/running, process 26320
# stop irqbalance
stop: Unknown instance:
# ps auxw | grep [i]rqbalance
root 26321 0.0 0.0 11276 640 ? Ss 21:03 0:00 /usr/sbin/irqbalance

Related branches

Chuck Short (zulcss) wrote :

Thanks for the bug report Ill have a look at this.

chuck

Changed in irqbalance (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package irqbalance - 0.55+20091017-3ubuntu3

---------------
irqbalance (0.55+20091017-3ubuntu3) maverick; urgency=low

  * debian/patches/do-irqbalance-pid.patch: Upstart needs a pid so it can shut down.
    (LP: #580674)
  * debian/irqbalance.upstart: Update upstart script.
 -- Chuck Short <email address hidden> Tue, 25 May 2010 17:38:47 -0400

Changed in irqbalance (Ubuntu):
status: Confirmed → Fix Released
Jürgen Kreileder (jk) on 2010-05-25
Changed in irqbalance (Ubuntu):
status: Fix Released → In Progress
Jürgen Kreileder (jk) wrote :

Reopened. The patch does not completely solve the problem:

The pid file doesn't get removed when irqbalance shuts down (missing capabilities?) and the next start fails because of open(...O_CREAT|O_EXCL...).

# sudo start irqbalance
irqbalance start/running, process 1347
# cat /var/run/irqbalance.pid ; echo
1347
# sudo stop irqbalance
irqbalance stop/waiting
# ps auxw | grep [i]rqbalance
# cat /var/run/irqbalance.pid ; echo
1347
# sudo start irqbalance
irqbalance start/spawned, process 1358
# ps auxw | grep [i]rqbalance
# tail /var/log/syslog
May 26 00:37:58 sphere init: irqbalance main process (1369) terminated with status 1
May 26 00:37:58 sphere init: irqbalance main process ended, respawning
May 26 00:37:58 sphere init: irqbalance main process (1371) terminated with status 1
May 26 00:37:58 sphere init: irqbalance main process ended, respawning
May 26 00:37:58 sphere init: irqbalance main process (1373) terminated with status 1
May 26 00:37:58 sphere init: irqbalance main process ended, respawning
May 26 00:37:58 sphere init: irqbalance main process (1375) terminated with status 1
May 26 00:37:58 sphere init: irqbalance main process ended, respawning
May 26 00:37:58 sphere init: irqbalance main process (1377) terminated with status 1
May 26 00:37:58 sphere init: irqbalance respawning too fast, stopped

Thierry Carrez (ttx) on 2010-06-16
Changed in irqbalance (Ubuntu):
assignee: nobody → Chuck Short (zulcss)
Chuck Short (zulcss) wrote :

This should be fixed for maverick.

Changed in irqbalance (Ubuntu):
status: In Progress → Fix Released
Graham (ubuntu-grahams) wrote :

I'm having this problem in an automated nightly build of a Natty Live Disc

Setting up irqbalance (0.56-1ubuntu3) ...
/etc/init.d/irqbalance: 85: start: not found
invoke-rc.d: initscript irqbalance, action "start" failed.
dpkg: error processing irqbalance (--configure):
 subprocess installed post-installation script returned error exit status 127

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers