irqbalance enabled unconditionally, can't be disabled via debconf

Bug #573657 reported by Jürgen Kreileder on 2010-05-02
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
irqbalance (Debian)
Fix Released
Unknown
irqbalance (Ubuntu)
Medium
Unassigned
Maverick
Medium
Unassigned

Bug Description

Binary package hint: irqbalance

[using 0.55+20091017-3ubuntu2 on lucid]

irqbalance gets enabled unconditionally upon installation. The user's answer to the question whether it should be enabled (upon installation or dpkg-reconfigure) gets ignored:

,---
| $ cat /etc/default/irqbalance
| #Configuration for the irqbalance daemon
|
| #Should irqbalance be enabled?
| ENABLED=1
| #Balance the IRQs only once?
| ONESHOT="0"
| $ sudo dpkg-reconfigure -ftext irqbalance
| stop: Unknown instance:
| Configuring irqbalance
| ----------------------
|
| Enable the irqbalance daemon to balance IRQs on SMP systems and systems with
| hyperthreading.
|
| Would you like to enable irqbalance? n
|
|
| irqbalance can run in one shot mode, where the IRQs are balanced only once. This
| is advantageous on hyperthreading systems such as the Pentium 4, which appear to
| be SMP systems, but are really one physical CPU.
|
| Would you like to balance the IRQs once? y
|
|
| irqbalance start/running, process 1496
| $ cat /etc/default/irqbalance
| #Configuration for the irqbalance daemon
|
| #Should irqbalance be enabled?
| ENABLED=1
| #Balance the IRQs only once?
| ONESHOT="1"
`---

=> dpkg-reconfigure managed to change the ONESHOT setting but not the ENABLED setting.

The problem is caused by a confusion over where to use "ENABLED" and where "ENABLE". I'm attaching a trivial patch which fixes the problem.

Jürgen Kreileder (jk) wrote :
description: updated
Chuck Short (zulcss) wrote :

Thanks this will be fixed in maverick.

chuck

Changed in irqbalance (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in irqbalance (Debian):
status: Unknown → New
David Futcher (bobbo) on 2010-06-08
tags: added: patch-forwarded-debian
papukaija (papukaija) on 2010-08-26
tags: added: lucid maverick patch
Thierry Carrez (ttx) on 2010-09-02
tags: added: server-mrs
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package irqbalance - 0.56-0ubuntu2

---------------
irqbalance (0.56-0ubuntu2) maverick; urgency=low

  * debian/irqbalance.{config,postinst}: Ask the user if they want to
    disable irqbalance or not. (LP: #573657)
 -- Chuck Short <email address hidden> Wed, 08 Sep 2010 09:01:22 -0400

Changed in irqbalance (Ubuntu Maverick):
status: Triaged → Fix Released
Changed in irqbalance (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.