Ubuntu

modprobe requires .conf filenames since Jaunty

Reported by Rolf Leggewie on 2009-03-11
48
This bug affects 6 people
Affects Status Importance Assigned to Milestone
acpi-support (Ubuntu)
Medium
Unassigned
Jaunty
Medium
Unassigned
Karmic
Medium
Unassigned
Lucid
Undecided
Unassigned
alsa-driver (Ubuntu)
Undecided
Daniel T Chen
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
bluez (Ubuntu)
Medium
Scott James Remnant (Canonical)
Jaunty
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)
Lucid
Undecided
Unassigned
irda-utils (Ubuntu)
Medium
Oliver Grawert
Jaunty
Medium
Oliver Grawert
Karmic
Medium
Oliver Grawert
Lucid
Undecided
Unassigned
isdnutils (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
ndiswrapper (Ubuntu)
Low
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
nvidia-kernel-common (Ubuntu)
Undecided
Unassigned
Jaunty
Undecided
Unassigned
Karmic
Undecided
Unassigned
Lucid
Undecided
Unassigned
oss-compat (Ubuntu)
Medium
Daniel T Chen
Jaunty
Medium
Daniel T Chen
Karmic
Medium
Daniel T Chen
Lucid
Undecided
Unassigned
sane-backends (Ubuntu)
Medium
Scott James Remnant (Canonical)
Jaunty
Medium
Scott James Remnant (Canonical)
Karmic
Medium
Scott James Remnant (Canonical)
Lucid
Undecided
Unassigned

Bug Description

Binary package hint: irda-utils

$ grep conf /var/log/syslog|grep mod
Mar 11 11:36:35 X24 irattach: + WARNING: All config files need .conf: /etc/modprobe.d/blacklist-scanner, it will be ignored in a future release.
Mar 11 11:36:35 X24 irattach: + WARNING: All config files need .conf: /etc/modprobe.d/ibm_acpi.modprobe, it will be ignored in a future release.
Mar 11 11:36:35 X24 irattach: + WARNING: All config files need .conf: /etc/modprobe.d/irda-utils, it will be ignored in a future release.
Mar 11 11:36:35 X24 irattach: + WARNING: All config files need .conf: /etc/modprobe.d/oss-compat, it will be ignored in a future release.

The config files for modprobe need to be renamed.

Rolf Leggewie (r0lf) on 2009-03-11
Changed in irda-utils:
importance: Undecided → Low
status: New → Triaged
Changed in oss-compat:
importance: Undecided → Low
status: New → Triaged
importance: Low → Medium
Changed in irda-utils:
importance: Low → Medium
Changed in sane-backends:
importance: Undecided → Medium
status: New → Triaged
Changed in acpi-support:
importance: Undecided → Medium
status: New → Triaged
Rolf Leggewie (r0lf) wrote :

targetting for next release, the fix is straightforward

Changed in acpi-support:
milestone: none → jaunty-alpha-6
Steve Langasek (vorlon) wrote :

none of these files are from acpi-support.

Changed in acpi-support:
status: Triaged → Invalid
Rolf Leggewie (r0lf) wrote :

Steve, my computer seems to disagree with you

$ dpkg -S /etc/modprobe.d/ibm_acpi.modprobe
acpi-support: /etc/modprobe.d/ibm_acpi.modprobe

Changed in acpi-support:
status: Invalid → Triaged
Steve Langasek (vorlon) wrote :

Then you have a local or ancient version of acpi-support installed. This is not in the Ubuntu package.

Changed in acpi-support:
status: Triaged → Invalid
Steve Langasek (vorlon) wrote :

Ok, a bit of archaeology reveals that this conffile was present in dapper-feisty, and was never properly cleaned up on upgrades from what I can see. I've committed a fix for this, but don't intend to upload prior to alpha-6.

Changed in acpi-support:
milestone: jaunty-alpha-6 → none
status: Invalid → Fix Committed
Colin Watson (cjwatson) wrote :

Also:

WARNING: All config files need .conf: /etc/modprobe.d/bluez, it will be ignored in a future release.

Changed in bluez (Ubuntu):
importance: Undecided → Medium
status: New → Triaged

bluez-utils looks like a transitional package, I assume it failed to cleanup properly

blacklist-scanner looks like an old file too (it was /etc/modprobe.d/libsane before I removed it)

Changed in sane-backends (Ubuntu Jaunty):
assignee: nobody → scott
status: Triaged → Fix Committed
Changed in bluez (Ubuntu Jaunty):
assignee: nobody → scott
status: Triaged → Fix Committed

Daniel, could you look at oss-compat -- it looked to me like the same modprobe lines are already in our alsa-base package anyway - so I couldn't understand what it's for

Changed in irda-utils (Ubuntu Jaunty):
assignee: nobody → ogra
Changed in oss-compat (Ubuntu Jaunty):
assignee: nobody → crimsun
Daniel T Chen (crimsun) wrote :

oss-compat doesn't seem particularly useful for Ubuntu, actually. I can think of OSSv4 using it, but we don't ship that, either. Perhaps it's a candidate for not syncing from Debian?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package sane-backends - 1.0.19-23ubuntu7

---------------
sane-backends (1.0.19-23ubuntu7) jaunty; urgency=low

  * debian/libsane.preinst: Remove the old blacklist-scanner modprobe
    file. LP: #340873.

 -- Scott James Remnant <email address hidden> Wed, 25 Mar 2009 13:40:43 +0000

Changed in sane-backends:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package acpi-support - 0.121

---------------
acpi-support (0.121) jaunty; urgency=low

  * Remove /etc/modprobe.d/ibm_acpi.modprobe in case it's still present;
    this conffile was shipped in dapper and never cleaned up properly.
    LP: #340873.
  * Drop smartdimmer from Recommends; this was only needed for the sony
    brightness scripts, which are removed in favor of hal.

 -- Steve Langasek <email address hidden> Wed, 25 Mar 2009 09:53:30 -0700

Changed in acpi-support:
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

This bug was fixed in the upload of bluez 4.32-0ubuntu4. Changelog:

bluez (4.32-0ubuntu4) jaunty; urgency=low

  * debian/bluez-utils.preinst: Correct think-o. LP: #350393.

 -- Scott James Remnant <email address hidden> Wed, 01 Apr 2009 09:47:32 +0100

bluez (4.32-0ubuntu3) jaunty; urgency=low

  * debian/bluez-utils.preinst: Remove /etc/modprobe.d/bluez on upgrade

 -- Scott James Remnant <email address hidden> Wed, 25 Mar 2009 13:43:00 +0000

Changed in bluez (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Daniele Napolitano (dnax88) wrote :

I've made a patch for this issue and bug #340718.

Oliver Grawert (ogra) wrote :

@daniele, did you test this patch ? even though i got the bug assigned (because i did the last upload of this package during a merge), i dont own a single irda device to test it. if you can positively confirm it doesnt introduce any regressions i'm happy to upload it.

Steve Langasek (vorlon) wrote :

The irda-utils patch doesn't handle clean-up of the old conffile location, and it needs to.

Daniele Napolitano (dnax88) wrote :

Patch for debian/postrm:

--- postrm 2009-04-15 16:28:26.074874256 +0200
+++ postrm.orig 2009-04-15 16:28:11.658834448 +0200
@@ -5,7 +5,7 @@

 PACKAGE="irda-utils"
 MODULES_24="/etc/modutils/$PACKAGE"
-MODULES_26="/etc/modprobe.d/$PACKAGE"
+MODULES_26="/etc/modprobe.d/$PACKAGE.conf"
 CONFIG="/etc/default/$PACKAGE"

 if [ -f /usr/share/debconf/confmodule ]; then

Daniele Napolitano (dnax88) wrote :

New patch version of postinst that remove deprecated MAKEDEV script calls, remove old modprobe config file (if exist) and add ircomm-tty and irnet modules into modprobe.d config file.

This is a patch to debian/irda-utils.irda-setup.init that make this init script LSB compliant.

--- irda-utils.irda-setup.init.orig 2009-04-15 17:37:34.466836798 +0200
+++ irda-utils.irda-setup.init 2009-04-15 17:22:42.506836166 +0200
@@ -1,5 +1,14 @@
 #!/bin/bash

+### BEGIN INIT INFO
+# Provides: irda
+# Required-Start: $remote_fs
+# Required-Stop:
+# Default-Start: S
+# Default-Stop:
+# Short-Description: Infrared port setup
+### END INIT INFO
+
 . /etc/default/irda-utils

 test "$AUTOMATIC" = "true" || exit 0

Oliver Grawert (ogra) wrote :

you change a lot more than needed in your patch ... please change only the actually requested filename

Daniele Napolitano (dnax88) wrote :

Yes, because there is others bugs in this package that block post install script and generate errors.

In any case I've made a patch only for this bug.

Oliver Grawert (ogra) on 2009-04-20
Changed in irda-utils (Ubuntu Jaunty):
milestone: none → jaunty-updates
Franz Dietzmann (tdk-le) wrote :

Sorry for the noob-question, but could you tell me how to apply the patch on my machine?

Sergio Callegari (callegar) wrote :

Hi,

now that the patch is known, is there a fixed deb, at least in some ppa?

I also need to apply this patch, can someone post directions that a noob could follow? Thanks

David Stefan (digikal-addick) wrote :

yet another noob..
how to apply the patch?
need some response here

The real question is why the hell do you need to apply the patch yourself ????

Because the problem is preventing me from doing something right now, and
I really don't want to wait until the patch makes it down into the
repositories?

Baptiste Mille-Mathias wrote:
> The real question is why the hell do you need to apply the patch
> yourself ????
>
>

There is the command "patch", you'll find a short tutorial on it on http://www.linuxtutorialblog.com/post/introduction-using-diff-and-patch-tutorial .

The file you need to apply the patch to is /var/lib/dpkg/info/irda-utils.postinst
Or at least with patching this one the installation worked for me.

I just found out about this after I edited the script by hand...

David Stefan (digikal-addick) wrote :

how do i patch it when it's not there

/var/lib/dpkg/info/irda-utils.postinst: line 184: ./MAKEDEV: No such file or directory
/var/lib/dpkg/info/irda-utils.postinst: line 92: update-modules: command not found

?

Franz Dietzmann (tdk-le) wrote :

/var/lib/dpkg/info/irda-utils.postinst is the file you need to patch. It is there.

Franz Dietzmann (tdk-le) wrote :

I am wondering though: The patch Daniele provided in Comment 18 solved the problem in irda-utils for me, so far everything works flawlessly. It's been more then 5 weeks since then, why is this fix not released?

David Stefan (digikal-addick) wrote :

it's not there.. unfortunately

Daniele Napolitano (dnax88) wrote :

Franz: Ask it to Oliver Grawert, this bug is assigned to he and it's planned to jaunty-updates...

I applied the patch from post 18, and this is my output now on "sudo apt-get install irda-utils"

Reading package lists...
Building dependency tree...
Reading state information...
irda-utils is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up irda-utils (0.9.18-8.1ubuntu1) ...

dpkg (subprocess): unable to execute post-installation script: Exec format error

dpkg: error processing irda-utils (--configure):

 subprocess post-installation script returned error exit status 2

Errors were encountered while processing:

 irda-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)

Franz Dietzmann got it fixed, so I'm not sure what I'm doing wrong here.

Franz Dietzmann (tdk-le) wrote :

well, as I said, I just applied the patch manually (adding the +++-lines and removing the --- lines from the irda-utils.postinst)
I have no knowledge of all this whatsoever, sorry. Did you check for typos?

Arian Kuschki (arian-kuschki) wrote :

Hi,
I applied this the patch postinst2.patch (744 bytes, text/plain) from Daniele Napolitano and on retrying to install irda-utils I get:

1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up irda-utils (0.9.18-8.1ubuntu1) ...
/var/lib/dpkg/info/irda-utils.postinst: line 185: ./MAKEDEV: No such file or directory
/var/lib/dpkg/info/irda-utils.postinst: line 93: update-modules: command not found
dpkg: error processing irda-utils (--configure):
 subprocess post-installation script returned error exit status 127
Errors were encountered while processing:
 irda-utils
E: Sub-process /usr/bin/dpkg returned an error code (1)

Franz Dietzmann (tdk-le) wrote :

Arian: Use the patch before that (postinst.patch (1.2 KiB, text/plain)) in comment 18.

Arian Kuschki (arian-kuschki) wrote :

Thank you Franz,
it worked. (David Stefan I think this might work for you too)
I received the warning below but the installation seems to have been successful:
update-rc.d: warning: /etc/init.d/irda-setup missing LSB information
update-rc.d: see <http://wiki.debian.org/LSBInitScripts>

Thanks all
Arian

Steve Langasek (vorlon) wrote :

The "fix" is not released because, as written in <https://bugs.launchpad.net/ubuntu/+source/irda-utils/+bug/340873/comments/16>, it is not a correct fix.

I don't understand why this bug is attracting so much attention, though. My understanding is that modutils gives a *warning* about old config file names, but still processes them in jaunty - is that not accurate?

Franz Dietzmann (tdk-le) wrote :

The irda-utils package does not install at the moment at all (https://bugs.launchpad.net/ubuntu/+source/irda-utils/+bug/340718). There is a patch in the comments that seems to "fix" this (even if it doesn't, I don't know about these things), or at least gets the package installed again and working. So I think the interest is understandable, if people need to use their IR-ports.

Steve Langasek (vorlon) wrote :

I'm marking this bug as wontfix for jaunty, because it is not warranted to SRU since *this* bug doesn't break anything. Bug #340718 is definitely a candidate for SRU. Both bugs should get fixed first in karmic.

Changed in irda-utils (Ubuntu Jaunty):
status: Triaged → Won't Fix
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package irda-utils - 0.9.18-8.1ubuntu2

---------------
irda-utils (0.9.18-8.1ubuntu2) karmic; urgency=low

  [ Daniele Napolitano ]
  * debian/postinst: remove call to update-modules, which was deprecated long
    ago and is no longer shipped by module-init-tools. LP: #340718.
  * debian/postinst: invoke MAKEDEV, not /dev/MAKEDEV, since the latter is
    obsolete.

  [ Steve Langasek ]
  * debian/postinst, debian/postrm: rename /etc/modprobe.d/irda-utils to
    /etc/modprobe.d/irda-utils.conf, as required by current
    module-init-tools. LP: #340873.
  * debian/preinst: handle migrating the modprobe.d filename on upgrade.
  * debian/preinst: remove config file for Linux 2.4 kernels on upgrade.
  * debian/postinst, debian/postrm: drop obsolete handling of modutils.

 -- Steve Langasek <email address hidden> Tue, 26 May 2009 10:53:59 +0000

Changed in irda-utils (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) on 2009-06-01
Changed in oss-compat (Ubuntu Jaunty):
status: Triaged → Won't Fix
Rolf Leggewie (r0lf) wrote :

Another candidate is ndiswrapper:

WARNING: All config files need .conf: /etc/modprobe.d/ndiswrapper, it will be ignored in a future release.

summary: - [Jaunty] modprobe requires .conf filenames now
+ modprobe requires .conf filenames since Jaunty
Changed in ndiswrapper (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Rolf Leggewie (r0lf) on 2010-02-21
Changed in ndiswrapper (Ubuntu):
milestone: none → ubuntu-10.04-beta-1
Rolf Leggewie (r0lf) wrote :

more candidates in lucid:
WARNING: All config files need .conf: /etc/modprobe.d/nvidia-kernel-nkc, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-oss, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-modem, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/ipw3945, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-scanner, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/ibm_acpi.modprobe, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/fuse, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/libsane, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-capiutils, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/lrm-video, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/libpisock9, it will be ignored in a future release.

Rolf Leggewie (r0lf) wrote :

please disregard my last comment. I did not realize this was coming from not-yet updated hardy package. I'm currently going hardy->lucid.

Changed in nvidia-kernel-common (Ubuntu):
status: New → Invalid
Changed in nvidia-kernel-common (Ubuntu Jaunty):
status: New → Invalid
Changed in nvidia-kernel-common (Ubuntu Karmic):
status: New → Invalid
Rolf Leggewie (r0lf) on 2010-05-01
Changed in ndiswrapper (Ubuntu Jaunty):
status: New → Won't Fix
Rolf Leggewie (r0lf) wrote :

Here is the list of conf files that apparently haven't been properly fixed in lucid, yet.

Rolf Leggewie (r0lf) wrote :

$ sudo modprobe mtdblock
WARNING: All config files need .conf: /etc/modprobe.d/alsa-base, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-modem, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/ibm_acpi.modprobe, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/blacklist-capiutils, it will be ignored in a future release.
WARNING: All config files need .conf: /etc/modprobe.d/libpisock9, it will be ignored in a future release.

Changed in alsa-driver (Ubuntu Jaunty):
status: New → Won't Fix
Changed in alsa-driver (Ubuntu Karmic):
status: New → Won't Fix
Steve Langasek (vorlon) wrote :

Gar. What's really great is alsa-base had the migration code for jaunty, and it was dropped afterwards. However, that does mean it's possible to rescue the patches in question from bzr - and forward them to Debian this time, since the same transition applies there!

Changed in alsa-driver (Ubuntu Jaunty):
status: Won't Fix → Fix Released
Rolf Leggewie (r0lf) wrote :

Thanks, Steve

Daniel T Chen (crimsun) on 2010-09-03
Changed in alsa-driver (Ubuntu):
assignee: nobody → Daniel T Chen (crimsun)
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package alsa-driver - 1.0.23+dfsg-1ubuntu3

---------------
alsa-driver (1.0.23+dfsg-1ubuntu3) maverick; urgency=low

  * debian/alsa-base.postinst:
    debian/linux-sound-base.postinst:
    - Readd accidentally-removed migration for newer module-init-tools
      (LP: #340873)
 -- Daniel T Chen <email address hidden> Thu, 02 Sep 2010 19:43:30 -0400

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
Steve Langasek (vorlon) wrote :

+ if dpkg --compare-versions "$2" lt "1.0.18.dfsg-1ubuntu5"; then

This cleanup needs to be handled on upgrade from the *lucid* version of the package, as well, not just the hardy version; so the version number needs to be bumped.

Also, you didn't include the corresponding snippets from the preinst scripts, so the ".dpkg-bak" handling is currently a non-sequitur.

So reopening the maverick task here, unfortunately.

(And opening a task for lucid - I think we want this fixed in SRU for the LTS, as well.)

Changed in alsa-driver (Ubuntu):
status: Fix Released → Triaged
Changed in acpi-support (Ubuntu Lucid):
status: New → Fix Released
Steve Langasek (vorlon) on 2010-09-03
Changed in bluez (Ubuntu Lucid):
status: New → Fix Released
Changed in irda-utils (Ubuntu Lucid):
status: New → Fix Released
Steve Langasek (vorlon) on 2010-09-03
Changed in nvidia-kernel-common (Ubuntu Lucid):
status: New → Invalid
Changed in oss-compat (Ubuntu Lucid):
status: New → Triaged
Changed in alsa-driver (Ubuntu Lucid):
status: New → Triaged
Changed in sane-backends (Ubuntu Lucid):
status: New → Fix Released
Steve Langasek (vorlon) on 2010-09-03
Changed in isdnutils (Ubuntu Jaunty):
status: New → Won't Fix
Daniel T Chen (crimsun) on 2010-09-04
Changed in alsa-driver (Ubuntu):
status: Triaged → Fix Committed
Colin Watson (cjwatson) wrote :

alsa-driver (1.0.23+dfsg-1ubuntu4) maverick; urgency=low

  * debian/alsa-base.preinst:
    debian/alsa-base.postinst:
    debian/linux-sound-base.postinst:
    - Handle upgrades from lucid, too. Thanks, Steve Langasek!
      (LP: #340873)

 -- Daniel T Chen <email address hidden> Fri, 03 Sep 2010 17:55:13 -0400

Changed in alsa-driver (Ubuntu):
status: Fix Committed → Fix Released
Rolf Leggewie (r0lf) on 2010-10-30
Changed in isdnutils (Ubuntu Karmic):
status: New → Won't Fix
Rolf Leggewie (r0lf) on 2011-10-02
Changed in oss-compat (Ubuntu Karmic):
status: Triaged → Won't Fix
Changed in ndiswrapper (Ubuntu Karmic):
status: New → Won't Fix
Stephen Kitt (steve-sk2) wrote :

This was fixed in version 0.0.4+nmu3 of oss-compat, which is in Lucid.

Changed in oss-compat (Ubuntu Lucid):
status: Triaged → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package oss-compat - 1

---------------
oss-compat (1) unstable; urgency=low

  * Switch to single-component versions.
  * Declare the package is "Multi-Arch: foreign", thanks to Steve Langasek
    for the hint! (Closes: #651335.)
  * Make /etc/modprobe.d/oss-compat.conf a file, handling the various
    upgrade cases, and only removing it on purge. (Closes: #649507.)
    (LP: #340873)
  * Add kmod as an alternative dependency to avoid preventing
    module-init-tools' removal.

 -- Stephen Kitt <email address hidden> Sun, 15 Jan 2012 14:06:16 +0100

Changed in oss-compat (Ubuntu):
status: Triaged → Fix Released
Steve Langasek (vorlon) wrote :

I'm not sure why this bug is still open, but the current isdnutils package does use a filename with a proper .conf extension - so closing the report.

Changed in isdnutils (Ubuntu):
status: New → Fix Released
Julian Andres Klode (juliank) wrote :

ndiswrapper now installs correct files on all systems.

ndiswrapper (1.59-2) unstable; urgency=medium

  * Only support modprobe.d (Closes: #724890)
  * debian/control: Set Standards-Version to 3.9.5
  * Recommend ndiswrapper-dkms in Ubuntu builds as well
  * kernel-3.14.patch: Add support for kernel 3.14

 -- Julian Andres Klode <email address hidden> Wed, 19 Mar 2014 16:08:06 +0100

Changed in ndiswrapper (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers