declares unnecessary dependency on libmysqlclient15off

Bug #73098 reported by Reinhard Tartler
2
Affects Status Importance Assigned to Milestone
ircii-pana (Ubuntu)
Fix Released
Undecided
StefanPotyra

Bug Description

it also has an unversioned suggest on libmysqlclient15off.
compare with: http://packages.ubuntu.com/dapper/net/bitchx,
https://lists.ubuntu.com/archives/ubuntu-motu/2006-November/000968.html

this bug doesn't exist in debian.

Revision history for this message
Reinhard Tartler (siretart) wrote :

Looks like a broken merge anyway:
http://changelogs.ubuntu.com/changelogs/pool/universe/i/ircii-pana/ircii-pana_1.1-4/changelog

please remerge with additional care.

Revision history for this message
Daniel T Chen (crimsun) wrote :

No, the source package in Debian Sid build-depends on libmysqlclient15-dev, and the bitchx binary package Suggests libmysqlclient15off. I doubt the Debian Sid source package is dead wrong (see the changelog entry for 1:1.0-0c17-2). There's nothing wrong with this merge. Look very carefully at http://ftp.debian.org/debian/pool/main/i/ircii-pana/ircii-pana_1.1-4.diff.gz .

Changed in ircii-pana:
status: Unconfirmed → Rejected
Revision history for this message
Daniel T Chen (crimsun) wrote :

Apologies for jumping the gun. Reopening. The Suggests needs to be versioned.

Changed in ircii-pana:
status: Rejected → Confirmed
Revision history for this message
StefanPotyra (sistpoty) wrote :

erm... the suggests is wrong in the first place: bitchx gets a dependency on libmysqlclient15off via ${shlibs:Depends} and has an additional suggests to it.

The cure to not have a dependency to libmysqlclient15off would be to move the plugin to a different binary package.

Revision history for this message
Reinhard Tartler (siretart) wrote :

stefan: sorry but no. Compare with http://packages.debian.org/unstable/net/bitchx

Revision history for this message
StefanPotyra (sistpoty) wrote :

After a closer look, the debian package avoids the strict dependency by overriding it via shlibs.local.

Revision history for this message
StefanPotyra (sistpoty) wrote :

I'll take care for remerging. And I'll stay with the shlibs hack (to avoid unnecessary divergence).

Changed in ircii-pana:
assignee: nobody → sistpoty
status: Confirmed → In Progress
Revision history for this message
StefanPotyra (sistpoty) wrote :

Changes:
 ircii-pana (1:1.1-4ubuntu2) edgy; urgency=low
 .
   * Remerge with debian's 1:1.1-4, imported:
     + Build-Depend on newer debhelper version.
     + Add a versioned suggests to libmysqlclient15off.
     + Add ${misc:Depends} to dependencies.
     + Update shlibs.local to match libmysqlclient library version. That
       way libmysqlclient15off, which is needed only for one plugin will
       not be in the dependencies any longer (closes: ubuntu #73098).
     + Update font path of bitchx.dirs.
     + Update font path in debian/rules.
   * Remaining change in ubuntu is:
     + Use default server irc.ubuntu.com (see entry directly below).

Changed in ircii-pana:
status: In Progress → Fix Committed
Revision history for this message
StefanPotyra (sistpoty) wrote :

D'oh... it's feisty :(.

Revision history for this message
StefanPotyra (sistpoty) wrote :

Changes:
 ircii-pana (1:1.1-4ubuntu2) feisty; urgency=low
 .
   * Remerge with debian's 1:1.1-4, imported:
     + Build-Depend on newer debhelper version.
     + Add a versioned suggests to libmysqlclient15off.
     + Add ${misc:Depends} to dependencies.
     + Update shlibs.local to match libmysqlclient library version. That
       way libmysqlclient15off, which is needed only for one plugin will
       not be in the dependencies any longer (closes: ubuntu #73098).
     + Update font path of bitchx.dirs.
     + Update font path in debian/rules.
   * Remaining change in ubuntu is:
     + Use default server irc.ubuntu.com (see entry directly below).
Files:
 0ce0f9b7c12540e8aa3e89dee0a3cbdf 850 net optional ircii-pana_1.1-4ubuntu2.dsc
 efe28b859ccef4161e5a7f27a8df28a7 55621 net optional ircii-pana_1.1-4ubuntu2.diff.gz

Revision history for this message
Reinhard Tartler (siretart) wrote : Re: [Bug 73098] Re: declares unnecessary dependency on libmysqlclient15off

> D'oh... it's feisty :(.
anyway, thank you very much for your work. Do you think it makes sense
to get this update to edgy-updates?

Revision history for this message
StefanPotyra (sistpoty) wrote :

hm... given that there has been only one bug filed due to the libmysqlclient dependency (which isn't all wrong in edgy, since the hard dependency is versioned, so the suggests is just useless) and no bug filed for the fonts yet, I don't think it the changes have such a high impact to justify an upload to -updates.

OTOH I must admit, that I'm not using bitchx myself, so I may be underrating this issue.

How about not targetting this for edgy-updates right now and in case new bugs come in considering it again?

StefanPotyra (sistpoty)
Changed in ircii-pana:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers