magic function whos not working in ipython

Bug #177253 reported by Timmie on 2007-12-18
Affects Status Importance Assigned to Milestone
ipython (Ubuntu)

Bug Description

Binary package hint: ipython

the magic function %whos always gives this strange error:

<type 'exceptions.AttributeError'> Traceback (most recent call last)

myscripts/<ipython console> in <module>()

/var/lib/python-support/python2.5/IPython/ in ipmagic(self, arg_s)
    962 else:
    963 magic_args = self.var_expand(magic_args,1)
--> 964 return fn(magic_args)
    966 def ipalias(self,arg_s):

/var/lib/python-support/python2.5/IPython/ in magic_whos(self, parameter_s)
    989 array_type = None
    990 else:
--> 991 array_type = Numeric.ArrayType.__name__
    993 # Find all variable names and types so we can figure out column sizes

<type 'exceptions.AttributeError'>: 'module' object has no attribute 'ArrayType'

on Windows this works.

Luca Falavigna (dktrkranz) wrote :

Thank you for your bug report.
Could you please indicate which version of ipython you are using and the steps to reproduce this bug?

Changed in ipython:
status: New → Incomplete
Timmie (timmie) wrote :


ii ipython 0.8.1-1 enhanced interactive Python shell

I run a script with %run and then did %whos.

Luca Falavigna (dktrkranz) wrote :

I get "Interactive namespace is empty." but no errors.

Timmie (timmie) wrote :

I set a post to ipython users.
Maybe they can help:
Re: matplotlib, ipython and ubuntu

Timmie (timmie) wrote :

please mark this as a solved issue. The problem was caused by conflicting versions of the Numeric modeule on my system:

matplotlib, ipython and ubuntu -

Timmie (timmie) wrote :

See my last comment. This has been solved and was a local issue. Nothing to do with Ubuntu and the package.

Changed in ipython:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers