presense of kvm-ipxe slows down kvm non-network boot

Bug #921230 reported by Scott Moser on 2012-01-24
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ipxe (Ubuntu)
Wishlist
Unassigned

Bug Description

$ kvm -boot order=c /tmp/disk.img -curses

you'll see somthing like:
|
| SeaBIOS (version pre-0.6.3-20111117_190135-rothera)
|
| iPXE (http://ipxe.org) 00:03.0 C900 PCI2.10 PnP PMM+17FC94C0+17F894C0 C900
| Press Ctrl-B to configure iPXE (PCI 00:03.0)...

That sits there for 2 to 3 seconds (per NIC), and slows boot down
by that much.

You can work around this by:
$ ( rm -Rf x && mkdir x && cd x && ln -sf /usr/share/qemu-kvm/* . && rm pxe* )
$ kvm -boot order=c -L x -curses

which basically just makes kvm think there are no pxe boot roms, which would be found in /usr/share/qemu-kvm/ as provided by kvm-ipxe.

I'd like some way to skip that configure step, since I am explicitly not booting from pxe.

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: kvm-ipxe 1.0.0+git-2.149b50-1ubuntu4
ProcVersionSignature: Ubuntu 3.2.0-10.17-generic 3.2.1
Uname: Linux 3.2.0-10-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
Date: Tue Jan 24 16:38:01 2012
Dependencies:

EcryptfsInUse: Yes
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
PackageArchitecture: all
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ipxe
UpgradeStatus: Upgraded to precise on 2011-11-07 (78 days ago)

Related branches

Scott Moser (smoser) on 2012-01-24
description: updated
Changed in ipxe (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
Serge Hallyn (serge-hallyn) wrote :

Looks like this is done in assembly by ipxe at

./arch/i386/prefix/romprefix.S

Do you have any suggestion for how to best change this? We could just set ROM_BANNER_TIMEOUT to 0 in our builds, then but users could never hit ctrl-b. Not that I'm convined they ever will. We could devide the timeout by 3 to make it more tolerable.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ipxe - 1.0.0+git-3.55f6c88-0ubuntu3

---------------
ipxe (1.0.0+git-3.55f6c88-0ubuntu3) quantal; urgency=low

  [ Serge Hallyn ]
  * debian/patches/rom-set-banner-timeout-0.diff: set rom banner timeout
    to 0. (LP: #921230)

  [ Stefan Bader ]
  * Modify the ROM names in of the allqemu target to use 8086100e instead
    of e1000_82540 and ne instead of ne2k_isa (LP: #948323)
 -- Serge Hallyn <email address hidden> Mon, 28 May 2012 11:57:48 -0500

Changed in ipxe (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers