Please offer a grub-ipxe.deb package

Bug #814038 reported by Dave Walker on 2011-07-21
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ipxe (Debian)
Fix Released
Unknown
ipxe (Ubuntu)
Low
Ben Howard

Bug Description

Reproduced from Debian bug:
"
Use case: a user installs grub-ipxe, reboots, gets a new grub entry to
"PXE - Network boot", selects it, and netboots his computer.

Proposed implementation:
 * Put ipxe.lkrn to /boot
 * Use /etc/grub.d/20_memtest86+ as a template for a new grub hook
   in /etc/grub.d/grub-ipxe
 * Call update-grub on grub-gpxe.postinst
"

Related branches

Dave Walker (davewalker) on 2011-07-21
Changed in ipxe (Ubuntu):
importance: Undecided → Low
status: New → Triaged
Dave Walker (davewalker) on 2011-07-23
tags: added: server-o-rs
Ben Howard (utlemming) on 2011-08-05
Changed in ipxe (Ubuntu):
assignee: nobody → Ben Howard (utlemming)
Ben Howard (utlemming) wrote :

The current version of lp:ubuntu/ipxe won't compile due to an infinite loop around linuxprefix.S. There is an upstream Debian version that lacks the file; merge request prepared.

Ben Howard (utlemming) wrote :

LP: #821725 has been filed against ipxe not building. After talking with Dave, a patch was prepared and is pending approval.

Changed in ipxe (Debian):
status: Unknown → New
Ben Howard (utlemming) on 2011-08-19
Changed in ipxe (Ubuntu):
status: Triaged → Fix Released
status: Fix Released → Triaged
Ben Howard (utlemming) wrote :

Committed fix, pending merge approval.

Changed in ipxe (Ubuntu):
status: Triaged → Fix Committed
Ben Howard (utlemming) on 2011-08-22
Changed in ipxe (Ubuntu):
status: Fix Committed → In Progress
Dave Walker (davewalker) on 2011-09-03
Changed in ipxe (Ubuntu):
milestone: none → ubuntu-11.10-beta-2
Marc Cluet (lynxman) wrote :

Tested against latest Oneiric, patch works as intended

Dave Walker (davewalker) on 2011-09-23
Changed in ipxe (Ubuntu):
milestone: ubuntu-11.10-beta-2 → ubuntu-11.10
Dave Walker (davewalker) wrote :

I'm really pretty nervous about adding this to Oneiric at this stage, simply because it touches grub. It wouldn't seem to be a release blocker, so I'm suggested we defer it to P-series.

Is that a fair comment?

Thanks.

tags: removed: server-o-rs
Dave Walker (davewalker) on 2011-10-17
Changed in ipxe (Ubuntu):
milestone: ubuntu-11.10 → precise-alpha-1
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ipxe - 1.0.0+git-2.149b50-1ubuntu2

---------------
ipxe (1.0.0+git-2.149b50-1ubuntu2) precise; urgency=low

  * Provide a new binary package, grub-ipxe - for ipxe usage via grub.
    - LP: #814038, Closes #626238
 -- Ben Howard <email address hidden> Thu, 25 Aug 2011 11:03:52 -0600

Changed in ipxe (Ubuntu):
status: In Progress → Fix Released
Changed in ipxe (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.