iptraf stop showes eth0/eth1 interface

Bug #568164 reported by Yucong Sun on 2010-04-21
66
This bug affects 12 people
Affects Status Importance Assigned to Milestone
iptraf (Fedora)
Fix Released
Low
iptraf (Ubuntu)
Undecided
Yucong Sun
Lucid
Undecided
Yucong Sun
Maverick
Undecided
Unassigned
Natty
Undecided
Yucong Sun
Oneiric
Undecided
Yucong Sun

Bug Description

TEST CASE:
1 use a system with two network interfaces (not sure if that is actually needed to trigger the bug, one may be enough)
2 run "sudo iptraf"
3 select "Ip trafic monitor" from the menu
4 verify that only "all interfaces" and "lo" show up
5 install the version from -proposed
6 repeat 2,3
7 verify that this time something like eth0, wlan0 etc appear

Binary package hint: iptraf

after upgrade from karmic to lucid, the IPtraf stops showes me eth0/eth1 interface, I can see them from "all" but the ability to watch specifiliy for an interface is lost.

iptraf -i eth0 works fine otherwise.

iptraf -u doesn't show it either.

Description of problem:

iptraf does not list the ethernet nic (eth0 in my case).

Version-Release number of selected component (if applicable):

How reproducible:

Always

Steps to Reproduce:
1. su -
2. iptraf
3. ip traffic monitor

Actual results:

Lists
 All interfaces
 lo

Expected results:
 All interfaces
 eth0
 lo

Additional info:

Just discovered that it does not list my wifi nic either.

strange I cannot reproduce it.

ip traffic monitor does not exist

try ifconfig eth0 up and than run again iptraf

same results, the nic is up and configured. it also happens with wlan0.

ip traffic monitor i mean > run iptraf, select ip traffic monitor (m), select interface (list appears, does not show eth0 nor wlan0)

[root@movix ~]# uname -r
2.6.31.6-145.fc12.x86_64
[root@movix ~]# rpm -q iptraf
iptraf-3.0.1-8.fc12.x86_64
[root@movix ~]# ifconfig eth0
eth0 Link encap:Ethernet HWaddr 00:1B:38:72:A6:06
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:18

noticed its just a listing problem, when packets goes through the interface, iptraf shows the name of the interface correctly (eth0, wlan0).

I cannot reproduce even on x86_64. I have only newer kernel.

[root@nec-em18 ~]# uname -r
2.6.31.6-162.fc12.x86_64
[root@nec-em18 ~]# rpm -q iptraf
iptraf-3.0.1-8.fc12.x86_64
[root@nec-em18 ~]# ifconfig | egrep "eth|lo"
eth0 Link encap:Ethernet HWadr 00:16:17:55:47:C0
eth1 Link encap:Ethernet HWadr 00:16:17:55:47:C1
eth2 Link encap:Ethernet HWadr 00:04:23:C0:07:DE
lo Link encap:loop back

Created attachment 377538
iptraf not listing wlan0, nor eth0

Just to make it graphic.

update your kernel. This should help. I have same issue with 2.6.31.5-127.fc12.x86_64

(In reply to comment #5)
> update your kernel. This should help. I have same issue with
> 2.6.31.5-127.fc12.x86_64

Still, with

# uname -r
2.6.31.6-166.fc12.x86_64

same results :(

send me your ifconfig -a

g# ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1B:38:72:A6:06
          UP BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
          Interrupt:18

lo Link encap:Local Loopback
          inet addr:127.0.0.1 Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING MTU:16436 Metric:1
          RX packets:23 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:1867 (1.8 KiB) TX bytes:1867 (1.8 KiB)

vboxnet0 Link encap:Ethernet HWaddr 0A:00:27:00:00:00
          BROADCAST MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

virbr0 Link encap:Ethernet HWaddr BA:82:D9:17:63:72
          inet addr:192.168.122.1 Bcast:192.168.122.255 Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:17 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 b) TX bytes:3584 (3.5 KiB)

wlan0 Link encap:Ethernet HWaddr 00:1E:4C:6B:DB:7E
          inet addr:200.109.190.122 Bcast:200.109.191.255 Mask:255.255.224.0
          inet6 addr: fe80::21e:4cff:fe6b:db7e/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
          RX packets:395669 errors:0 dropped:0 overruns:0 frame:0
          TX packets:364443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:234455729 (223.5 MiB) TX bytes:37416118 (35.6 MiB)

wmaster0 Link encap:UNSPEC HWaddr 00-1E-4C-6B-DB-7E-80-3E-00-00-00-00-00-00-00-00
          UP RUNNING MTU:0 Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

I have the same problem as described after upgrading from F11 to F12, kernel 2.6.31.9-174.fc12.x86_64. I've not tested it, but it's can be due to using NetworkManager?

(In reply to comment #9)
> I have the same problem as described after upgrading from F11 to F12, kernel
> 2.6.31.9-174.fc12.x86_64. I've not tested it, but it's can be due to using
> NetworkManager?

I dont think so, however i tested stoping NetworkManager, manually configuring my Nic eth0 and still getting the same results.

$ uname -r
2.6.31.9-174.fc12.x86_64

NM should not interfere with iptraf operations.

Any news, always the same using the kernel 2.6.31.12-174.2.3.fc12.x86_64 and iptraf-3.0.1-8.fc12.x86_64.

No news, still same behaviour:

[gomix@movix ~]$ uname -r
2.6.32.9-70.fc12.x86_64
[gomix@movix ~]$ iptraf -v

IPTraf Version 3.0.1
Copyright (c) Gerard Paul Java 1997-2004

I've made a fork. If you have a time try it compile and run it. If this not work try to use *iptraf -u* this should help you.

https://fedorahosted.org/releases/i/p/iptraf-ng/iptraf-ng-1.0.1.tar.gz

I've problem with compiling this code, see:

make all-recursive
make[1]: Entering directory `/home/honza/tmp/wq/iptraf-ng-1.0.1'
Making all in support
make[2]: Entering directory `/home/honza/tmp/wq/iptraf-ng-1.0.1/support'
/bin/sh ../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I.. -Wall -Werror -std=gnu99 -pedantic -g -O2 -MT libtextbox_la-listbox.lo -MD -MP -MF .deps/libtextbox_la-listbox.Tpo -c -o libtextbox_la-listbox.lo `test -f 'listbox.c' || echo './'`listbox.c
libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -Wall -Werror -std=gnu99 -pedantic -g -O2 -MT libtextbox_la-listbox.lo -MD -MP -MF .deps/libtextbox_la-listbox.Tpo -c listbox.c -fPIC -DPIC -o .libs/libtextbox_la-listbox.o
cc1: warnings being treated as errors
listbox.c: In function ‘tx_operate_listbox’:
listbox.c:108: error: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’
listbox.c:108: error: format ‘%d’ expects type ‘int’, but argument 4 has type ‘size_t’
make[2]: *** [libtextbox_la-listbox.lo] Error 1
make[2]: Leaving directory `/home/honza/tmp/wq/iptraf-ng-1.0.1/support'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/honza/tmp/wq/iptraf-ng-1.0.1'
make: *** [all] Error 2

hmmm, morning better than evening. If you have a time join <email address hidden>. We can find some solution.

Created attachment 400824
0001-fix-strcpy-overlap-memory.patch

I have a good news everyone. I found a problem in source code why is not NIC listed. Thanks to Jan. Patch is attached if you want to look and here you have a build: http://koji.fedoraproject.org/koji/taskinfo?taskID=2059230

nobody wants to test it?

iptraf-3.0.1-10.fc12 has been submitted as an update for Fedora 12.
http://admin.fedoraproject.org/updates/iptraf-3.0.1-10.fc12

iptraf-3.0.1-10.fc13 has been submitted as an update for Fedora 13.
http://admin.fedoraproject.org/updates/iptraf-3.0.1-10.fc13

With iptraf-3.0.1-10.fc12 I could see now all network interfaces: eth0, wlan0, lo etc. So bug is fixed. Many thanks!

:) i'll test it asap

Confirmed, the bug is fixed in my F12 x86_64 , :D

iptraf-3.0.1-10.fc13 has been pushed to the Fedora 13 stable repository. If problems still persist, please make note of it in this bug report.

iptraf-3.0.1-10.fc12 has been pushed to the Fedora 12 testing repository. If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with
 su -c 'yum --enablerepo=updates-testing update iptraf'. You can provide feedback for this update here: http://admin.fedoraproject.org/updates/iptraf-3.0.1-10.fc12

iptraf-3.0.1-10.fc12 has been pushed to the Fedora 12 stable repository. If problems still persist, please make note of it in this bug report.

Yucong Sun (sunyucong) wrote :

My eth0 have only 1 ip address, but my eth1 having mutiple, 3.0.6-3.0.7 upgrade broke the ability so I am guessing it is related to vlan stuff? but I have no vlan interface at all.

norbert (globtroter) wrote :

Actually none of the interfaces except loopback shows up in "select interface" box after after selecting "detailed interface statistics" or any other option. But if you select "lan station monitor" -> "all interfaces" you can actually observe traffic on other interfaces (e.g. wlan0, eth0). iptraf -d wlan0 also works.

Luca Aluffi (aluffilu) wrote :

It happens to me too, but only in "real" ubuntu. The one which runs under Virtualbox works fine.

The only noticeable difference (other than one system is real and the other virtualized) betwees the twos, is that the faulty one is 64 bits. I don't know if this matters.

Same problem here.
Lucid show eth1 in the x86 version, but doesn't display any data/traffic. The 64bit version doesn't show eth1 at all.

JAB van Ree (javanree) wrote :

I can also confirm this bug; in none of the iptraf dialogs interface eth0 can be selected as device, it only shows lo
Using Lucid AMD64

Radosław Łoboda (whitep0wer) wrote :

Confirmed on Ubuntu 10.10 Maverick x86_64. Eth devices do not show up on iptraf interface lists. Choosing "All interfaces" where possible shows all the traffic, though.

Version: iptraf-3.0.0-7

# lsb_release -dc
Description: Ubuntu 10.10
Codename: maverick

# uname -srvm
Linux 2.6.35-22-generic #35-Ubuntu SMP Sat Oct 16 20:45:36 UTC 2010 x86_64

# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether aa:aa:aa:aa:aa:aa brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether aa:aa:aa:aa:aa:aa brd ff:ff:ff:ff:ff:ff

Radosław Łoboda (whitep0wer) wrote :

Seems like Fedora guys have already coped with it:
https://bugzilla.redhat.com/show_bug.cgi?id=539740

tags: added: hw-specific
Changed in iptraf (Ubuntu):
status: New → Confirmed
gondim (gondim) wrote :

But they already fixed and we do not. :(

Radosław Łoboda (whitep0wer) wrote :

Okay, if nobody wants to take a look there, I'll post what these guys came up with.

It works, I tested it on my system.

Gil Disatnik (gil-disatnik) wrote :

It's simply crazy that this package doesn't work for over a year.

JAB van Ree (javanree) wrote :

When can we expect this to finally get fixed? A working patch has been available for 2 months now and still nothing happening. What's the point of an LTS release if nothing actually gets fixed :(

Yucong Sun (sunyucong) on 2011-04-21
Changed in iptraf (Ubuntu):
assignee: nobody → Yucong Sun (sunyucong)
status: Confirmed → In Progress
Michael Vogt (mvo) wrote :

I uplaoded this to lucid-proposed, maverick-proposed and natty-proposed now.

description: updated
Changed in iptraf (Ubuntu Maverick):
status: New → In Progress
Changed in iptraf (Ubuntu Lucid):
status: New → Incomplete
status: Incomplete → In Progress
Yucong Sun (sunyucong) on 2011-04-21
Changed in iptraf (Ubuntu Lucid):
assignee: nobody → Yucong Sun (sunyucong)

Accepted iptraf into lucid-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in iptraf (Ubuntu Lucid):
status: In Progress → Fix Committed
tags: added: verification-needed
Clint Byrum (clint-fewbar) wrote :

This needs the regression potential stated more clearly in the description before it hits -updates (though on reviewing the patch it appears quite small, which is why I've accepted it into -proposed).

Changed in iptraf (Ubuntu Maverick):
status: In Progress → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Accepted iptraf into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in iptraf (Ubuntu Natty):
status: In Progress → Fix Committed
Clint Byrum (clint-fewbar) wrote :

Accepted iptraf into natty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Hi Clint,

Should I update my existing branch or sumbit a new one?

Cheers.

On Mon, Apr 25, 2011 at 10:28 AM, Clint Byrum <email address hidden> wrote:
> This needs the regression potential stated more clearly in the
> description before it hits -updates (though on reviewing the patch it
> appears quite small, which is why I've accepted it into -proposed).
>
> ** Changed in: iptraf (Ubuntu Maverick)
>       Status: In Progress => Fix Committed
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/568164
>
> Title:
>  iptraf stop showes eth0/eth1 interface
>
> Status in “iptraf” package in Ubuntu:
>  Fix Committed
> Status in “iptraf” source package in Lucid:
>  Fix Committed
> Status in “iptraf” source package in Maverick:
>  Fix Committed
> Status in “iptraf” source package in Natty:
>  Fix Committed
> Status in “iptraf” package in Fedora:
>  Unknown
>
> Bug description:
>  TEST CASE:
>  1 use a system with two network interfaces (not sure if that is actually needed to trigger the bug, one may be enough)
>  2 run "sudo iptraf"
>  3 select "Ip trafic monitor" from the menu
>  4 verify that only "all interfaces" and "lo" show up
>  5 install the version from -proposed
>  6 repeat 2,3
>  7 verify that this time something like eth0, wlan0 etc appear
>
>  Binary package hint: iptraf
>
>  after upgrade from karmic to lucid, the IPtraf stops showes me
>  eth0/eth1 interface, I can see them from "all" but the ability to
>  watch specifiliy for an interface is lost.
>
>  iptraf -i eth0 works fine otherwise.
>
>  iptraf -u doesn't show it either.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/iptraf/+bug/568164/+subscribe
>

Clint Byrum (clint-fewbar) wrote :

Excerpts from Yucong Sun's message of Mon Apr 25 17:47:26 UTC 2011:
> Hi Clint,
>
> Should I update my existing branch or sumbit a new one?
>

Just update the bug report description here on Launchpad please. Your
upload is fine, but its important that we document the regression
potential so users understand how safe the update is to apply if they
click through to the bug report.

confirmed fix following the test case for Lucid

moving on to Maverick then Natty

reproduced error on maverick and natty

applied fix and it works on maverick and natty

v-done

tags: added: verification-done
removed: verification-needed
Yucong Sun (sunyucong) wrote :

To be precise, this is not HW specific, is because libc changed the way of handling overlapping memory strcpy, thus the problem

Yucong, you are correct. I am removing the tag to avoid any confusion.

tags: removed: hw-specific
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iptraf - 3.0.0-7ubuntu0.10.04

---------------
iptraf (3.0.0-7ubuntu0.10.04) lucid-proposed; urgency=low

  * src/iface.c: fix strcpy overlap memory problem. (LP: #568164)
 -- Yucong Sun <email address hidden> Wed, 20 Apr 2011 23:52:10 -0700

Changed in iptraf (Ubuntu Lucid):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iptraf - 3.0.0-7ubuntu0.10.10

---------------
iptraf (3.0.0-7ubuntu0.10.10) maverick-proposed; urgency=low

  * src/iface.c: fix strcpy overlap memory problem. (LP: #568164)
 -- Yucong Sun <email address hidden> Wed, 20 Apr 2011 23:52:10 -0700

Changed in iptraf (Ubuntu Maverick):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iptraf - 3.0.0-7ubuntu0.11.04

---------------
iptraf (3.0.0-7ubuntu0.11.04) natty-proposed; urgency=low

  * src/iface.c: fix strcpy overlap memory problem. (LP: #568164)
 -- Yucong Sun <email address hidden> Wed, 20 Apr 2011 23:52:10 -0700

Changed in iptraf (Ubuntu Natty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied to oneiric, too.

Changed in iptraf (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Changed in iptraf (Fedora):
importance: Unknown → Low
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.