Merge iptables 1.4.18-1.1 to fix missing dependency for perlipq

Bug #1228525 reported by Artur Rona on 2013-09-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
iptables (Ubuntu)
Undecided
Unassigned

Bug Description

Package perlipq has Build-Depends on iptables 1.4.18-1.1 which causes missing dependency, as we have only iptables 1.4.18-1.1. I have prepared a fake-merge that version to saucy because I do not want to force FFe of iptables 1.4.20 in the current saucy's phase.

iptables (1.4.18-1.1) unstable; urgency=low

  [ gregor herrmann ]
  * Fix "libipq.h includes non-existing linux/netfilter_ipv4/ip_queue.h":
    ship /usr/include/linux/netfilter_ipv4/ip_queue.h in iptables-dev;
    add Breaks on linux-libc-dev << 3.5
    (Closes: #707535)

  [ Dominic Hargreaves ]
  * Non-maintainer upload

 -- Dominic Hargreaves <email address hidden> Sat, 13 Jul 2013 16:09:01 +0100

More info:
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707406
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=707535

Related branches

Artur Rona (ari-tczew) on 2013-09-21
Changed in iptables (Ubuntu):
assignee: nobody → Artur Rona (ari-tczew)
status: New → In Progress
Artur Rona (ari-tczew) on 2013-09-21
Changed in iptables (Ubuntu):
assignee: Artur Rona (ari-tczew) → nobody
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iptables - 1.4.18-1.1ubuntu1

---------------
iptables (1.4.18-1.1ubuntu1) saucy; urgency=low

  * Merge changes from Debian, version 1.4.18-1.1 to fix FTBFS
    in package perlipq due to missing dependecy: (LP: #1228525)
    - debian/control
    - debian/iptables-dev.install
  * Fix unresolved @PACKAGE_VERSION@ in manpage. Cherry-pick from
    Debian, version 1.4.20-2: (LP: #1134554)
    - debian/iptables.install
    - debian/iptables.manpages
    - debian/nfnl_osf.8
    - 0201-iptables-xml_man_section.patch
  * Fix incorrectly calling setsockopt, cherry-pick: (LP: #1187177)
    - debian/patches/calling-setsockopt-incorrectly.patch

iptables (1.4.18-1.1) unstable; urgency=low

  [ gregor herrmann ]
  * Fix "libipq.h includes non-existing linux/netfilter_ipv4/ip_queue.h":
    ship /usr/include/linux/netfilter_ipv4/ip_queue.h in iptables-dev;
    add Breaks on linux-libc-dev << 3.5
    (Closes: #707535)

  [ Dominic Hargreaves ]
  * Non-maintainer upload
 -- Artur Rona <email address hidden> Fri, 20 Sep 2013 00:26:08 +0200

Changed in iptables (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers