package iptables-persistent 0.5.3ubuntu1 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1

Bug #967018 reported by Neil Wilson on 2012-03-28
42
This bug affects 6 people
Affects Status Importance Assigned to Milestone
iptables-persistent (Debian)
Fix Released
Unknown
iptables-persistent (Ubuntu)
Undecided
Unassigned

Bug Description

On upgrade from lucid to precise.

ProblemType: Package
DistroRelease: Ubuntu 12.04
Package: iptables-persistent 0.5.3ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-20.33-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Wed Mar 28 10:36:37 2012
ErrorMessage: ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha amd64 (20100224.1)
PackageArchitecture: all
SourcePackage: iptables-persistent
Title: package iptables-persistent 0.5.3ubuntu1 failed to install/upgrade: ErrorMessage: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: Upgraded to precise on 2012-03-28 (0 days ago)

Related branches

Neil Wilson (neil-aldur) wrote :
Changed in iptables-persistent (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in iptables-persistent (Ubuntu):
status: New → Confirmed
Neil Wilson (neil-aldur) on 2012-04-03
Changed in iptables-persistent (Ubuntu):
assignee: nobody → Neil Wilson (neil-aldur)
Neil Wilson (neil-aldur) on 2012-04-03
Changed in iptables-persistent (Ubuntu):
assignee: Neil Wilson (neil-aldur) → nobody
Vasea Pupkin (vasea-pupkin) wrote :

It returns the same error even on fresh precise beta 2 install.
Message:
update-rc.d: error: start|stop arguments not terminated by "."
subprocess installed post-installation script returned error exit status 1

Chow Loong Jin (hyperair) wrote :

It hasn't been fixed yet. To workaround this issue you can edit /var/lib/dpkg/info/iptables-persistent.postinst and change the update-rc.d line to the following:

update-rc.d iptables-persistent start 37 2 3 4 5 . stop 37 0 1 6 . >/dev/null

Note the extra "." before >/dev/null.

thx Chow Loong, you made my day...

Ronny Roethof (ronny-roethof) wrote :

thx Chow Loong :)
I'll put this patch in my personal apt repo for my kvm nodes puppetruns :)

On 19/04/2012 01:39, Ronny Roethof wrote:
> thx Chow Loong :)

(My given name's Loong Jin, by the way. Chow's my surname.)

> I'll put this patch in my personal apt repo for my kvm nodes puppetruns :)
>

Sure, but the fix will get up to Precise soon enough anyway.

--
Kind regards,
Loong Jin

Neil Wilson (neil-aldur) wrote :

I think this is probably a deficiency in the helper script. Logged Bug 985508.

The branch has been updated now to implement a workaround until dpkg-maintscript-helper gets a fix.

Neil Wilson (neil-aldur) wrote :

The discussion on Bug 985508 suggests that the pristine check can never apply for this package since /etc/iptables/rules is a 'configuration' file, not a conffile.

Therefore the use of dpkg-mainscript-helper is likely erroneous anyway. It will never be removed directly.

So perhaps we can strip all the complexity out?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iptables-persistent - 0.5.3ubuntu2

---------------
iptables-persistent (0.5.3ubuntu2) precise; urgency=low

  * debian/rules: add missing '.' (LP: #920055)
  * Stop using 'dpkg-maintscript-helper' for configuration files (LP: #967018)
 -- Neil Wilson <email address hidden> Tue, 03 Apr 2012 17:57:01 +0100

Changed in iptables-persistent (Ubuntu):
status: Confirmed → Fix Released
Changed in iptables-persistent (Debian):
status: New → Fix Committed
Changed in iptables-persistent (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.