Package fails at dpkg postinst during installation

Bug #920055 reported by Pritam Baral on 2012-01-22
52
This bug affects 13 people
Affects Status Importance Assigned to Milestone
iptables-persistent (Debian)
Fix Released
Unknown
iptables-persistent (Ubuntu)
Undecided
Unassigned

Bug Description

dpkg exits with error:
 subprocess installed post-installation script returned error exit status 1

The actual error being:
 update-rc.d: error: start|stop arguments not terminated by "."

The stop argument lacks a trailing dot in the post-inst file

Ubuntu 12.04 Precise Pangolin
iptables-persistent 0.5.3

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in iptables-persistent (Ubuntu):
status: New → Confirmed
Changed in iptables-persistent (Debian):
status: Unknown → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package iptables-persistent - 0.5.3ubuntu2

---------------
iptables-persistent (0.5.3ubuntu2) precise; urgency=low

  * debian/rules: add missing '.' (LP: #920055)
  * Stop using 'dpkg-maintscript-helper' for configuration files (LP: #967018)
 -- Neil Wilson <email address hidden> Tue, 03 Apr 2012 17:57:01 +0100

Changed in iptables-persistent (Ubuntu):
status: Confirmed → Fix Released
Changed in iptables-persistent (Debian):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.