iproute-dev is missing in Ubuntu Trusty

Bug #1303995 reported by Dmitry on 2014-04-07
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
iproute (Ubuntu)
Undecided
Unassigned

Bug Description

iproute-dev is missing in Ubuntu Trusty. What is a recommended solution to workaround this?

Hello Dmitry, are you looking for libnl ?

Dmitry (dmitrymq) wrote :

Is libnl a replacement for iproute/libnetlink.h? If so, should we provide a virtual package installing libnl instead of iproute-dev?

Hello again Dmitry!

The answer to both your questions are no.

Could you please give some background on what you're trying to do? You seem to be looking at all the wrong solutions, so I'd like to know which problem you're trying to solve....

Dmitry (dmitrymq) wrote :

I have a piece of code using libnetlink.h to monitor the network interfaces (I don't know the details). In Trusty there is no libnetlink.h. So the question is what is a suggested solution for that? Migrate to libnl, or.... ?

Hello again Dmitry!

Sounds to me like you should definitely look at using a real netlink library. There are multiple choices. If you don't need anything advanced and want something lightweight, I suggest you look at libmnl (minimal netlink library).

Ahem, there is enough publicly available code that explicitly uses -lnetlink which obviously won't build with libmnl.
So, the original question stands: where is the iproute-dev (that included libnetlink)?
And why was it removed?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in iproute (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers