FFE: ipplan incompatible with php 5.3

Bug #565781 reported by Bodo Linger
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ipplan (Debian)
Fix Released
Undecided
Unassigned
ipplan (Ubuntu)
Undecided
Unassigned
Nominated for Lucid by Jan Wagner

Bug Description

Binary package hint: ipplan

lsb_release -rd
Description: Ubuntu lucid (development branch)
Release: 10.04

apt-cache policy ipplan
ipplan:
  Installed: 4.92-1
  Candidate: 4.92-1
  Version table:
 *** 4.92-1 0
        500 http://de.archive.ubuntu.com/ubuntu/ lucid/universe Packages
        100 /var/lib/dpkg/status

I have installed ipplan using "aptitude --with-recommends install ipplan"
I have uncommented the two aliases as indicated in README.Debian then restarted apache
then I have accessd the web site,:Result:
--------------------------
If you see this message, submit a detailed bug report on Sourceforge including the message below, the database platform used and the steps to perform to recreate the problem.

PHP 5.3.2-1ubuntu4 (Linux)
Unknown error type: [8192] Function set_magic_quotes_runtime() is deprecated Line: 57 File: /usr/share/ipplan/ipplanlib.php
Problem with database permission or database tables - have installation instructions been followed?

Could not connect to database
--------------------------

Checking the PHP manual indicates that the function "set_magic_quotes_runtime" is deprecaed in PHP 5.3, wich is automatically installed by aptitude when installing ipplan..

I hope you can fix this until release ...
Best regards
Bodo

Revision history for this message
Jan Wagner (waja) wrote :

Hi there,

I have uploaded a new package to debian unstable some minutes ago:

ipplan (4.92a-1) unstable; urgency=low

  * New Upstream Release
    - PHP 5.3 compatibility (LP: #565781)
  * Add trailing trunk/ at Vcs-Svn-field
  * Update 10_custom_templates.dpatch due upstream changes

The changes from 4.92 are minor, so I would recommand to sync from unstable, if you are willing to fix this in lucid.

Cheers, Jan.

Changed in ipplan (Ubuntu):
status: New → Confirmed
Jan Wagner (waja)
Changed in ipplan (Debian):
status: New → Fix Released
Revision history for this message
Jan Wagner (waja) wrote :

There is another version between 4.92-1 and 4.92a-1, just uncritical and minor changes:

 ipplan (4.92-2) unstable; urgency=low

   * Updating standards version to 3.8.4
     - Add README.source
   * Migrate Vcs-Fields over to scm.uncompleted.org
   * Add 1.0 to debian/source/format
   * Fix typo in README.Debian

Jan Wagner (waja)
summary: - ipplan incompatible with php 5.3
+ FFE: ipplan incompatible with php 5.3
Revision history for this message
Jan Wagner (waja) wrote :

Hmmm ... just the upstream changes:

$ diff -Nur /tmp/ipplan/CHANGELOG /tmp/ipplan.new/CHANGELOG
--- /tmp/ipplan/CHANGELOG 2009-07-17 00:15:11.000000000 +0200
+++ /tmp/ipplan.new/CHANGELOG 2009-08-17 23:43:43.000000000 +0200
@@ -1,4 +1,11 @@
-ipplan v4.92
+ipplan v4.92a
+
+Aug 3, 2009
+ added: new config variable for template directory (CONFIG_DIR)
+ Jan Wagner
+ added: Italian translation
+ contributed by Calligaris Andrea
+ added: PHP 5.3 compatibility

 Jul 17, 2009
   fixed: when creating multiple contiguous subnets while

Revision history for this message
Scott Kitterman (kitterman) wrote :

FFe approved.

Revision history for this message
Andrew Mitchell (ajmitch) wrote :

Sync ACKed.

Revision history for this message
Steve Langasek (vorlon) wrote :

[Updating] ipplan (4.92-1 [Ubuntu] < 4.92a-1 [Debian])
 * Trying to add ipplan...
2010-04-19 17:16:50 INFO - <ipplan_4.92a.orig.tar.gz: downloading from http://ftp.debian.org/debian/>
2010-04-19 17:16:50 INFO - <ipplan_4.92a-1.diff.gz: downloading from http://ftp.debian.org/debian/>
2010-04-19 17:16:50 INFO - <ipplan_4.92a-1.dsc: downloading from http://ftp.debian.org/debian/>
I: ipplan [universe] -> ipplan_4.92-1 [universe].

Changed in ipplan (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers