ipmi modules need to manually inserted and device created

Bug #110992 reported by PaulSchulz on 2007-04-29
80
This bug affects 13 people
Affects Status Importance Assigned to Milestone
ipmitool (Ubuntu)
Wishlist
Unassigned
linux (Ubuntu)
Medium
Unassigned

Bug Description

The ipmitool package requires kernel modules to work. These are available in the Ubuntu/Debian kernel..

  ./kernel/drivers/char/ipmi
  ./kernel/drivers/char/ipmi/ipmi_msghandler.ko
  ./kernel/drivers/char/ipmi/ipmi_devintf.ko
  ./kernel/drivers/char/ipmi/ipmi_poweroff.ko
  ./kernel/drivers/char/ipmi/ipmi_si.ko
  ./kernel/drivers/char/ipmi/ipmi_watchdog.ko

The ipmitool uses the device - '/dev/ipmi0' - this currently needs to manually created, by hand.

The 'ipmievd.init.basic' script supplied with the package does not work, and gives the following
errors:
-----
Setting up OpenIPMI driver...
FATAL: Module ipmi_kcs_drv not found.
FATAL: Error inserting ipmi_si (/lib/modules/2.6.20-14-generic/kernel/drivers/char/ipmi/ipmi_si.ko): No such device
------

Morten C. Kuehl (morten-kuehl) wrote :

Is there a manual workaround for this problem?

Fabián Rodríguez (magicfab) wrote :

Paul, could you share the workaround you used to make this work, pending a final fix ? Thank you.

Changed in ipmitool:
assignee: nobody → magicfab
status: New → Incomplete
Fabián Rodríguez (magicfab) wrote :

I happen to have access to a Poweredge 1850. Using Ubuntu 6.06.1 LTS (Dapper), the following workaround seems to work ( from http://www.debian-administration.org/articles/341#comment_5 ):

nano /usr/share/ipmitool/ipmi.init.basic

The top section looks like this:

# load the ipmi modules
modprobe ipmi_msghandler
modprobe ipmi_devintf
if ! modprobe ipmi_kcs_drv ; then
modprobe ipmi_si # try new module name
fi

This script check doesn't work, and throws an error that it can't load the KCS driver.

Change it to:
modprobe ipmi_msghandler
modprobe ipmi_devintf
modprobe ipmi_si # try new module name

Save as: /usr/share/ipmitool/ipmi.init.debian

I didn`t need to creat the device manually, though. Did you have to do that ?

To start the OpenIPMI driver, do:
/usr/share/ipmitool/ipmi.init.basic

You can test the local (KCS) IPMI interface by issuing:
ipmitool -I open channleinfo

Although my LAN interface is configured, the following command failed for me:
ipmitool -I lan -H HOST_IP_ADDRESS -U USERNAME -a channel info

More information about setting up and using IPMI on Dell servers can be found at:
http://www.dell.com/downloads/global/power/ps4q04-20040204-Murphy.pdf

drink (martin-espinoza) wrote :

I am pleased to report that this works for IBM xSeries eserver 325 also.

Wouldn't it be enough to just make these modules autoload?\

The proper fix for the script if you want it to work as originally designed is "modprobe ipmi_kcs_drv || modprobe ipmi_si" but... who cares? seems like a distribution will know which modules are included.

In theory, adding the names of the three modules we want to the end of /etc/modules should solve the problem. Another theory is that after doing a depmod, just loading ipmi_si should load all three modules. Haven't tried it though.

Salgar (salgar) wrote :

You must load ipmi_devintf and ipmi_si. The module ipmi_msghandler will be loaded automatically.

sudo echo "ipmi_devintf" >> /etc/modules
sudo echo "ipmi_si" >> /etc/modules

... and it works.

Changed in ipmitool:
assignee: magicfab → nobody

The problem is straightforward to see and is easy to confirm.

Changed in ipmitool (Ubuntu):
status: Incomplete → Confirmed
Chuck Short (zulcss) wrote :

Why not just get to load the modules when the server boots?

Changed in ipmitool (Ubuntu):
importance: Undecided → Wishlist
status: Confirmed → Triaged

One would imagine that this bug could have been fixed any time in the last couple of years. It would require editing a couple of files on the part of one of the maintainers. Is there a good reason this has not been completed?

Dave Walker (davewalker) wrote :

Can this bug be reproduced on Lucid?

Dave Walker <email address hidden> writes:
> Can this bug be reproduced on Lucid?

I'm not running Lucid yet. However, you can check if the defect is there
just by reading a couple of files, you don't need to ask anyone to
reproduce it.

Perry
--
Perry E. Metzger <email address hidden>

On my lucid install ipmi_si seems to autoload, but ipmi_devintf doesn't.
Loading ipmi_devintf is enough to have /dev/ipmi0 created and ipmitool then works.

Ted Reed (treed) wrote :

I can confirm the same results as Niklas. In addition, there are errors that occur during installation of ipmitool:

(Reading database ... 48065 files and directories currently installed.)
Unpacking libreadline5 (from .../libreadline5_5.2-7build1_amd64.deb) ...
Selecting previously deselected package ipmitool.
Unpacking ipmitool (from .../ipmitool_1.8.11-1ubuntu1_amd64.deb) ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Setting up libreadline5 (5.2-7build1) ...

Setting up ipmitool (1.8.11-1ubuntu1) ...
ipmievd: using pidfile /var/run/ipmievd.pid0
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory
Unable to open interface
invoke-rc.d: initscript ipmievd, action "start" failed.
Unable to start ipmievd during installation. Trying to disable.

Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Writing extended state information... Done

Jeff Lane (bladernr) wrote :

Why is this still even an issue?

Verified that on the latest Lucid SRU, ipmi_si and ipmi_msghandler load at boot but ipmi_devintf does not.

Changed in linux (Ubuntu):
status: New → Triaged
tags: added: kernel-key
Jeff Lane (bladernr) wrote :
Download full text (5.4 KiB)

Ok... so further investigation:

Fresh Natty install on an IBM server with BMC using the latest ISOs as of 8 March.

Looking in /lib/modules/2.6.38-5-generic/kernel/drivers/char/ipmi/ shows that the drivers are present.
No IPMI packages are installed:

First I install ipmitool:

ubuntu@ubuntu:~$ sudo apt-get install ipmitool
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  openipmi
The following NEW packages will be installed:
  ipmitool
0 upgraded, 1 newly installed, 0 to remove and 13 not upgraded.
Need to get 418 kB of archives.
After this operation, 1,118 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ natty/universe ipmitool amd64 1.8.11-2ubuntu3 [418 kB]
Fetched 418 kB in 0s (431 kB/s)
ySelecting previously deselected package ipmitool.
(Reading database ... 30797 files and directories currently installed.)
Unpacking ipmitool (from .../ipmitool_1.8.11-2ubuntu3_amd64.deb) ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for man-db ...
Setting up ipmitool (1.8.11-2ubuntu3) ...
ipmievd: using pidfile /var/run/ipmievd.pid0
Could not open device at /dev/ipmi0 or /dev/ipmi/0 or /dev/ipmidev/0: No such file or directory
Unable to open interface
invoke-rc.d: initscript ipmievd, action "start" failed.
Unable to start ipmievd during installation. Trying to disable.

Also note that installing ipmitool does not install any other packages at all.

These errors happened because /dev/ipmi0 is not created... that requires ipmi_devmntf to be loaded. One would think that since I just installed ipmitool, which includes ipmievd to pass BMC messages on to syslog, that as soon as I reboot, the modules would be loaded, /dev/ipmi0 would be created and everthing would be copacetic. So after installing ipmitool and verifying that ipmievd was not running, /dev/ipmi0 was not there, and the modules were not loaded, I rebooted the server to see what would happen.

ipmi modules are NOT loaded, ipmievd is not started, and /dev/ipmi0 is not created, thus, nothing.

Now I install the openipmi package (which is NOT pulled in by installing ipmitool):

ubuntu@ubuntu:~$ sudo apt-get install openipmi
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  libopenipmi0 libperl5.10 libsensors4 libsnmp-base libsnmp15
Suggested packages:
  lm-sensors snmp-mibs-downloader
The following NEW packages will be installed:
  libopenipmi0 libperl5.10 libsensors4 libsnmp-base libsnmp15 openipmi
0 upgraded, 6 newly installed, 0 to remove and 13 not upgraded.
Need to get 2,288 kB of archives.
After this operation, 6,595 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://10.189.84.1/enablement/cdimage.ubuntu.com/ubuntu-server/daily/current/natty-server-amd64/ natty/main libopenipmi0 amd64 2.0.18-0ubuntu3 [559 kB]
Get:2 http://10.189.84.1/enablement/cdimage.ubuntu.com/ubuntu-server/daily/current/natty-server-amd64/ natty/main libperl5.10 amd64 5.10.1-17ubuntu3 [1,200 B]
Get:3 http://10.189.84.1/enable...

Read more...

Jeff Lane (bladernr) wrote :

Also, by "pulling in openipmi" I mean that perhaps the control file for the ipmitool package could change from suggesting openipmi to recommending openipmi

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ipmitool - 1.8.11-2ubuntu4

---------------
ipmitool (1.8.11-2ubuntu4) natty; urgency=low

  * Changed openipmi from Suggests to Recommends to ensure
    it's installed too. (LP: #110992)
 -- Jeff Lane <email address hidden> Wed, 09 Mar 2011 10:40:28 -0500

Changed in ipmitool (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu):
importance: Undecided → Medium
Seth Forshee (sforshee) on 2011-06-28
Changed in linux (Ubuntu):
status: Triaged → Invalid
Jeff Lane (bladernr) wrote :

Just out of curiosity, this was marked Fix Released on March 19, why is it now being marked invalid?

Jeff Lane (bladernr) wrote :

Nevermind... I fail at reading comprehension :-) I didn't realize that the kernel bug was still open.

This bug was filed against a series that is no longer supported and so is being marked as Won't Fix. If this issue still exists in a supported series, please file a new bug.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: Invalid → Won't Fix
Martin (ub71-martin) wrote :

I have opened a new bug report which is basically the same as the current, which still happens on Lucid:
https://bugs.launchpad.net/ubuntu/+source/ipmitool/+bug/908112

But I am not able (Or I don't know how) to attach it to a specific ubuntu distribution release.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers