Ubuntu

ipheth driver does not support iPhone4

Reported by Tim Potter on 2010-09-23
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ipheth (Ubuntu)
Low
kruisailija
Maverick
Low
Unassigned

Bug Description

The USB product ID for iPhone4 is not in the current ipheth-dkms package. It's a simple fix - just add a define and an extra entry in a table. See my PPA for source changes:

https://launchpad.net/~tpot/+archive/ipheth

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: ipheth-dkms 1.0-1ubuntu1
ProcVersionSignature: Ubuntu 2.6.35-20.29-generic 2.6.35.4
Uname: Linux 2.6.35-20-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
Date: Thu Sep 23 10:49:55 2010
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Alpha amd64 (20100803.1)
PackageArchitecture: all
ProcEnviron:
 LANG=en_AU.utf8
 SHELL=/bin/bash
SourcePackage: ipheth

Tim Potter (tpot) wrote :
Stefano Rivera (stefanor) wrote :

Tim: I heard about this through a comment on bug #605740.

The best way to get a fix into Ubuntu (when you know your way around packaging) is the sponsorship process: https://wiki.ubuntu.com/SponsorshipProcess

I.e. attach a debdiff for maverick-updates and subscribe ubuntu-sponsors

I'm hesitant to make this fix myself, as I can't test it.

Changed in ipheth (Ubuntu):
importance: Undecided → Low
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

Looks like the natty kernel ipheth module supports iPhone 4, so we just need to sync Debian's change, dropping the ipheth-dkms package.

For maverick, an SRU with the added USB ID is necessary.

Changed in ipheth (Ubuntu Maverick):
importance: Undecided → Low
status: New → Confirmed
Stefano Rivera (stefanor) wrote :

Sync request tracked in LP: #661669

Stefano Rivera (stefanor) wrote :

SRU Patch for maverick

Changed in ipheth (Ubuntu Maverick):
status: Confirmed → Fix Committed

Accepted ipheth into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Ilja Pavkovic (ipavkovic) wrote :

installed maverick-proposed package. Works now!

tags: added: verification-done
removed: verification-needed
Danilo Martins (mawkee) wrote :

Confirmed fix on maverick-proposed.

Stefano Rivera (stefanor) wrote :

The (separately tracked) sync has happened.

Changed in ipheth (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ipheth - 1.0-1ubuntu1.1

---------------
ipheth (1.0-1ubuntu1.1) maverick-proposed; urgency=low

  * Add iPhone 4 support, thanks to Tim Potter (LP: #645680)
 -- Stefano Rivera <email address hidden> Sat, 16 Oct 2010 13:20:07 +0200

Changed in ipheth (Ubuntu Maverick):
status: Fix Committed → Fix Released
Changed in ipheth (Ubuntu):
assignee: nobody → kruisailija (kruisailija)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers