Default to early instead of auto when MODULES=most

Bug #1778738 reported by Julian Andres Klode on 2018-06-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
amd64-microcode (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned
intel-microcode (Ubuntu)
Undecided
Unassigned
Trusty
Undecided
Unassigned
Xenial
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
Unassigned

Bug Description

[Impact]
Initramfs for MODULES=most should build with all microcodes installed

[Test case]
Have both amd64-microcode and intel-microcode installed, and MODULES=most set. Test generated initramfs in both amd64 and intel machines and make sure the microcodes load.

If that's not feasible, we should at least run update-initramfs with -v and ensure that it says the right things:

I: amd64-microcode: installing AMD64 microcode into the early initramfs...
intel-microcode: adding microcode for either all or selected Intel processor models
[long list of microcodes]

[Regression potential]
Some tools will fail to understand the initramfs, as it now has two cpio archives prepended (e.g. lsinitramfs skips intel microcode archive, as seen in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=886424)

Changed in amd64-microcode (Ubuntu):
status: New → In Progress
status: In Progress → Fix Committed
Changed in intel-microcode (Ubuntu):
status: New → Fix Committed
tags: added: block-proposed
Dimitri John Ledkov (xnox) wrote :

Tested on intel locally, it's loaded, with both amd64-microcode & intel-microcode installed from proposed.

ditto on amd baremetal instance i got off a public cloud.

tags: removed: block-proposed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-microcode - 3.20180425.1ubuntu1

---------------
intel-microcode (3.20180425.1ubuntu1) cosmic; urgency=medium

  * Default to early instead of auto, and install all of the microcode,
    not just the one matching the current CPU, if MODULES=most is set
    in the initramfs-tools config (LP: #1778738)

 -- Julian Andres Klode <email address hidden> Tue, 26 Jun 2018 16:31:30 +0200

Changed in intel-microcode (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package amd64-microcode - 3.20180524.1ubuntu1

---------------
amd64-microcode (3.20180524.1ubuntu1) cosmic; urgency=medium

  * Default to 'early' instead of 'auto' in the initramfs-tools hook
    when building with MODULES=most (LP: #1778738)

 -- Julian Andres Klode <email address hidden> Tue, 26 Jun 2018 16:32:22 +0200

Changed in amd64-microcode (Ubuntu):
status: Fix Committed → Fix Released
tags: added: id-5b0f2e633d73b7b1eb883677
description: updated
description: updated
description: updated
Julian Andres Klode (juliank) wrote :

I'm not sure how feasible retesting loading of the firmware is for the 8 SRUs. We tested that once on cosmic per vendor, so given that the rest is equal, just ensuring it's there is probably fine.

Hello Julian, or anyone else affected,

Accepted intel-microcode into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/intel-microcode/3.20180425.1~ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in intel-microcode (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted amd64-microcode into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/amd64-microcode/3.20180524.1~ubuntu0.18.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in amd64-microcode (Ubuntu Bionic):
status: New → Fix Committed
Changed in intel-microcode (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed-artful
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted intel-microcode into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/intel-microcode/3.20180425.1~ubuntu0.17.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in amd64-microcode (Ubuntu Artful):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted amd64-microcode into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/amd64-microcode/3.20180524.1~ubuntu0.17.10.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in intel-microcode (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted intel-microcode into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/intel-microcode/3.20180425.1~ubuntu0.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in amd64-microcode (Ubuntu Xenial):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted amd64-microcode into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/amd64-microcode/3.20180524.1~ubuntu0.16.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted intel-microcode into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/intel-microcode/3.20180425.1~ubuntu0.14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in intel-microcode (Ubuntu Trusty):
status: New → Fix Committed
tags: added: verification-needed-trusty
Changed in amd64-microcode (Ubuntu Trusty):
status: New → Fix Committed
Łukasz Zemczak (sil2100) wrote :

Hello Julian, or anyone else affected,

Accepted amd64-microcode into trusty-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/amd64-microcode/3.20180524.1~ubuntu0.14.04.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-trusty to verification-done-trusty. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-trusty. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Łukasz Zemczak (sil2100) wrote :

btw. is it necessary for these to go to -security as well? Or just -updates is enough? For now I assumed the latter, since no security sign-off was requested (and for -security updates we'd need to get these built in the security PPA probably).

Steve Beattie (sbeattie) wrote :

Hi, the trusty amd64-microcode SRU has been superceded by https://launchpad.net/ubuntu/+source/amd64-microcode/3.20180524.1~ubuntu0.14.04.2+really20130710.1 which was a revert due to LP: #1779092. Thanks.

Changed in amd64-microcode (Ubuntu Trusty):
status: Fix Committed → Triaged
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers