[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x25 (or later)

Bug #1724650 reported by Chatty on 2017-10-18
106
This bug affects 22 people
Affects Status Importance Assigned to Milestone
intel-microcode (Ubuntu)
Undecided
Unassigned

Bug Description

During boot the above message appears.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: evince 3.25.92-1
ProcVersionSignature: Ubuntu 4.13.0-12.13-generic 4.13.3
Uname: Linux 4.13.0-12-generic x86_64
ApportVersion: 2.20.7-0ubuntu1
Architecture: amd64
CasperVersion: 1.384
CurrentDesktop: ubuntu:GNOME
Date: Wed Oct 18 20:25:20 2017
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Alpha amd64 (20170926)
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: evince
UpgradeStatus: No upgrade log present (probably fresh install)
---
ApportVersion: 2.20.4-0ubuntu4
Architecture: amd64
AudioDevicesInUse:
 Cannot stat file /proc/2447/fd/17: Stale file handle
 Cannot stat file /proc/2447/fd/18: Stale file handle
                      USER PID ACCESS COMMAND
 /dev/snd/controlC0: ubuntu 2325 F.... pulseaudio
 /dev/snd/controlC1: ubuntu 2325 F.... pulseaudio
CasperVersion: 1.380
CurrentDesktop: Unity:Unity7
DistroRelease: Ubuntu 17.04
LiveMediaBuild: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 10f1:1a63 Importek
 Bus 001 Device 003: ID 8087:07dc Intel Corp.
 Bus 001 Device 002: ID 18a5:0302 Verbatim, Ltd Flash Drive
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Medion S6417 MD99651
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 4.10.0-19.21-generic 4.10.8
RelatedPackageVersions:
 linux-restricted-modules-4.10.0-19-generic N/A
 linux-backports-modules-4.10.0-19-generic N/A
 linux-firmware 1.164
Tags: zesty
Uname: Linux 4.10.0-19-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/10/2015
dmi.bios.vendor: INSYDE Corp.
dmi.bios.version: GOLF2.0_BD4.12R
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Golf 2.0
dmi.board.vendor: Medion
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Medion
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDECorp.:bvrGOLF2.0_BD4.12R:bd08/10/2015:svnMedion:pnS6417MD99651:pvrTBDbyOEM:rvnMedion:rnGolf2.0:rvrType2-BoardVersion:cvnMedion:ct10:cvrChassisVersion:
dmi.product.name: S6417 MD99651
dmi.product.version: TBD by OEM
dmi.sys.vendor: Medion
---
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: ubuntu 1685 F.... pulseaudio
 /dev/snd/controlC0: ubuntu 1685 F.... pulseaudio
CasperVersion: 1.387
CurrentDesktop: ubuntu:GNOME
DistroRelease: Ubuntu 17.10
LiveMediaBuild: Ubuntu 17.10 "Artful Aardvark" - Release amd64 (20171017.1)
Lsusb:
 Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
 Bus 001 Device 004: ID 10f1:1a63 Importek
 Bus 001 Device 003: ID 8087:07dc Intel Corp.
 Bus 001 Device 002: ID 18a5:0302 Verbatim, Ltd Flash Drive
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
MachineType: Medion S6417 MD99651
Package: linux (not installed)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=C.UTF-8
 SHELL=/bin/bash
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/username.seed boot=casper quiet splash ---
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
RelatedPackageVersions:
 linux-restricted-modules-4.13.0-16-generic N/A
 linux-backports-modules-4.13.0-16-generic N/A
 linux-firmware 1.169
Tags: artful
Uname: Linux 4.13.0-16-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 08/10/2015
dmi.bios.vendor: INSYDE Corp.
dmi.bios.version: GOLF2.0_BD4.12R
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: Golf 2.0
dmi.board.vendor: Medion
dmi.board.version: Type2 - Board Version
dmi.chassis.asset.tag: Chassis Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: Medion
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnINSYDECorp.:bvrGOLF2.0_BD4.12R:bd08/10/2015:svnMedion:pnS6417MD99651:pvrTBDbyOEM:rvnMedion:rnGolf2.0:rvrType2-BoardVersion:cvnMedion:ct10:cvrChassisVersion:
dmi.product.family: Type1Family
dmi.product.name: S6417 MD99651
dmi.product.version: TBD by OEM
dmi.sys.vendor: Medion

Chatty (mail-chatty) wrote :
Chatty (mail-chatty) wrote :

This also happens with Fedora 27: https://bugzilla.redhat.com/show_bug.cgi?id=1501362

Sebastien Bacher (seb128) wrote :

that doesn't seem a bug with evince the pdf reader?

affects: evince (Ubuntu) → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1724650

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected zesty
description: updated
Chatty (mail-chatty) wrote : CRDA.txt

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Chatty (mail-chatty) wrote :

The above logs were taken with Ubuntu 17.04 where TSC deadline enables just fine even though the microcode revision is 0x1f as in 17.10 where this revision causes problems which ought to be solved in revision 0x25.

apport information

description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Chatty (mail-chatty) wrote :

The above log files have this time been taken with Ubuntu 17.10 nightly 20171017 and show the firmware bug with microcode still being revision 0x1f.

Chatty (mail-chatty) on 2017-10-18
Changed in linux (Ubuntu):
status: Incomplete → Confirmed
affects: linux (Ubuntu) → linux-firmware (Ubuntu)
Seth Forshee (sforshee) wrote :

Wrong package, the ucode is in the intel-microcode package and not linux-firmware.

affects: linux-firmware (Ubuntu) → intel-microcode (Ubuntu)
Dave Chiluk (chiluk) wrote :

There is no way to tell if you even have the intel-microcode package installed which should have the newest microcode. Please apt install intel-microcode and update this bug.

dino99 (9d9) wrote :

There is a proposed upstream patch: lp:1726303

Dan Streetman (ddstreet) wrote :

> There is a proposed upstream patch: lp:1726303

that bug is dup of bug 1724912

but, the patch will only "help" you if the TSC_DEADLINE disabling was done incorrectly, i.e. if your system doesn't actually have that timer. That isn't the case for you.

> The above logs were taken with Ubuntu 17.04 where TSC deadline enables just fine
> even though the microcode revision is 0x1f as in 17.10 where this revision causes
> problems which ought to be solved in revision 0x25.

Because pre-artful 4.13 the kernel doesn't have the commit that actually checks the ucode and disables the timer for buggy fw versions. (I should probably get that commit backported to avoid buggy TSC_DEADLINE timer use).

If your cpu ucode isn't at the fixed level, your TSC_DEADLINE timer is buggy and may cause problems.

As @chiluk said, you need to install intel-microcode and reboot; that will get your cpu up to the correct fixed level of ucode.

Dan Streetman (ddstreet) on 2017-10-26
Changed in intel-microcode (Ubuntu):
status: Confirmed → Fix Released
Dan Streetman (ddstreet) wrote :

Your cpu is:

[ 0.162937] smpboot: CPU0: Intel(R) Core(TM) M-5Y31 CPU @ 0.90GHz (family: 0x6, model: 0x3d, stepping: 0x4)

The latest Intel microcode, release 20170707, contains:

$ iucode-tool -L 06-3d-04
microcode bundle 1: 06-3d-04
  001/001: sig 0x000306d4, pf_mask 0xc0, 2017-01-27, rev 0x0025, size 17408

The latest Ubuntu 17.10 intel-microcode package contains:

$ iucode-tool -l microcode-20170707.dat | grep 306d4
  001/141: sig 0x000306d4, pf_mask 0xc0, 2017-01-27, rev 0x0025, size 17408

So it already contains your fixed ucode, you just need to install intel-microcode and reboot.

Chatty (mail-chatty) wrote :

@Dan: please See #19 - I was testing Ubuntu 17.10 live ISO. Probably this latest ucode does not get loaded.

Dan Streetman (ddstreet) wrote :

> I was testing Ubuntu 17.10 live ISO. Probably this latest ucode does not get loaded.

Yes probably not from a live cd. However for an installed system, you should install intel-microcode and reboot, if your CPU firmware is buggy.

The alternative is to get your motherboard's latest BIOS/firmware, which sometimes includes CPU microcode updates (but, not always).

Chatty (mail-chatty) wrote :

I solved this bug (and also https://bugs.launchpad.net/ubuntu/+source/linux/+bug/1724657) by inserting intel-ucode.img (taken from recent arch linux iso) as first initrd into grub.cfg. This updates the microcode very early in the boot process. And this way I can use the live iso without having to install to hard drive and install additional packages and so on.

Nermeen Hussein (nhm) wrote :

I found this bug in my system logs today, but I boot just fine. Can someone pls guide me step-by-step how to solve it? I hate to be stranded suddenly from being able to boot. Pls note I'm still very new with linux and ubuntu so any "lingo" needs to be very basic so I can understand it. Thanks.

Chatty (mail-chatty) wrote :

What system are you using? Which live media did you use for booting?

kiran (kirankrishnan337) wrote :

I got this bug as well. My system is not shutting down as well. What should i do?
It started after i installed Ubuntu 17.10.

Dan Streetman (ddstreet) wrote :

> Can someone pls guide me step-by-step how to solve it?

This is not an Ubuntu bug. Your processor microcode (firmware) is old and contains bugs. Sometimes motherboard BIOS updates contain processor microcode updates, but not always, and BIOS isn't always at the latest level.

To allow Ubuntu to update your processor microcode, do this (don't type in the $ character):

$ sudo apt-add-repository restricted
$ sudo apt update
$ sudo apt install intel-microcode
$ sudo reboot

> I got this bug as well.

See above; this isn't an Ubuntu bug. Feel free to do the above steps to allow Ubuntu to install updated processor microcode on each boot, to address the buggy microcode in your CPU.

> My system is not shutting down as well.

That's unrelated to this bug.

Gaël Macherel (djaz) wrote :

Hello !

I've been having this bug as well, when trying to install Ubuntu 17.10 (or fedora 27) in dual boot, and any linux distrib on Virtual Machine (Virtual Box).

The problem is that I can't even boot under Linux (because I can't install it, and I face this problem even with a live-session), so I can't try the commands previously advised.

Also, I'm kind of new to the Linux world, so I have no idea on how to "insert intel-ucode.img (taken from recent arch linux iso) as first initrd into grub.cfg".

Any clue ?
Thanks all for your help,
Gaël

Dan Streetman (ddstreet) wrote :

> The problem is that I can't even boot under Linux

This issue will not prevent you from booting or installing Linux, so if you're unable to do that it is completely unrelated to this and you should either open a new bug or try different installation instructions.

Zachary Habrat (idea2form) wrote :

I am like Dan Streetman and can not type anything after this error during install of Ubuntu 17.04. I can not try sudo apt-get install-intelmicrocode or anything like this because it will not let me type.

My screen looks like this.
https://photos.app.goo.gl/A5vYLwU5ChGq8U7J3

I am like Thomas Hisch who posted on the Fedora community thread for this issue on 2017-11-08 13:56:34 EST
https://bugzilla.redhat.com/show_bug.cgi?id=1501362#c11
... because I also have an Asus motherboard and Intel i7. I think mine is a intel i7 3770K.

I followed steps to update the microchip manually from the windows hard drive. https://www.youtube.com/watch?v=nEYqw5tvZHs
This was successful, I have installed the latest microchip architecture.

I have noticed that some people are having luck changing files in the installer prior to boot. I want to try this but all the posts referring to this are far too geeky for me to follow. I am a first time linux user.

The USB installed Ubuntu flawlessly on my Lenovo laptop. I used rufus to make my .iso bootable.

Sorry I am not very tech savoy, I hope this helps everyone here.

Zachary Habrat (idea2form) wrote :

I want to add that I have two 780ti Nvidea cards. The second error from the screenshot above is.
nouveau 0000:01:00.0: DDC responded, but no EDID for DVI-D-1
Googling this error produces very few results. Why would an Nvidea card need anything Nouveau?
source --> https://bugs.freedesktop.org/show_bug.cgi?id=33165
I don't know if I am unbootable because of this error or the one this thread of discussion is dedicated to. If anyone knows about this second possibly unrelated error, please advise. I am getting linux installed for the first time.

Dan Streetman (ddstreet) wrote :

> Why would an Nvidea card need anything Nouveau?

nouveau is the open-source driver for Nvidia cards:
https://nouveau.freedesktop.org/wiki/

Your booting problem is most likely not related to this issue. It seems to me like your issue is with the X server (graphics) not correctly starting.

As this is a bug report for a specific problem that is likely unrelated to your installation problem, I suggest seeking more general installation help from better sources, such as IRC:
https://wiki.ubuntu.com/IRC/ChannelList

or general installation help:
https://help.ubuntu.com/community/Installation

Finally, if you are new to Linux, it is probably better for you to try installing the Ubuntu Long-Term-Support (LTS) release. The current LTS release is Xenial 16.04, which you can download here:
http://releases.ubuntu.com/16.04/

I updated my 16.04.3 Desktop installation today and saw pretty much the same message, only different version requested:

[Firmware Bug]: TSC_DEADLINE disabled due to Errata; please update microcode to version: 0x22 (or later)

I'm fairly new to this bug reporting, so let me know if you need some more info from me.

Dan Streetman (ddstreet) wrote :

> I'm fairly new to this bug reporting, so let me know if you need some more info from me.

This is not a kernel bug. Your firmware is old and contains a known cpu bug. You need to install the intel-microcode package so your cpu firmware is brought up-to-date on every boot (of Ubuntu). The CPU firmware is not persistent like your motherboard BIOS, you can't "upgrade" your CPU firmware once and then it's done. It must be done every boot, which is what the intel-microcode package sets up.

Vinod Chaurasia (vinodvghs) wrote :

X025

To post a comment you must log in.