intel-microcode: New CPU microcode 20140430

Bug #1319114 reported by Tim Gardner on 2014-05-13
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
intel-microcode (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Tim Gardner
Trusty
Undecided
Tim Gardner
Utopic
Undecided
Unassigned

Bug Description

A new CPU microcode release, 20140430 version was released and can be downloaded from:
https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23829

Tim Gardner (timg-tpi) on 2014-05-13
Changed in intel-microcode (Ubuntu Precise):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in intel-microcode (Ubuntu Trusty):
assignee: nobody → Tim Gardner (timg-tpi)
status: New → In Progress
Changed in intel-microcode (Ubuntu Utopic):
status: New → Fix Released
Tim Gardner (timg-tpi) on 2014-05-13
Changed in intel-microcode (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in intel-microcode (Ubuntu Trusty):
status: In Progress → Fix Committed

Hello Tim, or anyone else affected,

Accepted intel-microcode into trusty-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/intel-microcode/2.20140430.1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

tags: added: verification-needed
Chris J Arges (arges) wrote :

Hello Tim, or anyone else affected,

Accepted intel-microcode into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/intel-microcode/0.20140430-p-1ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Grant Slater (firefishy) wrote :

intel-microcode on trusty ok for me.

TEST CASE:
1. Package update.
2. Package update triggers update-initramfs
3. ucode loads/applied as expected. (on reboot)
4. No locks-ups or other unexpected hardware issues after load.

VERIFICATION DONE
1. Package update installed as expected.
2. Manually loaded new ucode by: "cat /lib/firmware/intel-ucode/06-3e-04 | sudo iucode-tool -k -tb -" without issue.
3. Ran a few minutes of prime95 Torture Test without issue.
4. Rebooted system without issue. Confirmed new ucode applied via dmesg
"[ 0.000000] CPU0 microcode updated early to revision 0x427, date = 2014-04-10"...

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-microcode - 2.20140430.1ubuntu1

---------------
intel-microcode (2.20140430.1ubuntu1) trusty; urgency=medium

  * A new CPU microcode release, 20140430 version was released and can be downloaded from:
    https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23829
    -LP: #1319114
 -- Tim Gardner <email address hidden> Tue, 13 May 2014 11:50:12 -0600

Changed in intel-microcode (Ubuntu Trusty):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for intel-microcode has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package intel-microcode - 0.20140430-p-1ubuntu1

---------------
intel-microcode (0.20140430-p-1ubuntu1) precise; urgency=medium

  * New upstream data file: microcode-20140430
    https://downloadcenter.intel.com/Detail_Desc.aspx?agr=Y&DwnldID=23829
    -LP: #1319114
 -- Tim Gardner <email address hidden> Tue, 13 May 2014 12:15:53 -0600

Changed in intel-microcode (Ubuntu Precise):
status: Fix Committed → Fix Released

On Tue, 17 Jun 2014, Grant Slater wrote:
> TEST CASE:
> 1. Package update.
> 2. Package update triggers update-initramfs
> 3. ucode loads/applied as expected. (on reboot)
> 4. No locks-ups or other unexpected hardware issues after load.
>
> VERIFICATION DONE
> 1. Package update installed as expected.
> 2. Manually loaded new ucode by: "cat /lib/firmware/intel-ucode/06-3e-04 | sudo iucode-tool -k -tb -" without issue.
> 3. Ran a few minutes of prime95 Torture Test without issue.
> 4. Rebooted system without issue. Confirmed new ucode applied via dmesg
> "[ 0.000000] CPU0 microcode updated early to revision 0x427, date = 2014-04-10"...
>
>
> ** Tags removed: verification-needed
> ** Tags added: verification-done

I found out a few days ago that release 20140430 fixes one *critical
erratum* for the Xeon E5v2 and Xeon E7v2 processors, as well as a few severe
ones. As per the changelog, other processors did not receive new updates
on this release.

Without the microcode update, any VMs on boxes with Xeon E5v2 and E7v2
processors are at risk of unpredictable behaviour due to incorrect page
translations(!).

That said, these are server platforms, so their users should have received
notice of a EFI/BIOS *critical* firmware update from the server vendor that
includes the microcode update.

--
  "One disk to rule them all, One disk to find them. One disk to bring
  them all and in the darkness grind them. In the Land of Redmond
  where the shadows lie." -- The Silicon Valley Tarot
  Henrique Holschuh

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers