/var/log/installer/initial-status.gz is empty on server installs

Bug #337276 reported by Ruben Laban on 2009-03-03
8
Affects Status Importance Assigned to Milestone
installation-report (Ubuntu)
Undecided
Colin Watson
Hardy
Low
Colin Watson

Bug Description

Binary package hint: installation-report

Example:

# ls /var/log/installer/initial-status.gz -l
-rw-r--r-- 1 root root 0 2009-03-02 12:02 /var/log/installer/initial-status.gz

I get similar results on Hardy and Intrepid, i386 and amd64.

This is an issue for the installer team because that file exists specifically to help us debug certain kinds of problems; we'd like to get this fixed to increase our odds of getting useful debugging output.

This was fixed in installation-report version 2.38ubuntu2 in Jaunty. http://bazaar.launchpad.net/~ubuntu-core-dev/installation-report/hardy-proposed/revision/57 is a backport of this change that I'd like to get in for Ubuntu 8.04.3.

TEST CASE: Perform an installation with the alternate or server installer; check whether /var/log/installer/initial-status.gz contains useful contents similar to that of /var/lib/dpkg/status.

REGRESSION POTENTIAL: I can't think of any way that this could go wrong, other than the original bug persisting. The command in question is already failing as it stands, and the failure is being ignored, so it isn't going to cause an installation failure or anything.

Colin Watson (cjwatson) on 2009-03-03
Changed in installation-report:
assignee: nobody → cjwatson
importance: Undecided → Low
milestone: none → ubuntu-8.04.3
status: New → Triaged
assignee: nobody → cjwatson
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package installation-report - 2.38ubuntu2

---------------
installation-report (2.38ubuntu2) jaunty; urgency=low

  * Run gzip chrooted to /target rather than in the installer environment,
    since busybox-udeb isn't configured with gzip support, only gunzip
    (LP: #337276).

 -- Colin Watson <email address hidden> Tue, 03 Mar 2009 15:50:36 +0000

Changed in installation-report:
status: New → Fix Released
Colin Watson (cjwatson) on 2009-06-04
description: updated
Changed in installation-report (Ubuntu Hardy):
status: Triaged → In Progress
Martin Pitt (pitti) wrote :

Accepted installation-report into hardy-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in installation-report (Ubuntu Hardy):
status: In Progress → Fix Committed
tags: added: verification-needed
Steve Beattie (sbeattie) wrote :

I've verified that the 8.04.2 server cd installation does not correctly populate the contents of /var/log/installer/initial-status.gz, and that with the version of installation-report in hardy-proposed, 2.31ubuntu2, via the netboot image and apt-setup/proposed is enabled, correctly copies data to /var/log/installer/initial-status.gz.
Otherwise, installation functioned normally, no sign of regressions was seen.

Alas, the hardy daily server cd w/build 20090624 did not get built with -proposed enabled, as the problem recurs there.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package installation-report - 2.31ubuntu2

---------------
installation-report (2.31ubuntu2) hardy-proposed; urgency=low

  * Run gzip chrooted to /target rather than in the installer environment,
    since busybox-udeb isn't configured with gzip support, only gunzip
    (LP: #337276).

 -- Colin Watson <email address hidden> Thu, 04 Jun 2009 21:07:35 +0100

Changed in installation-report (Ubuntu Hardy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers