Merge with Debian 20110122

Bug #887663 reported by Jeremy Bicha on 2011-11-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
installation-guide (Ubuntu)
Undecided
Unassigned

Bug Description

See the attached merge proposal for more details.

installation-guide (20110122) unstable; urgency=low

  [ Frans Pop ]
  * List myself as one of the main authors in the administrativa appendix.
  * Clarify IP addresses in example for booting SS4000-E (arm). Thanks to
    Miroslav Kure for the patch.
  * Add link to boot screen section in accessibility section. Closes: #579954.

  [ Martin Michlmayr ]
  * Update links for ARM images.

  [ Samuel Thibault ]
  * Update brltty version.
  * Document booting from DOS (Closes: Bug#518808).
  * Add non-Linux infrastructure to the build system.
  * Add kFreeBSD infrastructure.
  * Replace Linuxish bits with per-port entities.
  * Rephrase Hurd-specific paragraph explaining that Debian GNU/Hurd is not
    Linux.
  * Add a "What is Debian GNU/kFreeBSD" section.
  * Add the list of architectures supported by the kFreeBSD port.
  * Restrict "Board Devices" accessibility section to Linux.
  * Fix port URL for non-Linux ports.
  * Fix "hardware" part for non-Linux ports. Now needs fine-tune from BSD
    people.
  * Fix "boot-installer" part for non-Linux ports. Still needs extensive
    review from BSD people.
  * Fix "preparing", "using-d-i", "boot-new", "post-install", "howto",
    "preseed", "partitioning", and "random-bits" parts for non-Linux ports.
  * Factorize os-specific parameters in build/arch-options.
  * Rename debian entity to debian-gnu. Introduce new debian entity which just
    stands for "Debian".
  * Rename Mandrake into Mandriva (Closes: Bug#601308).
  * Update installation sizes for amd64 instead of i386.
  * Mention Windows 2003, Vista, and 7.
  * Fix graphical boot options.
  * Move user setup to before clock setup in "Using the Debian Installer" and
    "Automating the installation using preseeding".
  * Document dpkg-reconfigure keyboard-configuration instead of kbd-config.
  * Add installation-guide-kfreebsd-{i386,amd64} packages.
  * Reference Debian Installer modules documentation from the preseed section
    (Closes: Bug#603159).
  * Move boot parameters subsections from inside the debian installer parameters
    section, to which they don't really belong.
  * Make subsection Installation Over the Network a direct child of Using
    Individual Components instead of hiding it in "Miscellaneous".
  * Rename 6.3.8 "Miscellaneous" into "Troubleshooting".
  * Fix default tftp directory from /var/lib/tftpboot to /srv/tftp, thanks
    Charles Plessy (Closes: Bug#606725).
  * Enable Spanish and Swedish translations (almost up-to-date).
  * Reword i386 and amd64 arch names to be consistent with the corresponding
    release-notes change: Intel x86 → 32-bit PC, AMD64 → 64-bit PC.
  * Add keyboard-configuration/xkb-keymap preseed variable.
    (Closes: Bug#599772)

  [ Joey Hess ]
  * Update USB stick documentation to reflect isohybird mini.iso files,
    as generated by debian-installer >= 20100913.

  [ Christian Perrier ]
  * Remove obsolete reference to the replicator package
    Closes: #597983

  [ Maximilian Attems ]
  * Remove obsolete reference to kernel-img.conf

  [ Colin Watson ]
  * Fix "/etc/init.d/dhcpd3-server" typo (should be
    /etc/init.d/dhcp3-server), and unfuzzy all translations (LP: #666726).

  [ Joey Hess ]
  * Updated USB stick documentation to describe the much simpler, more
    flexible, and likely more robust use of isohybrid images. All i386
    and amd64 ISO images are now isohybrid.
  * Remove documentation of no longer supported
    grub-installer/grub2_instead_of_grub_legacy preseed. Closes: #610739

 -- Christian Perrier <email address hidden> Sat, 22 Jan 2011 13:16:49 +0100

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: installation-guide-amd64 20100518ubuntu5
ProcVersionSignature: Ubuntu 3.1.0-2.3-generic 3.1.0
Uname: Linux 3.1.0-2-generic x86_64
ApportVersion: 1.25-0ubuntu1
Architecture: amd64
Date: Tue Nov 8 12:06:44 2011
Dependencies:

PackageArchitecture: all
SourcePackage: installation-guide
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Jeremy Bicha (jbicha) wrote :
Timo Aaltonen (tjaalton) wrote :

You need to get rid of "preseed-X" part of en/appendix/preseed.xml, it got removed from Debian already

http://anonscm.debian.org/viewvc/d-i/trunk/manual/en/appendix/preseed.xml?r1=56148&r2=56249

though they still have it in the translated versions, you could remove those as well (filed bug 655210 to Debian about it).

Timo Aaltonen (tjaalton) wrote :

note that by removing that section you'd fix bug 881984

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in installation-guide (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (26.7 KiB)

This bug was fixed in the package installation-guide - 20150528ubuntu1

---------------
installation-guide (20150528ubuntu1) xenial; urgency=low

  * Merge from Debian unstable; LP: #887663.
    - fixes a wrong init script name for dhcpd. LP: #666726.
    - fixes a typo in the table of memory requirements. LP: #1030336.
    - drops obsolete mention of 2.6 kernels in keyboard preseeding.
      LP: #1000354.
    - fixes wrong make-kpkg example invocation. LP: #1019906.
    - fixes stale link to debian-installer subversion repo. LP: #1233732.
  * Remaining changes:
    - Extensive (although possibly incomplete) Ubuntu branding, adjustments
      for our mirror layout, etc.
    - Build only English (for now, until we figure out how to avoid trashing
      translations quite so badly with Ubuntu branding etc.).
    - Drop build-dependency on poxml for now, since we don't ship any
      translations.
    - Add "Ubuntu and Debian" and "What is Ubuntu?" section, text borrowed
      from the Ubuntu web site. Disable the "What is Debian GNU/Linux?"
      section.
    - Build only Ubuntu architectures (amd64, arm64, armhf, i386, powerpc,
      ppc64el, s390x).
    - Direct installation reports to ubuntu-users for now.
    - Document mounting /sys in various places.
    - Update chroot-install guide for language packs; add
      a bit more advice about installing grub.
    - Document our root password and sudo arrangements.
    - Adjust various memory and disk space requirements. Talk about the
      default Ubuntu desktop and Ubuntu tasks rather than Debian tasks.
    - Document network-console/authorized_keys_url feature
    - Document mirror/udeb/components.
    - Document scheme for preseeding the use of CC.archive.ubuntu.com
      mirrors.
    - Document how to override the weak password check.
    - Document preseeding user-setup's home directory encryption facility.
    - Document new simplified partman preseeding.
    - Document partman-auto-lvm/guided_size.
    - Document partman/default_filesystem.
    - Document live-installer/net-image.
    - Improve examples of tasksel/first preseeding to avoid mentioning
      standard, which is installed by default.
    - Document pkgsel/update-policy.
    - Document pkgsel/updatedb.
    - Document apt-setup/security_path.
    - Disable documentation of win32-loader.
    - Document netboot-style USB images. Still mention the hd-media images,
      but they're downplayed since many USB sticks are too small for a full
      Ubuntu ISO image.
    - Retain delta for commented-out OldWorld Mac support because it's easier
      than reverting it; but at this point OldWorld Macs will almost
      certainly never be supported in Ubuntu or Debian.
    - Remove comments about automatic installation methods that have been
      removed from Ubuntu.
    - Document Kickstart installations.
    - Unset supports-floppy-boot for all our architectures.
    - Don't recommend passing http://archive.ubuntu.com/ubuntu to
      debootstrap.
    - Document that i586 processors and i686 without cmov are no longer
      supported.
  * Dropped changes, included in Debian:
    - Update keyboard preseeding documentation for conso...

Changed in installation-guide (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments