s390-dasd module does not perform with preseed file

Bug #1572941 reported by bugproxy on 2016-04-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu on IBM z Systems
Critical
Dimitri John Ledkov
installation-guide (Ubuntu)
Wishlist
Skipper Bug Screeners
Xenial
High
Unassigned
s390-dasd (Ubuntu)
High
Dimitri John Ledkov
Xenial
Medium
Dimitri John Ledkov

Bug Description

[Impact]

 * Enable preseeding activation of dasd drives, and formating them with dasdfmt. Otherwise, unattended installation cannot be preseeded.

[Test Case]

 * perform unattanded installation onto dasd drives:
 - single, unformatted
 - single, formatted
 - single, formatted, force reformat
 - multiple dasd drives

[Regression Potential]

 * Interractive code path is unchanged, when no keys are preseeded. Code follows closely s390-zfcp preseed logic.

[Other Info]

 * New preseed keys:

d-i s390-dasd/dasd string 0.0.0200,0.0.0201
d-i s390-dasd/auto_format boolean false
(true, if dasd key used above)
d-i s390-dasd/force_format boolean false

== Comment: #1 - Ekaterina Teplova <email address hidden> - 2016-04-20 05:41:13 ==
Installer version 20101020ubuntu431
Started installation with preseed file. Installation stops at formatting step (s390-dasd preseed statement).

Attaching syslog and hardware-summary.

Could you please document in Release Notes the following restriction for Ubuntu16.04:

"It is currently not possible to perform a fully unattended installation on DASD devices."

bugproxy (bugproxy) on 2016-04-21
tags: added: architecture-s39064 bugnameltc-140503 severity-high targetmilestone-inin---
Changed in ubuntu:
assignee: nobody → Skipper Bug Screeners (skipper-screen-team)
affects: ubuntu → installation-guide (Ubuntu)
Dimitri John Ledkov (xnox) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Committed
status: Fix Committed → Fix Released
bugproxy (bugproxy) on 2016-04-21
tags: added: targetmilestone-inin1604
removed: targetmilestone-inin---
Changed in installation-guide (Ubuntu):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in installation-guide (Ubuntu):
status: New → Confirmed
dann frazier (dannf) on 2016-04-26
Changed in ubuntu-z-systems:
status: New → Confirmed
importance: Undecided → High
Changed in ubuntu-z-systems:
assignee: nobody → Dimitri John Ledkov (xnox)
Changed in ubuntu-z-systems:
status: Confirmed → In Progress
importance: High → Critical
summary: - [Document in Release Notes] s390-dasd module does not perform with
- preseed file
+ s390-dasd module does not perform with preseed file
Changed in s390-dasd (Ubuntu):
status: New → In Progress
assignee: nobody → Dimitri John Ledkov (xnox)
importance: Undecided → High
tags: added: block-proposed
Dimitri John Ledkov (xnox) wrote :

Fully preseeded installation verified, releasing s390-dasd update in yakkety.

tags: removed: block-proposed
Changed in s390-dasd (Ubuntu Xenial):
status: New → Confirmed
importance: Undecided → Medium
assignee: nobody → Dimitri John Ledkov (xnox)
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-dasd - 0.0.36ubuntu2

---------------
s390-dasd (0.0.36ubuntu2) yakkety; urgency=medium

  * Inproduce preseed step in the state machine, based on s390-zfcp
    implementation. LP: #1572941
  * Add s390-dasd/dasd key to preseed dasd drives to be activated, using
    this key also enables auto_format if it wasn't explicitely specified.
  * Add s390-dasd/auto_format and s390-dasd/force_format preseed only keys
    to dasdfmt devices when needed and always.
  * Use chzdev to activate devices and block until they are ready to be
    used, otherwise dasdfmt fails.
  * Add more error messages when opening and reading geometry of the
    device, prior to dasdfmt.
  * Fix di_snprintfcat compiler warning.

 -- Dimitri John Ledkov <email address hidden> Wed, 18 May 2016 12:46:15 +0100

Changed in s390-dasd (Ubuntu):
status: In Progress → Fix Released

Hello bugproxy, or anyone else affected,

Accepted s390-dasd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/s390-dasd/0.0.36ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in s390-dasd (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in ubuntu-z-systems:
status: In Progress → Fix Committed

------- Comment From <email address hidden> 2016-05-23 05:49 EDT-------
Will be fixed within Xenial.

Changed in ubuntu-z-systems:
status: Fix Committed → Fix Released
Dimitri John Ledkov (xnox) wrote :

Verification performed with fully unattended preseed, appended to the initramfs, using proposed udebs to pull in the new s390-dasd, and it successfully completes.

Please release this update to xenial-updates.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package s390-dasd - 0.0.36ubuntu1.1

---------------
s390-dasd (0.0.36ubuntu1.1) xenial; urgency=medium

  * Inproduce preseed step in the state machine, based on s390-zfcp
    implementation. LP: #1572941
  * Add s390-dasd/dasd key to preseed dasd drives to be activated, using
    this key also enables auto_format if it wasn't explicitely specified.
  * Add s390-dasd/auto_format and s390-dasd/force_format preseed only keys
    to dasdfmt devices when needed and always.
  * Use chzdev to activate devices and block until they are ready to be
    used, otherwise dasdfmt fails.
  * Add more error messages when opening and reading geometry of the
    device, prior to dasdfmt.
  * Fix di_snprintfcat compiler warning.

 -- Dimitri John Ledkov <email address hidden> Wed, 18 May 2016 12:46:15 +0100

Changed in s390-dasd (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for s390-dasd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Dimitri John Ledkov (xnox) wrote :

Documentation added in the temporary location:
https://wiki.ubuntu.com/S390X

From there -> there is link to automating installations with preseeds -> https://wiki.ubuntu.com/S390X/InstallationGuide/AutomatedInstallsWithPreseed which lists s390-dasd/dasd keys and auto_format/force_format.

Subsequently this will be moved to the Installer guide. This task should be considered as fixed.

Changed in installation-guide (Ubuntu Xenial):
status: New → Fix Released
Changed in installation-guide (Ubuntu):
importance: High → Wishlist

------- Comment From <email address hidden> 2016-06-20 13:29 EDT-------
I successfully verified the fix in s390-dasd, which means, I could perform various fully automated installations via preseed.
Since the fix is now in /pool/main, I highly recommend to remove the "apt-setup/proposed=true" statement in the example parmfile in https://wiki.ubuntu.com/S390X/InstallationGuide/AutomatedInstallsWithPreseed.
Thanks for the implementation! Closing this bug now.

Frank Heimes (frank-heimes) wrote :

It got removed from the example, but is still mentioned in in a side note and for reference, just in case of any new upcoming new preseed feature that will require proposed ...
Thx for testing, verification and feedback !

Changed in installation-guide (Ubuntu Xenial):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers