installation guide needs to point to ports.ubuntu.com for PowerPC images

Bug #1391019 reported by Scott Connerly on 2014-11-10
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
installation-guide (Ubuntu)
Undecided
Unassigned

Bug Description

I'm attempting to install Ubuntu on a PowerPC machine.

I started here:
https://wiki.ubuntu.com/PowerPCFAQ#Which_Macs_are_compatible_with_Ubuntu.3F
which directed me to:

The installation guide I'm attempting to follow (and where I believe the documentation bug is)
https://help.ubuntu.com/12.04/installation-guide/powerpc/index.html

It directs me to download the *.iso files from here:
http://archive.ubuntu.com/ubuntu/dists/precise/main/installer-powerpc/current/images
which yields a 404. Its as if the PowerPC section has been removed from the archive, or moved elsewhere.

While we're at it, whenever the solution is determined, we should probably share it with
https://www.jeremymorgan.com/tutorials/linux/how-to-install-linux-ppc-powerbook-g4/
as he has the highest ranked article on how to install Ubuntu on a PowerBook G4 (a popular PowerPC machine)

Oliver Grawert (ogra) wrote :

http://ports.ubuntu.com/ubuntu-ports/dists/precise/main/ has them ... i adjusted the bug title accordingly

summary: - PowerPC downloads missing
+ installation guide needs to point to ports.ubuntu.com for PowerPC images
Changed in installation-guide (Ubuntu):
status: New → Confirmed
Launchpad Janitor (janitor) wrote :
Download full text (26.7 KiB)

This bug was fixed in the package installation-guide - 20150528ubuntu1

---------------
installation-guide (20150528ubuntu1) xenial; urgency=low

  * Merge from Debian unstable; LP: #887663.
    - fixes a wrong init script name for dhcpd. LP: #666726.
    - fixes a typo in the table of memory requirements. LP: #1030336.
    - drops obsolete mention of 2.6 kernels in keyboard preseeding.
      LP: #1000354.
    - fixes wrong make-kpkg example invocation. LP: #1019906.
    - fixes stale link to debian-installer subversion repo. LP: #1233732.
  * Remaining changes:
    - Extensive (although possibly incomplete) Ubuntu branding, adjustments
      for our mirror layout, etc.
    - Build only English (for now, until we figure out how to avoid trashing
      translations quite so badly with Ubuntu branding etc.).
    - Drop build-dependency on poxml for now, since we don't ship any
      translations.
    - Add "Ubuntu and Debian" and "What is Ubuntu?" section, text borrowed
      from the Ubuntu web site. Disable the "What is Debian GNU/Linux?"
      section.
    - Build only Ubuntu architectures (amd64, arm64, armhf, i386, powerpc,
      ppc64el, s390x).
    - Direct installation reports to ubuntu-users for now.
    - Document mounting /sys in various places.
    - Update chroot-install guide for language packs; add
      a bit more advice about installing grub.
    - Document our root password and sudo arrangements.
    - Adjust various memory and disk space requirements. Talk about the
      default Ubuntu desktop and Ubuntu tasks rather than Debian tasks.
    - Document network-console/authorized_keys_url feature
    - Document mirror/udeb/components.
    - Document scheme for preseeding the use of CC.archive.ubuntu.com
      mirrors.
    - Document how to override the weak password check.
    - Document preseeding user-setup's home directory encryption facility.
    - Document new simplified partman preseeding.
    - Document partman-auto-lvm/guided_size.
    - Document partman/default_filesystem.
    - Document live-installer/net-image.
    - Improve examples of tasksel/first preseeding to avoid mentioning
      standard, which is installed by default.
    - Document pkgsel/update-policy.
    - Document pkgsel/updatedb.
    - Document apt-setup/security_path.
    - Disable documentation of win32-loader.
    - Document netboot-style USB images. Still mention the hd-media images,
      but they're downplayed since many USB sticks are too small for a full
      Ubuntu ISO image.
    - Retain delta for commented-out OldWorld Mac support because it's easier
      than reverting it; but at this point OldWorld Macs will almost
      certainly never be supported in Ubuntu or Debian.
    - Remove comments about automatic installation methods that have been
      removed from Ubuntu.
    - Document Kickstart installations.
    - Unset supports-floppy-boot for all our architectures.
    - Don't recommend passing http://archive.ubuntu.com/ubuntu to
      debootstrap.
    - Document that i586 processors and i686 without cmov are no longer
      supported.
  * Dropped changes, included in Debian:
    - Update keyboard preseeding documentation for conso...

Changed in installation-guide (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers