package inn2 2.5.0-1ubuntu not installed failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #511437 reported by sirtao on 2010-01-23
104
This bug affects 13 people
Affects Status Importance Assigned to Milestone
inn2 (Debian)
Fix Released
Unknown
inn2 (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: inn2

ubuntu 9.10
2.5.0-1ubuntu

ProblemType: Package
Architecture: i386
Date: Sat Jan 23 02:10:09 2010
DistroRelease: Ubuntu 9.10
ErrorMessage: subprocess installed post-installation script returned error exit status 1
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
Package: inn2 (not installed)
ProcVersionSignature: Ubuntu 2.6.31-17.54-generic
SourcePackage: inn2
Title: package inn2 (not installed) failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
Uname: Linux 2.6.31-17-generic i686

sirtao (sirtao) wrote :
Mitch Towner (kermiac) wrote :

I can confirm this on an up-to-date stock standard install of Karmic.

Setting up inn2 (2.5.0-1ubuntu1) ...
innconfval: hostname does not resolve or domain not set in inn.conf
dpkg: error processing inn2 (--configure):
 subprocess installed post-installation script returned error exit status 1
Setting up bsd-mailx (8.1.2-0.20081101cvs-2ubuntu1) ...
update-alternatives: using /usr/bin/bsd-mailx to provide /usr/bin/mailx (mailx) in auto mode.
Setting up mailx (1:20081101-2ubuntu1) ...
Errors were encountered while processing:
 inn2
E: Sub-process /usr/bin/dpkg returned an error code (1)

$ uname -a
Linux ubuntu 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 16:20:31 UTC 2009 i686 GNU/Linux

Changed in inn2 (Ubuntu):
status: New → Confirmed

confirmed on lucid inn2/lucid uptodate 2.5.1-1

problem is that hostname needs to be a FQDN for inn2 postinst to work. if its a local name like mycomputer then inn2 will fail with the error. whereas if hostname is set to something like mycomputer.org, then inn2 will configure fine.

could also fix by specifying the domain: parameter in /etc/news/inn.conf either to the hostname, FQDN or not. Is this wise though? Or should the install really just fail
I suppose in post install you could check first for
$ /usr/lib/news/bin/innconfval -C
innconfval: hostname does not resolve or domain not set in inn.conf

and if so then get hostname --fqdn and add this as the domain: parameter. This would allow installation without failure but would mean that inn.conf could contain
domain: SomeLocalName

Is that a reasonable thing to do though?

Or prompt the user to set domainname instead of just failing

i've mentioned it to debian and their happy to have the postinst abort in this case rather than add any additional checks. should this be a won't fix then?

Hi,

Thanks for getting back to me on this. Sadly, on busy with an international
move at the moment and cannot be of any help wiothout my machines...

Thank you for your attention, though!

J.

On Sat, Jan 23, 2010 at 17:25, SevenMachines <email address hidden>wrote:

> i've mentioned it to debian and their happy to have the postinst abort
> in this case rather than add any additional checks. should this be a
> won't fix then?
>
> --
> package inn2 2.5.0-1ubuntu not installed failed to install/upgrade:
> subprocess installed post-installation script returned error exit status 1
> https://bugs.launchpad.net/bugs/511437
> You received this bug notification because you are a direct subscriber
> of a duplicate bug.
>

Changed in inn2 (Debian):
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.