inkscape crashed with SIGSEGV in Avoid::VertInf::removeFromGraph()

Bug #977003 reported by Arthur Rodrigues on 2012-04-09
50
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Johan Engelen
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

I was having huge difficulties to finish an image in which I was using diagram connectors to draw arrows between circles (a graph, for those who know what it is).

At some point, I needed to draw the curved arrows in the image attached, and every time I needed to move the drawing or do anything with the arrows, like changing the markers' colors, these curved arrows kept turning into straight ones again, over and over.

After a million times going like this, I asked inkscape to render a latex formula for me and, when the formula was ready, the arrows simply disappeared!

This is everything that I remember happening before the crash.

ProblemType: Crash
DistroRelease: Ubuntu 11.10
Package: inkscape 0.48.2-0ubuntu1
ProcVersionSignature: Ubuntu 3.0.0-17.30-generic 3.0.22
Uname: Linux 3.0.0-17-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Mon Apr 9 02:49:18 2012
ExecutablePath: /usr/bin/inkscape
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
ProcCmdline: inkscape
SegvAnalysis:
 Segfault happened at: 0x8822f11 <_ZN5Avoid7VertInf15removeFromGraphEb+17>: cmpb $0x0,0x8(%esi)
 PC (0x08822f11) ok
 source "$0x0" ok
 destination "0x8(%esi)" (0x00000008) not located in a known VMA region (needed writable region)!
SegvReason: writing NULL VMA
Signal: 11
SourcePackage: inkscape
Stacktrace:
 #0 0x08822f11 in Avoid::VertInf::removeFromGraph(bool) ()
 No symbol table info available.
 Não é possível acessar a memória no endereço 0xbfdedfac
StacktraceTop: Avoid::VertInf::removeFromGraph(bool) ()
Title: inkscape crashed with SIGSEGV in Avoid::VertInf::removeFromGraph()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: admin audio cdrom colord dialout fax fuse plugdev pulse-access saned scanner sudo users vboxusers voice

Arthur Rodrigues (araruna) wrote :
tags: removed: need-duplicate-check

StacktraceTop: Avoid::VertInf::removeFromGraph(bool) ()

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
Alex Valavanis (valavanisalex) wrote :

Possible duplicates..?

bug #965051 <inkscape hangs when edit/cut objects>
bug #837631 <Crash when grouping objects+connectors across different layers>

visibility: private → public
tags: added: connectors crash
su_v (suv-lp) wrote :

Alex Valavanis wrote:
> Possible duplicates..?
>
> bug #965051 <inkscape hangs when edit/cut objects>
> bug #837631 <Crash when grouping objects+connectors across different layers>

Based on the backtrace, possibly - but without the SVG file the reported crash cannot be further investigated (a screenshot or bitmap export doesn't really help).

Arthur Rodrigues wrote:
> At some point, I needed to draw the curved arrows in the image
> attached, and every time I needed to move the drawing or do anything
> with the arrows, like changing the markers' colors, these curved
> arrows kept turning into straight ones again, over and over.

Connectors do not keep manual edits - they are lost each time a reouting of the connectors is triggered (see also bug #168748, bug #740802 and bug #942308). Either draw regular paths with the pen tool, or adjust the curvature of the connectors using the options on the connector tool controls bar.

Related manual section:
<http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Connectors-Modifying.html#Connectors-Modifying-Routing>

Changed in inkscape:
status: New → Incomplete
Arthur Rodrigues (araruna) wrote :

Well, there is the svg I was working on. I don't remember changing it much after I filed this bug., but I don't guarantee it.
When I opened it a few seconds ago, the arrows dislayed in the png I attached earlier were completely messed up.

I don't remember if I told what version of inkscape I was using, but either way, it's the 0.48.3.1 r9886 (according tho the "About inkscape" menu option).

I remember that even if I deleted the messed edges and recreated them (using the connector), the problem still happened.

Thanks for your time,

jazzynico (jazzynico) wrote :

Since the document has only one layer, it's more likely a duplicate of bug #965051 <inkscape hangs when edit/cut objects>.
But I still can't reproduce it with the attached file (didn't try too hard, though).

su_v (suv-lp) wrote :

Steps to reproduce a crash (unclear to me though whether this is what happened to the reporter):
1) open 'todos.svg'
2) select the group of connectors for the bottom-left diagram
   (note: only one of them initially appears to connect two of the circles, the others have zero-length at the SVG origin -> this is tracked already in other reports)
3) ungroup it
   (connectors are now rendered at expected positions)
4) drag a selection frame around the bottom-left diagram
5) group the selection

-> crash (see attached backtrace from r11513, OS X 10.7.4, 64bit).

jazzynico (jazzynico) wrote :

On the other hand, bug #837631 <Crash when grouping objects+connectors across different layers> is more about grouping than layers...

jazzynico (jazzynico) wrote :

Reproduced on Ubuntu 11.04, Inkscape trunk revision 11513.
"Fixing" as explained bug #837631 comment #6 doesn't work here.

Changed in inkscape:
importance: Undecided → High
status: Incomplete → Confirmed
jazzynico (jazzynico) on 2012-06-26
Changed in inkscape (Ubuntu):
status: New → Confirmed
jazzynico (jazzynico) wrote :

Also crashes on Windows XP, Inkscape trunk revision 12228.

Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Johan Engelen (johanengelen) wrote :

fixed in rev. 13413

because of constructor "ConnRef(Router *router, const unsigned int id)", _srcVert and _dstVert can be NULL, and _active can be false. this constructor seems unfinished, but is used elsewhere in the code. hence the crash.

Changed in inkscape:
assignee: nobody → Johan Engelen (johanengelen)
milestone: none → 0.91
status: Triaged → Fix Committed
Johan Engelen (johanengelen) wrote :

correction: fixed in experimental rev 13413, trunk rev 13444

Changed in inkscape (Ubuntu):
status: Triaged → Fix Committed
Alex Valavanis (valavanisalex) wrote :

Fix committed upstream (not committed in Ubuntu yet)

Changed in inkscape (Ubuntu):
status: Fix Committed → Triaged
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Debian):
status: Unknown → Confirmed
Changed in inkscape (Debian):
status: Confirmed → Fix Released
Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.