inkscape crashed with SIGSEGV in sp_dtw_color_profile_event()

Bug #966441 reported by sam tygier on 2012-03-27
56
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Kris
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

inkscape had some documents open over nautilus's ssh mount. i was not doing anythin at the time.

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: inkscape 0.48.3.1-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-20.32-generic 3.2.12
Uname: Linux 3.2.0-20-generic x86_64
ApportVersion: 1.95-0ubuntu1
Architecture: amd64
Date: Tue Mar 27 18:50:23 2012
ExecutablePath: /usr/bin/inkscape
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120108)
ProcCmdline: inkscape
ProcEnviron:
 LANGUAGE=en_GB:en
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: inkscape
Title: inkscape crashed with SIGSEGV in g_signal_emit_valist()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

sam tygier (samtygier) wrote :

StacktraceTop:
 sp_dtw_color_profile_event (dtw=0xc35c400) at widgets/desktop-widget.cpp:783
 _g_closure_set_va_marshal (closure=0xa, marshal=0) at /build/buildd/glib2.0-2.32.0/./gobject/gclosure.c:885
 ?? ()

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
summary: - inkscape crashed with SIGSEGV in g_signal_emit_valist()
+ inkscape crashed with SIGSEGV in sp_dtw_color_profile_event()
tags: removed: need-amd64-retrace
visibility: private → public
tags: added: crash
Changed in inkscape:
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Kris (kris-degussem) on 2013-02-23
Changed in inkscape:
status: New → In Progress
assignee: nobody → Kris (kris-degussem)
milestone: none → 0.49
Kris (kris-degussem) wrote :

Could not check/invoke the error myself, although the bug is quite probably due to a missing null pointer check. Added this check in trunk revision 12141.

Changed in inkscape:
status: In Progress → Fix Committed
Kris (kris-degussem) on 2013-03-05
tags: added: backport-proposed
su_v (suv-lp) wrote :

Backported to lp:inkscape/0.48.x in revision 9961.

Changed in inkscape:
milestone: 0.49 → 0.48.5
Kris (kris-degussem) on 2013-12-11
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.5-2ubuntu1

---------------
inkscape (0.48.5-2ubuntu1) utopic; urgency=medium

  * Merge with Debian Unstable (LP: #1358863). Fixes several Ubuntu bugs:
    - Illustrator CS SVG won't load: namespace URIs in entities (LP: #166371)
    - inkscape crashed with SIGSEGV in
      sp_dtw_color_profile_event() (LP: #966441)
    - inkscape crashed with SIGSEGV (LP: #1051017)
    - inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
      (LP: #1163241)
    - save a copy reverts to save as (LP: #529843)
    - Extension to braille not working on Xubuntu 12.10 (LP: #1090865)
  * Remaining changes:
    - debian/control:
      + Set Ubuntu Developer as maintainer,
      + build-depend on dh-translation to handle Ubuntu translation,
      + demote pstoedit from Recommends to Suggests (because it's in universe),
    - debian/patches/0006_add_unity_quicklist_support.patch: add.
    - debian/patches/series: update.
    - debian/rules:
      + add dh_translation to handle Ubuntu translation
  * Drop debian/patches/librevenge.patch (superseded by
      debian/patches/0006-Update_to_new_libwpg.patch)

inkscape (0.48.5-2) unstable; urgency=medium

  * debian/patches/: patchset updated
    - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
      Thanks to Rene Engelhard (rene) for the patch.
  * debian/control: build-dependencies updated
    - librevenge-dev added
    - libwpd-dev (>= 0.9.0) dropped
    - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
  * debian/: dh-autoreconf usage applied

inkscape (0.48.5-1) unstable; urgency=medium

  [ Luca Bruno ]
  * debian/rules: fix FTBFS on alpha (Closes: #738155)

  [ Mattia Rizzolo ]
  * debian/patches/: patchset updated against v0.48.5
    - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
    - 0005-Fix_FTBFS_due_to_tests.patch added

  [ Matteo F. Vescovi ]
  * Imported Upstream version 0.48.5
 -- Alex Valavanis <email address hidden> Tue, 19 Aug 2014 19:10:32 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers