Ubuntu

Messages dialog doesn't work

Reported by John Smith on 2012-01-03
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Low
John Smith
inkscape (Ubuntu)
Low
Unassigned

Bug Description

The View > Messages dialog currently doesn't seem to work

1. There seems to be no way to start capturing the log messages in the Messages dialog (apparently there is a menu in the dialog, but it doesn't appear in Ubuntu)

2. Setting the preference 'dialogs > debug > redirect =1' as suggested in the dialog does not capture messages to that dialog.
Instead Inkscape on startup sends messages to a separate 'Debug' dialog, not the dialog that open via View > Messages.

I suggest as a first step adding a button to the Message dialog to enable capturing the log messages.

John Smith (john-smithi) wrote :

Ubuntu 11.10 / 0.48.2 (r9819)

~suv (suv-lp) wrote :

Not reproduced with Inkscape 0.48+devel r10828 on OS X 10.7.2 Lion

A simple way to produce an internal console message:

1) switch to text tool
2) do not click on the canvas (use <esc> to deselect any selected text object)
3) change the default font by overwriting it with a non-existing font name

-> pango-related warning is captured by the dialog.

(Note: to reset the default font, it is best to open 'Text > Text & Font', select the font 'Sans' in the left list, adjust the font size (default is 40px), and click on 'Set as default')

~suv (suv-lp) wrote :

Also works (with above 'steps to produce') in Inkscape 0.48.2 on OS X 10.7.2 Lion.

~suv (suv-lp) wrote :

Omitted from the 'steps to produce':

0) open 'View > Messages…'
    in the dialog: 'File > Clear', 'File > Capture log messages'

No manual edits to ~/.config/inkscape/preferences.xml - works with default (new) preferences.

John Smith (john-smithi) wrote :

> 1. There seems to be no way to start capturing the log messages

I'll mark this as Ubuntu only, since the 'File' menu in this dialog is not visible.
Is this the only dialog that uses a menu ?
Shall we replace the menu with buttons (see attached) to match other dialogs ?

> 2. Setting the preference does not capture messages to that dialog

This still seems valid, we should remove this message about setting this preference since it doesn't work.

Changed in inkscape:
assignee: nobody → John Smith (john-smithi)
~suv (suv-lp) wrote :

> Shall we replace the menu with buttons (see attached) to match other dialogs ?

It might be interesting to first figure out why the menu doesn't show up for you on Ubuntu, and compare it to other linux distros and Inkscape on Windows as well. Attaching a screenshot with plain (Raleigh) Gtk+ theme, showing the content of the 'File' menu of the docked dialog.

> This still seems valid, we should remove this message about
> setting this preference since it doesn't work.

Agreed - it might be useful though to try to first figure out
- why the message is there in the first place
- what happens/happened with the "other" debug dialog you mentioned
- whether the hidden preference referred to is relevant today, on which platforms, and
- how it needs to be defined within the current prefs structure
- …

I'm against doing a quick change without checking the background/history of the dialog and its intended (original) purpose.

Some quick search results:
> You might have noticed the DebugDialog, which is found
> from the View/Messages... menuitem. It is a trivial text
> window, whose only current purpose is to catch g_log(),
> g_message(), g_warning(), etc messages, and
> print them in the GUI, instead of writing to the terminal.
>
> While Linux users might not consider this exciting, this
> will hopefully be a benefit to Win32 users. On Windows,
> that extra DOS console window popping up can be a
> terrible annoyance.
>
> So it is turned on by default on Win32, and can be turned
> on for other platforms by setting
>
> dialogs.debug redirect="1"
<http://article.gmane.org/gmane.comp.graphics.inkscape.devel/4867>

«Debugging output can now be redirected from console to the new Messages window (open via a command in the View menu). This redirection is on by default on Windows. »
<http://wiki.inkscape.org/wiki/index.php/Release_notes/0.40#Interface_and_usability>

>> Look in the View/Messages dialog. Use "Capture" and see what it
>> emits. These are the same messages that a person would see
>> on Unix.
>>
> Actually, that is not correct. What "capture" does is show you all of the
> debug messages that you output with g_message(), g_warning(), and
> g_error(). Nobody should be using printf() anyway.
>
> We made this dialog for us Win32 guys who are cursed with bad
> consoles. Damn those lazy arrogant Linux guys! ^^ :-)
<http://thread.gmane.org/gmane.comp.graphics.inkscape.devel/17875/focus=17878>

… to be continued.

jazzynico (jazzynico) wrote :

Not reproduced on Ubuntu 11.04 (classic gnome desktop).
Reproduced on Ubuntu 11.10 (Unity), Inkscape 0.48.2 and trunk.

Changed in inkscape:
importance: Undecided → Low
status: New → Confirmed
Changed in inkscape (Ubuntu):
status: New → Confirmed
John Smith (john-smithi) wrote :

There are 2 dialogs in the code with almost identical functionality:
1. Debug dialog - this is an older style dialog, that isnt connected to any menu/shortcut - so cant be shown right now
2. Message dialog - newer style dialog that can be shown from View > Messages

The only difference between the Dialogs "Capture" menu and the "Capture" preference is that the preference is set on startup, so captures almost all the errors, the dialog only starts capturing after the dialog is opened.

If the "capture" preference is set then Inkscape creates (but does not show) a Debug dialog on startup and sends output there. But when the user opens the View > Messages a Message dialog is created and shown. Message dialog does not capture the output from startup - hence the preference is not really working.

This probably worked in the past when View > Messages opened a Debug dialog, and the Debug dialog was simply shown (not created) on View > Messages.

Now days there is a dialog manager that controls creating/showing dialogs opened via the menu, but Inkscape is still independently creating a Debug dialog on startup (which the dialog manager doesn't know about).

So the solution to the preference problem is to have Inkscape ask the Dialog manager to create a Message dialog on startup.

John Smith (john-smithi) wrote :

Attached patch to :
a) Convert the dialog menu into buttons to be more consistent with other dialogs (it appears this is the only dialog that has its own menu), and work on Ubuntu 11.10.
b) Remove the message about setting a preference - since it currently doesn't work.

jazzynico (jazzynico) on 2012-01-09
Changed in inkscape:
milestone: none → 0.49
status: Confirmed → In Progress
jazzynico (jazzynico) wrote :

Looks good on Windows XP, Inkscape 10865.

It would be nice to have an accelerator on the Clear button ( _("_Clear") ) as it was in the original menu. It's good for usability, and don't break the original string in case we also want to patch the branch (0.48.3). The capture status messages are not an issue, they were not translated in 0.48.2...

Test on Ubuntu planned later. If there's no objection (OS X issue?), I'd like to commit the patch quickly.

~suv (suv-lp) wrote :

@JazzyNico:
> If there's no objection (OS X issue?)

Looks ok to me - quick test done with r10865 + patch on
- OS X Lion (64bit) with gtk2/x11 2.24.8
- Mac OS X Leopard (32bit) with gtk2/quartz 2.24.8

@John - my apologies for my earlier rejection of proposed changes, and thank you for the detailed explanation about the current situation.

jazzynico (jazzynico) wrote :

Fix committed in the branch (revision 9851) and the trunk (10866).
Thanks John!

Changed in inkscape:
milestone: 0.49 → 0.48.3
status: In Progress → Fix Committed

The attachment "911123.patch" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-reviewers team please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
tags: added: patch-accepted-upstream
removed: patch
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Ted Gould (ted) on 2012-02-15
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.3-0ubuntu1

---------------
inkscape (0.48.3-0ubuntu1) precise; urgency=low

  * New upstream release (LP: #933188). Fixes several Ubuntu bugs:
    - inkscape fails to build with glib 2.31 (LP: #898538)
    - ctrl c ctrl v of text in edit mode crashes inkscape (LP: #496793)
    - Completely replace lcms1 by lcms2 in Ubuntu (LP: #885324)
    - parameters ending with '\' causes python to bomb (LP: #168417)
    - Extensions with <check> tags fail to load (LP: #668895)
    - ESC doesn't cancel move when using the Node Tool (LP: #788560)
    - unable to edit attributes in Inkscape XML Editor (LP: #884368)
    - Some layers should be visible by default in Layers dialog (LP: #902054)
    - Path Effect List is hidden (LP: #909958)
    - Input Devices > Hardware > Tree of devices is hidden (LP: #910467)
    - Glyphs Font styles are hidden (LP: #911079)
    - Error messages from Extensions hidden (LP: #911079)
    - Messages dialog doesn't work (LP: #911123)
  * Drop 02-add-shebangs-and-fix-permissions.dpatch: Applied upstream.
  * Drop build-dependency on specific libwpd/libwpg version.
 -- Alex Valavanis <email address hidden> Thu, 16 Feb 2012 14:33:40 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers