Inkscape missing libgtkmm-2.4.so.1 dependency

Bug #842564 reported by seanyseansean on 2011-09-06
This bug report is a duplicate of:  Bug #843038: Inkscape linker issue on x86_64. Edit Remove
70
This bug affects 17 people
Affects Status Importance Assigned to Milestone
gtkmm2.4 (Ubuntu)
Undecided
Unassigned
inkscape (Ubuntu)
Undecided
Unassigned

Bug Description

I've clean installed Oneiric Ocelot beta 1 (x64). After installing Inkscape, it doesn't start. Running it from the terminal I get:

"inkscape: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory"

However, package libgtkmm-2.4-1c2a is pulled in. Any ideas?

seanyseansean (seany) wrote :

Further info: i've just reinstalled the lib:

  sudo apt-get install --reinstall libgtkmm-2.4-1c2a

... and it now works fine. This was definitely already installed, and the system is a basic x64 running Unity 3D. No other packages added apart from inkscape.

Alex Valavanis (valavanisalex) wrote :

Thanks for the report. Please could you run the following command to gather some extra information about your Inkscape installation?

apport-collect 842564

Changed in inkscape (Ubuntu):
status: New → Incomplete
Tyler Wright (mail-tylerwright) wrote :

This bug affected me, seanyseanyseany's fix worked for me too

daveclubb (daveclubb) wrote :

As for Tyler, same problem and fix worked. Thanks

Alex (zk118243) wrote :

This is still the case in 12.04 32 bit.

Viktor Pal (deere) wrote :

This is still the case in 14.04, fresh install.

The package state is installed:
# dpkg -l libgtkmm-2.4-1c2a
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name Version Architecture Description
+++-=====================================================-===============================-===============================-================================================================================================================
ii libgtkmm-2.4-1c2a:amd64 1:2.24.4-1ubuntu1 amd64 C++ wrappers for GTK+ (shared libraries)

But the files are all missing:
# dpkg -L libgtkmm-2.4-1c2a | xargs -n 1 ls -lad
drwxr-xr-x 23 root root 4096 Feb 10 22:07 /.
drwxr-xr-x 10 root root 4096 Nov 26 23:12 /usr
drwxr-xr-x 188 root root 24576 Feb 12 22:58 /usr/lib
drwxr-xr-x 84 root root 69632 Feb 12 01:31 /usr/lib/x86_64-linux-gnu
ls: cannot access /usr/lib/x86_64-linux-gnu/libgtkmm-2.4.so.1.1.0: No such file or directory
ls: cannot access /usr/lib/x86_64-linux-gnu/libgdkmm-2.4.so.1.1.0: No such file or directory
drwxr-xr-x 298 root root 12288 Feb 12 22:58 /usr/share
drwxr-xr-x 1910 root root 69632 Feb 12 22:58 /usr/share/doc
drwxr-xr-x 2 root root 4096 Nov 26 23:47 /usr/share/doc/libgtkmm-2.4-1c2a
ls: cannot access /usr/share/doc/libgtkmm-2.4-1c2a/copyright: No such file or directory
ls: cannot access /usr/share/doc/libgtkmm-2.4-1c2a/AUTHORS: No such file or directory
ls: cannot access /usr/share/doc/libgtkmm-2.4-1c2a/NEWS.gz: No such file or directory
ls: cannot access /usr/share/doc/libgtkmm-2.4-1c2a/README: No such file or directory
ls: cannot access /usr/share/doc/libgtkmm-2.4-1c2a/changelog.Debian.gz: No such file or directory
ls: cannot access /usr/lib/x86_64-linux-gnu/libgdkmm-2.4.so.1: No such file or directory
ls: cannot access /usr/lib/x86_64-linux-gnu/libgtkmm-2.4.so.1: No such file or directory

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gtkmm2.4 (Ubuntu):
status: New → Confirmed
Nick (xepecine) wrote :

Fresh install 16.04 same story.

$inkscape
inkscape: error while loading shared libraries: libgtkmm-2.4.so.1: cannot open shared object file: No such file or directory

sudo apt-get install --reinstall libgtkmm-2.4-1v5
fixed the problem.

Nkansah Rexford (seanmavley) wrote :

On 18.04, Re install doesn't fix the issue.
Something is fundamentally broken with 18.04.

Many of the applications that worked on 16.04 no longer work. Inkscape, Virtualbox, VLC, etc. All complains of missing something something.

Genc Tato (gtato6) wrote :

Confirm that it is not working on 18.04

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers