Inkscape suggests skencil and python as useless add-on packages

Bug #762541 reported by ani_mw on 2011-04-16
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
inkscape (Debian)
Fix Released
Unknown
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: software-center

Dia and some other programs are mentioned as add-ons but they're not,
I think there needs to be another category which says: Similar programs or something like that, in which these programs belong

Related branches

ani_mw (cr-anil) wrote :
Robert Roth (evfool) wrote :

This seems to be OK to me, as Dia is Suggested by the Inkscape package, because it adds additional exporting functionality to inkscape, thus is an Add-On to Inkscape. The Software Center explicitly states that a package suggested by another one should be treated as an add-on package of the package suggesting it. See https://wiki.ubuntu.com/SoftwareCenter#Add-on%20packages.

ani_mw (cr-anil) wrote :

Ahh... fair enough. Marking as invalid.

Changed in software-center (Ubuntu):
status: New → Invalid
Matthew Paul Thomas (mpt) wrote :

This is a bug in the inkscape package. It "Suggests: dia | dia-gnome", when it should not. It also "Suggests: skencil" and should not. (And I don't understand why it "Suggests: python".)

affects: software-center (Ubuntu) → inkscape (Ubuntu)
Changed in inkscape (Ubuntu):
status: Invalid → Confirmed
tags: added: metadata
Alex Valavanis (valavanisalex) wrote :

Inkscape provides an extension "dia.inx" that allows Dia files to be read by Inkscape. It is only enabled if dia is installed. I think "Suggests: dia" is fine here, because it adds extra functionality to Inkscape.

I can't see an obvious reason for "Suggests: skencil". The import/export extensions don't require it any more. "Suggests: python" is also clearly not needed. The "Recommends: python-*" explicitly list all non-standard python modules that would normally be needed for Inkscape extension scripts.

Changed in inkscape (Ubuntu):
assignee: nobody → Alex Valavanis (valavanisalex)
importance: Undecided → Low
status: Confirmed → Triaged
summary: - USC shows Dia as a addon to Inkscape.
+ Inkscape suggests skencil and python as useless add-on packages
Alex Valavanis (valavanisalex) wrote :

Added this to the branch I have been preparing for the next Ubuntu package version. @sponsors - please consider sponsoring the upload. Thanks

Changed in inkscape (Ubuntu):
assignee: Alex Valavanis (valavanisalex) → nobody
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-2ubuntu5

---------------
inkscape (0.48.1-2ubuntu5) oneiric; urgency=low

  * debian/rules: No need to manually call intltool-update on build. This
    is now handled by dh_translations.
  * debian/control: No longer suggest python and skencil. They do not
    offer any enhancement to Inkscape (LP: #762541)
  * debian/control: Suggest transfig to allow import of xfig files
    (LP: #668300)
  * debian/patches/02-add-shebangs-and-fix-permissions.dpatch:
    No longer mark JavaScript extension files as standalone executables
    (LP: #602005):
    - share/extensions/*.js: Revert addition of shebangs
    - share/extensions/Makefile.am: Install *.js using _DATA rule rather
      than _SCRIPTS rule to avoid giving executable permission
  * debian/patches/fix-fontforge-glyph-template.dpatch: Cherry-pick
    patch from uptream trunk to fix layer structure in template (LP: #565296)
 -- Alex Valavanis <email address hidden> Mon, 30 May 2011 18:50:49 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
Changed in inkscape (Debian):
status: Unknown → New
Duncan Lithgow (duncan-lithgow) wrote :

How come I'm still seeing this in a fresh install of Ubuntu 12.04?

I've got the default install in Ubuntu of Inkscape 0.48.3.1 r9886 which is older than the closure of this bug. What's going on?

Duncan Lithgow (duncan-lithgow) wrote :

Sorry, ignore my comment, I was frustrated about Dia being in there as an add-on but can see in comment 5 that this is consistent with ubuntu policy. Sorry for the noise.

Changed in inkscape (Debian):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.