Launcher - Add 'new document' option to Open Office, Gimp and Inkscape quicklists

Bug #676886 reported by John Lea on 2010-11-18
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
Critical
Unassigned
Inkscape
Wishlist
Alex Valavanis
Unity
Fix Released
Medium
Didier Roche
unity design (obsolete project)
Fix Released
Critical
Unassigned
unity-2d
Medium
Olivier Tilloy
inkscape (Ubuntu)
Medium
Unassigned
unity (Ubuntu)
Undecided
Unassigned
unity-2d (Ubuntu)
Undecided
Unassigned

Bug Description

Launcher - Add 'new document (or drawing, spreadsheet, etc...)' option to Open Office, Gimp and Inkscape quicklists

Description:

In user testing we found that users had difficulty creating new documents. To provide a shortcut to this common use case a 'new document' entry should be added to the quicklist of the following applications:

1) Open Office word processor - "New Document"
2) Open Office spreadsheet - "New Spreadsheet"
3) Open Office presentation - "New Presentation"
4) Gimp - "New Image"
5) Inkscape - "New Drawing"

Related branches

John Lea (johnlea) on 2010-11-18
Changed in unity-design:
status: New → Confirmed
tags: added: udn-launcher
John Lea (johnlea) on 2010-11-18
tags: added: udt
John Lea (johnlea) on 2010-11-18
Changed in unity-design:
status: Confirmed → Fix Released
importance: Undecided → Critical
John Lea (johnlea) on 2010-11-19
Changed in ayatana-design:
status: New → Fix Released
importance: Undecided → Critical
John Lea (johnlea) on 2010-11-19
Changed in ayatana-design:
status: Fix Released → Fix Committed
Changed in unity-design:
status: Fix Released → Fix Committed
John Lea (johnlea) on 2010-12-02
Changed in ayatana-design:
status: Fix Committed → Fix Released
Changed in unity-design:
status: Fix Committed → Fix Released
David Barth (dbarth) on 2010-12-02
Changed in unity:
status: New → Triaged
importance: Undecided → Medium
David Barth (dbarth) on 2010-12-02
Changed in unity:
assignee: nobody → Didier Roche (didrocks)
milestone: none → 3.2.4
Paul Sladen (sladen) wrote :

I was about to file-something about the sub-optimal use-case of opening a second/third/fourth GNOME Terminal instance... perhaps the same approach right-click approach could be taken for applications that generally need to be opened multiple times (this was one of the first things that I instinctively tried).

Neil J. Patel (njpatel) wrote :

Just to be clear, these should be implemented as desktop file shortcuts not as plugins. We also need to test that the shortcut loading works properly in the launcher.

Neil J. Patel (njpatel) wrote :

Gord added desktop shortcut support this week, so we should be good to go here.

Changed in unity:
milestone: 3.2.4 → 3.2.8
Didier Roche (didrocks) wrote :

ok, so from now on, in unity 3.2.6, we have "Open New Window" in quicklist by default to run multiple instance of applications.

This make the use of "create a new document" useless (or the wording should be changed for them, maybe?) As this has (or should have) the exactly same behavior of "create a new document". So quicklist items for those is useless? Or maybe, when we add the quicklist, we should have a way to remove "create a new document" in the desktop file explicitly?

If we keep "Open New Window", we are coherent for other application (and I think most of application will use documents, so creating a new one)
If we want for some applications hiding "Open New Window" and adding "Create a new document", this will create some inconsistency and I think we will have to patch a lot of applications, even those we don't support fully like glabels only to get the same wording.

Openoffice writer/spreadsheet/presentation is behaving as expected, as well as inkscape.

There is a bug/feature in gimp making than opening gimp again by "Open New Window" just focus it. I'll add a separate one for that.

Changed in unity:
status: Triaged → Incomplete
Changed in unity-2d:
importance: Undecided → Medium
status: New → Incomplete
Alex Launi (alexlauni) wrote :

Is this fix-released? We've had new window for quite some time but I don't think that's the same as new document. What about things like gedit that have tabs, new document doesn't necessarily mean either of things so maybe it's too ambiguous anyway?

Changed in unity:
status: Incomplete → Confirmed
Didier Roche (didrocks) wrote :

@Alex: this isn't fix-released. We hold this action as there were the "New Window" anywhere. Now that we removed it and replace it by middle click, we can start working on it (without having double entries and such bugs).

The list of the 3 apps is small though. If design can give a bigger list like gedit as you told…

Didier Roche (didrocks) wrote :

@inskape developers: please find the patch attached to this bug report

Inkscape is done, gnome-screenshot has been added for a more complex example (see bug #720610)
So, closing this task as The gimp need a more advanced patch (there is no way with the command line to force gimp opening a new blank image). On LibreOffice, I opened bug #720716 for tracking it.

Changed in unity:
status: Confirmed → Fix Committed
milestone: 3.2.8 → 3.4.4
Didier Roche (didrocks) wrote :
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-0ubuntu2

---------------
inkscape (0.48.1-0ubuntu2) natty; urgency=low

  * debian/patches/01_add_unity_quicklist_support.patch:
    - add unity quicklist support for a new entry to inkscape (LP: #676886)
 -- Didier Roche <email address hidden> Thu, 17 Feb 2011 14:48:57 +0100

Changed in inkscape (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2011-02-18
Changed in unity:
status: Fix Committed → Fix Released
Changed in inkscape:
status: New → Triaged
importance: Undecided → Wishlist
David Barth (dbarth) on 2011-02-21
tags: added: needsdesignreview
John Lea (johnlea) wrote :

Reviewed this bug and the 'New Document', 'New spreadsheet', ect... options do not appear in the quicklist. Returned to triaged.

tags: removed: needsdesignreview
Didier Roche (didrocks) wrote :

Seems you didn't read my comment above stating that the libreoffice ones are given to the libreoffice maintainer and is tracked under another bug.

John Lea (johnlea) wrote :

Moved back to 'fix released' and 'reviewedbydesign' because the Open Office issue is now being tracked as bug https://bugs.launchpad.net/ayatana-design/+bug/720716

tags: added: reviewedbydesign
removed: udt
Florian Boucault (fboucault) wrote :

Didier, do you have any details on the technical implementation of the solution for inkscape? Is there a standard for it? Is it documented somewhere?

Florian Boucault (fboucault) wrote :

https://wiki.ubuntu.com/Unity/LauncherAPI details the quicklists specification.

Changed in unity-2d:
status: Incomplete → Triaged
tags: added: delta-with-3d
Changed in unity-2d:
milestone: none → 3.10
Changed in unity-2d:
milestone: 3.10 → none
Changed in unity-2d:
milestone: none → 3.10
assignee: nobody → Olivier Tilloy (osomon)
Changed in unity-2d:
status: Triaged → Fix Committed
Alex Valavanis (valavanisalex) wrote :

@inkscape-dev: I was thinking about committing this to lp:inkscape. Does anyone foresee any problems, or shall I go ahead.

Changed in inkscape:
assignee: nobody → Alex Valavanis (valavanisalex)
ScislaC (scislac) wrote :

I'm a little confused... given that Inkscape launches with a new/blank document, does this pop up the templates list instead to choose a different type of new document?

It's probably in a different report (who knows), but is there any work on "recent documents" from the unity launcher? I have to admit, this is one area Win7 is doing things right in their start menu now.

Alex Valavanis (valavanisalex) wrote :

The new quicklist option just runs the "inkscape" command, so it simply launches a new Inkscape window with default settings. As I understand it, this is needed because the default launcher can't open multiple windows...

In other words, the first time that you click on the launcher, Inkscape opens a new window. Subsequent clicks on the launcher just switch focus to the existing window. If the user wants to create a new document, they need to use "File->New->..." in Inkscape. With the new quicklist option, the user can now also create additional drawings from the launcher (right click on icon, choose "New Drawing"). In terms of providing a cohesive user experience, this is probably a good thing!

I don't know about accessing recent documents from launchers. Maybe one of the Unity devs can help here?

Didier Roche (didrocks) wrote :

This is more about adding a dynamic quicklist to inkscape (the current patch is a static quicklist). You can find some information about how to implement some dynamic quicklist entries (only when the application is running), here: https://wiki.ubuntu.com/Unity/LauncherAPI#Dynamic%20Quicklist%20entries

ScislaC (scislac) wrote :

Alex, I say go for it. The not being able to launch new windows from the launcher is definitely something that feels unnatural. Didier, provided it hadn't been requested or planned at this point, what is the most appropriate place to request the recent documents and such for apps pinned in the laucher? (other things are launching a private firefox session from the launcher and such)

Alex Valavanis (valavanisalex) wrote :

Fixed committed in lp:inkscape (r101201)

(my first commit to lp:inkscape, so please make sure I didn't mess anything up!)

Changed in inkscape:
milestone: none → 0.49
status: Triaged → Fix Committed
tags: added: patch-accepted-upstream
Changed in inkscape (Ubuntu):
importance: Undecided → Medium
Didier Roche (didrocks) on 2011-05-31
Changed in unity-2d (Ubuntu):
status: New → Fix Committed
Changed in unity-2d:
milestone: 3.10 → 3.8.6
Changed in unity-2d:
status: Fix Committed → Fix Released
Changed in unity-2d (Ubuntu):
status: Fix Committed → Fix Released
Changed in unity (Ubuntu):
status: New → Fix Released
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers