Indian Rupee: <ctrl-shift-u> 2 0 b 9 <enter> reports "unprintable"

Bug #662150 reported by Paul Sladen
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Fix Released
Low
Unassigned
inkscape (Ubuntu)
Fix Released
Low
Unassigned

Bug Description

Binary package hint: inkscape

The standard method for entering Unicode symbols (such as the Indian Rupee Sign) into Gtk+-based applications is the sequence:

  <ctrl-shift-u> 2 0 b 9 <enter>

doing this in Inkscape results in a report that the character is not printable and no character being inserted. However copying-and-pasting "₹" directly allows it to be inserted.

Ideally Inkscape would not try to be too-clever-for-its-own-good by artificially restricting the characters that can be entered with overriding the default Gtk+ methods.

Tags: fonts text
Revision history for this message
Alex Valavanis (valavanisalex) wrote :

As I understand it, the U+20B9 symbol was only approved a couple of months ago. <http://std.dkuug.dk/jtc1/sc2/wg2/docs/n3862.pdf>

I guess this might have something to do with the problem? Inkscape has no problem with other Unicode currency symbols like U+20B5

Changed in inkscape (Ubuntu):
status: New → Triaged
importance: Undecided → Low
tags: added: fonts text
Changed in inkscape:
importance: Undecided → Low
status: New → Triaged
Revision history for this message
Paul Sladen (sladen) wrote :

Alex: yes the Unicode codepoint was only assigned on 11 August 2010, and Unicode 6.0 was only released on 11 October 2010 (one day after the release of Ubuntu that shipped with a font containing the glyph).

However, that is all some what ancillary. The problem here is differing codepaths; pasting '₹' works, but using the Gtk+ method for Unicode entry does not.

Therefore, Inkscape is /overriding/ the default Gtk+ method and /breaking/ it in the process (eg. extra code in Inkscape is /obstructing/ something that is already working at the toolkit-wide level).

In this case Inkscape appears to be applying some kind of filter; and that filter of course can never reliably cope with future expansion of Unicode. Ideally the "clever" filter would be removed and the standard Gtk+ methodology be allowed to operate normally.

Revision history for this message
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r9832 on OS X 10.5.8 (ubuntu font installed)

Entering the Unicode with 'Ctrl+U 20b9' [1] fails with the message 'Non-printable character'.
Appending via 'Text > Glyphs…' dialog (Range: Currency Symbols) also works (besides pasting).

[1] <http://tavmjong.free.fr/INKSCAPE/MANUAL/html/Text-Creating.html#id4377874>
    <http://wiki.inkscape.org/wiki/index.php/Release_notes/0.42#Text>
    «Unicode entry in Text tool now conforms to ISO 14755’s “basic method”.»

Revision history for this message
su_v (suv-lp) wrote :

- Reproduced with Inkscape 0.48+devel r9832 on OS X 10.5.8
+ Reproduced with Inkscape 0.48+devel r9832 on OS X 10.5.8 (gtk2 2.20.1)

Revision history for this message
Open-Elearning (open-elearning) wrote :

Same problem with Inkscape 0.48.5 r under ubuntu 12.04 64 bits (Entering the Unicode with 'Ctrl+U 20b9' fails with the message 'Non-printable character'.)

Revision history for this message
Open-Elearning (open-elearning) wrote :

(and it seems that this bug affect all the unicode caracters not only Indian Ruppy, same problem on greek caracters)

Revision history for this message
jazzynico (jazzynico) wrote :

Reproduced on Crunchbang Waldorf, Inkscape 0.48.3.1.
Not reproduced with trunk revision 13507.

Could someone else confirm it's fixed with other operating systems?

Revision history for this message
su_v (suv-lp) wrote :

On OS X 10.7.5 (64bit):
- reproduced with (official packages) Inkscape 0.47, 0.48, 0.48.1
- not reproduced with (official package) Inkscape 0.48.2
- not reproduced with (local builds) Inkscape 0.48.2, 0.48.3.1, 0.48.4. 0.48.5 and current trunk r13505

Revision history for this message
jazzynico (jazzynico) wrote :

Tested again on Windows XP:
- reproduced with 0.48.2.
- not reproduced with 0.48.3.1, 0.48.5 and 0.91.x rev. 13633.

@Open-Elearning - Could you please confirm you're running Inkscape 0.48.5? As far as I can tell, the latest official Inkscape packages for your Ubuntu version is inkscape 0.48.3.1-1ubuntu1.

Revision history for this message
Open-Elearning (open-elearning) wrote :

Sorry, it works for me under ubuntu 12.04 64 bits with Inkscape 0.48.5 r.

On french laptop keyborad with the numeric pad it doesn't work, but with the numbers above the letters it works.
Sorry for the wrong report.

Revision history for this message
Open-Elearning (open-elearning) wrote :

(yes i'm using an other version than the default version of ubuntu 12.04 64 bits)

Revision history for this message
jazzynico (jazzynico) wrote :

Thanks for reporting back! I'm closing the report fixed then.

> On french laptop keyborad with the numeric pad it doesn't work

Follow-up report: Bug #1394559 "Unicode mode doesn't work with the numeric pad"

Changed in inkscape:
status: Triaged → Fix Released
Revision history for this message
Open-Elearning (open-elearning) wrote :

Great, thanks for this new bug report, followed up.

Changed in inkscape:
milestone: none → 0.48.3
Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers