[FFe] Please merge inkscape (main) with version 0.48.0-1 from Debian experimental main

Bug #628048 reported by Alex Valavanis on 2010-09-01
22
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Baltix
Undecided
Unassigned
inkscape (Ubuntu)
Wishlist
Chris Coulson

Bug Description

Binary package hint: inkscape

New upstream release introduces and improves several features. A few bugs are also marked as fixed upstream:
 * bug #388063
 * bug #401567
 * bug #456248
 * bug #463602

Debian changelog head:

inkscape (0.48.0-1) experimental; urgency=low

   * [cae07a3] New Upstream version 0.48.0
   * [309c498] add patch to fix crash in node tool
   * The highlights of this release are:
       - multipath editing
       - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
       - new Airbrush tool
       - LaTeX export with PDF/PS/EPS
       - JessyInk extension to create presentations
       - numerous bugfixes
   * [56702cf] don't build-depend on libssl-dev (closes: #573338)
   * [013b235] wrap lines in debian/control. patch by Benjamin Drung,
     many thanks to him (closes: #576357)
   * [747d3d1] add README.source adopted from nagios to make lintian a
     bit happier
   * [4df0df7] Remove all patches since they are applied upstream
 -- Wolfram Quester <email address hidden> Mon, 16 Aug 2010 13:49:28 +0200

Alex Valavanis (valavanisalex) wrote :

Does anyone have any idea why there's no lp:debian/experimental/inkscape branch on Launchpad yet? Until it appears, we can only perform this merge manually

Changed in baltix:
status: New → Invalid
status: Invalid → New
Alex Valavanis (valavanisalex) wrote :

I have made a manual merge, because lp:debian/experimental/inkscape is not yet available.

Please check the debdiff very carefully, because (a) I'm still pretty new to this and (b) It's my first manual merge

Changed in inkscape (Ubuntu):
assignee: nobody → Alex Valavanis (valavanisalex)
status: New → In Progress
Alex Valavanis (valavanisalex) wrote :

(build test in progress on my local machine)

tags: added: patch
Alex Valavanis (valavanisalex) wrote :

Test version in my PPA: ppa:valavanisalex/inkscape

https://launchpad.net/~valavanisalex/+archive/inkscape

Alex Valavanis (valavanisalex) wrote :

Oops... FTBFS in PPA for i386 and amd64

Alex Valavanis (valavanisalex) wrote :

Failure seems to be here:

install -o root -g root -m 644 /build/buildd/inkscape-0.48.0/debian/inkscape.xpm /build/buildd/inkscape-0.48.0/debian/inkscape/usr/share/pixmaps/inkscape.xpm
install: cannot create regular file `/build/buildd/inkscape-0.48.0/debian/inkscape/usr/share/pixmaps/inkscape.xpm': No such file or directory
make: *** [install] Error 1
dpkg-buildpackage: error: /usr/bin/fakeroot debian/rules binary-arch gave error exit status 2

Alex Valavanis (valavanisalex) wrote :

OK, I'm quite confused about this. debian/rules hasn't changed since the last Ubuntu release. Any ideas why this line is causing problems all of a sudden?

Alex Valavanis (valavanisalex) wrote :

Thanks to tumbleweed and evilshadeslayer on #ubuntu-motu, I have found the solution. We just need to add usr/share/pixmaps/ to debian/dirs

I'll upload the fixed debdiff shortly

Changed in inkscape (Ubuntu):
status: In Progress → Confirmed
assignee: Alex Valavanis (valavanisalex) → nobody
Alex Valavanis (valavanisalex) wrote :

New (hopefully final) debdiff. Just added a couple of notes in the changelog about the patches which were taken upstream.

Alex Valavanis (valavanisalex) wrote :

Successful i386 build in PPA

Alex Valavanis (valavanisalex) wrote :

Successful amd64 build in PPA

Alex Valavanis (valavanisalex) wrote :

Installs and runs successfully on i386

summary: - Please merge inkscape (universe) with version 0.48.0-1 from Debian
+ [FFe] Please merge inkscape (universe) with version 0.48.0-1 from Debian
experimental main

I've unsubscribed motu-release and subscribed ubuntu-release. Please only subscribe ubuntu-release in the future.

Marking as new as the FFe hasn't been approved yet.

Changed in inkscape (Ubuntu):
status: Confirmed → New
importance: Undecided → Wishlist
Ted Gould (ted) wrote :

+1 to the merge. There are many fixes and features in 0.48. It has been out since roughly feature freeze so it has had some time to bake. There is also a nighly PPA that was tested previous to 0.48 so it should land softly.

Scott Kitterman (kitterman) wrote :

Ack. FFe approved. Leaving at New for sponsor's review.

Mantas Kriaučiūnas (mantas) wrote :

Inkscape 0.48 still isn't associated with lots of supported filetypes including PDF, Postscript (ps), Encapsulated Postscript (eps), Adobe illustrator (ai), AutoCAD DXF, etc., see bug #278307
I've patched inkscape.desktop.in file from inkscape sources and added main supported filetypes into MimeType line.
Please add the patch, attached to bug #278307 into version 0.48 and allow opening supported files directly from GNOME/KDE and other standards compliant file manager.

Also don't forget to include update-desktop-database command in debian/postinst script.

description: updated
Changed in inkscape (Ubuntu):
assignee: nobody → Chris Coulson (chrisccoulson)

Thanks for working on this, I've uploaded it now

Changed in inkscape (Ubuntu):
status: New → Fix Committed
Alex Valavanis (valavanisalex) wrote :

That's great news. Thanks very much.

sam tygier (samtygier) wrote :

inkscape 0.48 hasn't turned up in the repos yet. https://launchpad.net/ubuntu/+source/inkscape does not show 0.48.

Chris Coulson (chrisccoulson) wrote :

That's because it hasn't been approved by anyone yet. We're in final freeze, please be patient.

It's sat in the queue, you can see this for yourself here: https://edge.launchpad.net/ubuntu/maverick/+queue?queue_state=1&queue_text=

summary: - [FFe] Please merge inkscape (universe) with version 0.48.0-1 from Debian
+ [FFe] Please merge inkscape (main) with version 0.48.0-1 from Debian
experimental main
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.0-1ubuntu1

---------------
inkscape (0.48.0-1ubuntu1) maverick; urgency=low

  * Merge with Debian unstable (LP: #628048, LP: #401567, LP: #456248,
    LP: #463602, LP: #591986)
  * debian/control:
    - Ubuntu maintainers
    - Promote python-lxml, python-numpy, python-uniconvertor to Recommends.
    - Demote pstoedit to Suggests (universe package).
    - Suggests ttf-dejavu instead of ttf-bitstream-vera (LP: #513319)
  * debian/rules:
    - Run intltool-update on build (Ubuntu-specific).
    - Add translation domain to .desktop files (Ubuntu-specific).
  * debian/dirs:
    - Add usr/share/pixmaps. Allow inkscape.xpm installation
  * drop 50-poppler-API.dpatch (now upstream)
  * drop 51-paste-in-unwritable-directory.dpatch (now upstream)

inkscape (0.48.0-1) experimental; urgency=low

  * [cae07a3] New Upstream version 0.48.0
  * [309c498] add patch to fix crash in node tool
  * The highlights of this release are:
      - multipath editing
      - improved text tool: subscript, superscript, numerical input for text kerning, tracking and more
      - new Airbrush tool
      - LaTeX export with PDF/PS/EPS
      - JessyInk extension to create presentations
      - numerous bugfixes
  * [56702cf] don't build-depend on libssl-dev (closes: #573338)
  * [013b235] wrap lines in debian/control. patch by Benjamin Drung,
    many thanks to him (closes: #576357)
  * [747d3d1] add README.source adopted from nagios to make lintian a
    bit happier
  * [4df0df7] Remove all patches since they are applied upstream
 -- Alex Valavanis <email address hidden> Sun, 12 Sep 2010 19:44:58 +0100

Changed in inkscape (Ubuntu):
status: Fix Committed → Fix Released
Scott Kitterman (kitterman) wrote :

Unsubscribing the release team since otherwise, due to the bogus baltix task it won't come off of our bug list.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers