gimp_xcf.py crashed with TypeError in effect()

Bug #565296 reported by Vyacheslav S. on 2010-04-17
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Medium
jazzynico
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: inkscape

After I've saved a simple drawing as Inkscape SVG (Created from template fontforge glyph) and cople of seconds after got this crush report.

Description: Ubuntu lucid (development branch)
Release: 10.04

inkscape:
  Installed: 0.47.0-2ubuntu2
  Candidate: 0.47.0-2ubuntu2
  Version table:
 *** 0.47.0-2ubuntu2 0
        500 http://il.archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

ProblemType: Crash
DistroRelease: Ubuntu 10.04
Package: inkscape 0.47.0-2ubuntu2
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
Architecture: i386
CheckboxSubmission: 045a5921d8c95708a6dcf31b24f15ea6
CheckboxSystem: daed2f3d6643b4a84b4520a2427f8c2b
Date: Sat Apr 17 13:26:56 2010
ExecutablePath: /usr/share/inkscape/extensions/gimp_xcf.py
InstallationMedia: Ubuntu 10.04 "Lucid Lynx" - Alpha i386 (20100329)
InterpreterPath: /usr/bin/python2.6
ProcCmdline: python /usr/share/inkscape/extensions/gimp_xcf.py --guides=false --grid=false /tmp/ink_ext_XXXXXX.svgY4E8AV
ProcEnviron:
 LANG=en_US.utf8
 SHELL=/bin/bash
PythonArgs: ['/usr/share/inkscape/extensions/gimp_xcf.py', '--guides=false', '--grid=false', '/tmp/ink_ext_XXXXXX.svgY4E8AV']
SourcePackage: inkscape
Title: gimp_xcf.py crashed with TypeError in effect()
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Related branches

Vyacheslav S. (slovarikable) wrote :

Thank you for taking the time to report this crash and helping to make Ubuntu better. This particular crash has already been reported and is a duplicate of bug #553617, so is being marked as such. Please look at the other bug report to see if there is any missing information that you can provide, or to see if there is a workaround for the bug. Additionally, any further discussion regarding the bug should occur in the other report. Please continue to report any other bugs you may find.

tags: removed: need-duplicate-check
visibility: private → public
su_v (suv-lp) wrote :

Reproduced with Inkscape 0.48+devel r9686 on OS X 10.5.8 when exporting a file created from template 'font_glyph'

Possibly caused by incomplete layer structure of "layer 1" in the template?

Changed in inkscape:
importance: Undecided → Medium
status: New → Confirmed
tags: added: exporting xcf
Changed in inkscape (Ubuntu):
status: New → Confirmed
jazzynico (jazzynico) wrote :

FontForge template (layer errors) fixed in the trunk, revision 9693.
Please test!

Changed in inkscape:
assignee: nobody → JazzyNico (jazzynico)
status: Confirmed → In Progress
su_v (suv-lp) wrote :

Crash not reproduced when exporting a new SVG file from the modified FontForge template of r9693 to XCF.
I haven't tested the SVG file in FontForge though - does it handle Inkscape's layer tags?

jazzynico (jazzynico) wrote :

> I haven't tested the SVG file in FontForge though - does it handle Inkscape's layer tags?

All I can say is that a Glyph created with this template in Inkscape is correctly imported in FontForge.

jazzynico (jazzynico) on 2010-08-11
Changed in inkscape:
milestone: none → 0.49
status: In Progress → Fix Committed
Alex Valavanis (valavanisalex) wrote :

Added upstream patch for testing in Ubuntu

Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Low
Alex Valavanis (valavanisalex) wrote :

I don't see a crash using inkscape_0.48.1-2ubuntu2 (Ubuntu Natty). However, I can't save as XCF. I get a "This extension requires at least one non empty layer." message, and a zero-byte output file.

tags: added: patch
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-2ubuntu5

---------------
inkscape (0.48.1-2ubuntu5) oneiric; urgency=low

  * debian/rules: No need to manually call intltool-update on build. This
    is now handled by dh_translations.
  * debian/control: No longer suggest python and skencil. They do not
    offer any enhancement to Inkscape (LP: #762541)
  * debian/control: Suggest transfig to allow import of xfig files
    (LP: #668300)
  * debian/patches/02-add-shebangs-and-fix-permissions.dpatch:
    No longer mark JavaScript extension files as standalone executables
    (LP: #602005):
    - share/extensions/*.js: Revert addition of shebangs
    - share/extensions/Makefile.am: Install *.js using _DATA rule rather
      than _SCRIPTS rule to avoid giving executable permission
  * debian/patches/fix-fontforge-glyph-template.dpatch: Cherry-pick
    patch from uptream trunk to fix layer structure in template (LP: #565296)
 -- Alex Valavanis <email address hidden> Mon, 30 May 2011 18:50:49 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
su_v (suv-lp) on 2011-06-10
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Patch committed in the 0.48.x branch, revision 9799.

Changed in inkscape:
milestone: 0.49 → 0.48.2
tags: removed: backport-proposed
Ted Gould (ted) on 2011-09-07
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments