Ubuntu

Editing a connector within a group that has been transformed returns it to its original position

Reported by Alex Valavanis on 2010-03-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Medium
Unassigned
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: inkscape

Most of the issues with connectors inside groups described in bug #168360 were fixed in version 0.47.0. However, a subtle problem remains.

To reproduce:

* Create a new inkscape document
* Draw two simple shapes
* Select the diagram connectors tool and join the two shapes
* Group the shapes and the connector
* Move the entire group
* Enter the group
* Select the diagram connectors tool and edit the connector line
 > The connector immediately returns to its original position (i.e. the position before the group was moved)

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 10.10
Package: inkscape 0.48.0-1ubuntu1
ProcEnviron:
 LANGUAGE=en_GB:en
 PATH=(custom, user)
 LANG=en_GB.utf8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.32-15.22-generic
SourcePackage: inkscape
Uname: Linux 2.6.32-15-generic i686

Alex Valavanis (valavanisalex) wrote :
~suv (suv-lp) on 2010-03-08
tags: added: connectors
~suv (suv-lp) wrote :

see also bug #479553 “Moving shape with connectors, connectors go wild”

jazzynico (jazzynico) wrote :

Confirmed on Ubuntu 9.10, Inkscape 0.47~pre4-0ubuntu1.

Changed in inkscape (Ubuntu):
status: New → Confirmed
jazzynico (jazzynico) wrote :

The issue is a bit different with bzr rev. 9286. There's no preview line problem, but the connector is moved back to its original place as soon as I edit it on the moved group.

Changed in inkscape:
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

I confirm the behaviour in comment #4 using inkscape_0.48.0-1ubuntu1. I have updated the description accordingly

summary: - Incorrect preview when editing a connector within a group that has been
- transformed
+ Editing a connector within a group that has been transformed returns it
+ to its original position
description: updated
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Changed in inkscape:
importance: Undecided → Medium
Changed in inkscape (Ubuntu):
importance: Undecided → Low
~suv (suv-lp) wrote :

No longer reproduced in Inkscape 0.48+devel r9989 on OS X 10.5.8

(fixed with r9988)

~suv (suv-lp) on 2010-12-29
Changed in inkscape:
milestone: none → 0.48.1
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.1-0ubuntu1

---------------
inkscape (0.48.1-0ubuntu1) natty; urgency=low

  * New upstream version (LP: #710619). Fixes several Ubuntu bugs:
    - Node editing causes segmentation fault (LP: #544599)
    - Cursor position markers are not cleared from rulers (LP: #627134)
    - Crashes when opening document properties (LP: #658055)
    - Export to XCF error with default template (LP: #485032)
    - Editing a connector in a transformed group returns it to original
      position (LP: #533897)
    - Ungrouping objects changes position of arrow lines (LP: #552289)
    - Will not save XCF file (LP: #642417)
    - XCF export fails when exporting from unsaved document (LP: #650890)
  * Drop all patches: Applied upstream
  * debian/rules: Disable chmod on debian/patches/* in clean rule (no patches used)
 -- Alexander Valavanis <email address hidden> Tue, 01 Feb 2011 12:53:34 +0000

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
jazzynico (jazzynico) on 2011-03-05
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers