save a copy reverts to save as

Bug #529843 reported by Kevin Hunter on 2010-03-01
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
Low
Tomasz Boczkowski
inkscape (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: inkscape

Just as summary describes. Repeatable with:

0. Edit some file.
1. File → Save a Copy
2. Choose a filename that already exists.
3. It will ask "Replace existing file?" Answer "No"
4. Rename to a new filename and click save.

It saves the new file, but now the *new* file is the active file. It's like the "No" response returned to the wrong section of code (to "Save As" as opposed to "Save a Copy")

ProblemType: Bug
Architecture: amd64
Date: Sun Feb 28 22:58:06 2010
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release amd64 (20091027)
NonfreeKernelModules: nvidia
Package: inkscape 0.47~pre4-0ubuntu1
ProcEnviron:
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-19.56-generic
SourcePackage: inkscape
Uname: Linux 2.6.31-19-generic x86_64

Related branches

Kevin Hunter (hunteke) wrote :
su_v (suv-lp) wrote :

reproduced with Inkscape 0.47 r9118 on OS X 10.5.8

Changed in inkscape:
status: New → Confirmed
tags: added: saving
Alex Valavanis (valavanisalex) wrote :

Confirmed in inkscape 0.47.0-1ubuntu2 in lucid alpha3

Changed in inkscape (Ubuntu):
status: New → Confirmed
Alex Valavanis (valavanisalex) wrote :

Still in inkscape_0.48.0-1ubuntu1

tags: removed: amd64
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
importance: Undecided → Low
Changed in inkscape:
importance: Undecided → Low
su_v (suv-lp) on 2014-01-26
tags: added: easy-fix
Changed in inkscape:
assignee: nobody → Tomasz Boczkowski (penginsbacon)

The patch fixes the sp_file_save_dialog call, which occurs after user clicks "no" in file replace dialog.

The attachment "save_copy.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
jazzynico (jazzynico) wrote :

Patch from comment #5 tested successfully on Crunchbang Waldorf, Inkscape trunk revision 13153, and committed revision 13154.
Thanks Tomasz!

Changed in inkscape:
milestone: none → 0.91
status: Triaged → Fix Committed
tags: added: backport-proposed
su_v (suv-lp) wrote :

Backported to stable release branch <lp:inkscape/0.48.x> in revision 10021.

Changed in inkscape:
milestone: 0.91 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.5-2ubuntu1

---------------
inkscape (0.48.5-2ubuntu1) utopic; urgency=medium

  * Merge with Debian Unstable (LP: #1358863). Fixes several Ubuntu bugs:
    - Illustrator CS SVG won't load: namespace URIs in entities (LP: #166371)
    - inkscape crashed with SIGSEGV in
      sp_dtw_color_profile_event() (LP: #966441)
    - inkscape crashed with SIGSEGV (LP: #1051017)
    - inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
      (LP: #1163241)
    - save a copy reverts to save as (LP: #529843)
    - Extension to braille not working on Xubuntu 12.10 (LP: #1090865)
  * Remaining changes:
    - debian/control:
      + Set Ubuntu Developer as maintainer,
      + build-depend on dh-translation to handle Ubuntu translation,
      + demote pstoedit from Recommends to Suggests (because it's in universe),
    - debian/patches/0006_add_unity_quicklist_support.patch: add.
    - debian/patches/series: update.
    - debian/rules:
      + add dh_translation to handle Ubuntu translation
  * Drop debian/patches/librevenge.patch (superseded by
      debian/patches/0006-Update_to_new_libwpg.patch)

inkscape (0.48.5-2) unstable; urgency=medium

  * debian/patches/: patchset updated
    - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
      Thanks to Rene Engelhard (rene) for the patch.
  * debian/control: build-dependencies updated
    - librevenge-dev added
    - libwpd-dev (>= 0.9.0) dropped
    - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
  * debian/: dh-autoreconf usage applied

inkscape (0.48.5-1) unstable; urgency=medium

  [ Luca Bruno ]
  * debian/rules: fix FTBFS on alpha (Closes: #738155)

  [ Mattia Rizzolo ]
  * debian/patches/: patchset updated against v0.48.5
    - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
    - 0005-Fix_FTBFS_due_to_tests.patch added

  [ Matteo F. Vescovi ]
  * Imported Upstream version 0.48.5
 -- Alex Valavanis <email address hidden> Tue, 19 Aug 2014 19:10:32 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers