[new upstream]Inkscape 1.0

Bug #1876996 reported by Guybrush88 on 2020-05-05
26
This bug affects 3 people
Affects Status Importance Assigned to Milestone
inkscape (Ubuntu)
Status tracked in Groovy
Focal
Wishlist
Mattia Rizzolo
Groovy
Wishlist
Mattia Rizzolo

Bug Description

On upstream, the final version of Inkscape 1.0 has been released. These are the release notes: https://inkscape.org/release/inkscape-1.0/

Erich Eickmeyer (eeickmeyer) wrote :

If you have a look at https://launchpad.net/ubuntu/+source/inkscape, you will find that 1.0-rc4 is currently stuck in release-proposed for groovy. Rest assured, this is being worked on.

Changed in inkscape (Ubuntu):
status: New → In Progress
importance: Undecided → Wishlist
Mattia Rizzolo (mapreri) on 2020-05-07
Changed in inkscape (Ubuntu):
assignee: nobody → Mattia Rizzolo (mapreri)
amano (jyaku) wrote :

Is it possible to have that SRU'ed as an additional Inkscape1.0 package to the LTS? Paralle to the normal Inkscape one?

Mattia Rizzolo (mapreri) wrote :

mhh, in parallel... perhaps. but it would be _very_ odd.

Let me add the ~ubuntu-sru team to seek their input.

I suppose the options would be inkscape1.0 package conflicting/replacing(/providing?) with the regular inkscape, or be able to install it completely in parallel, though I'm not sure if the latter would work.

About uploading 1.0 as an update to 0.92.4, that won't be possible, too many changes including breaking changes to the command line that are easily going to break other packages.

Anyway, an update to the ~inkscape.dev/stable PPA will happen soon.

Mattia Rizzolo (mapreri) on 2020-05-08
Changed in inkscape (Ubuntu Focal):
assignee: nobody → Mattia Rizzolo (mapreri)
importance: Undecided → Wishlist
amano (jyaku) wrote :

I think that conflicting/replacing would be fine. Focal will be around for a long, long time and 1.0 had a very bad timing being released so close after Focal.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu Focal):
status: New → Confirmed
Mantas Kriaučiūnas (mantas) wrote :

I think the best solution for focal would be to upload new inkscape release to focal-backports repository

Mattia Rizzolo (mapreri) wrote :

The backport project is mostly dead, finding somebody to approve uploads is already tricky enough, the idea that I would need to chase people down for any needed update already scares me.

Changed in inkscape (Ubuntu Focal):
status: Confirmed → Triaged
Changed in inkscape (Ubuntu Groovy):
status: In Progress → Fix Committed
Mantas Kriaučiūnas (mantas) wrote :

Someone tried to backport Inkscape 1.0-1 package to Ubuntu 20.04 (Focal)?
Debhelper 13 is not available in 20.04, it would be nice to have PPA with backported Inkscape 1.0 for testing.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 1.0-1

---------------
inkscape (1.0-1) unstable; urgency=medium

  [ Mattia Rizzolo ]
  * New upstream version 1.0. LP: #1876996
    https://wiki.inkscape.org/wiki/index.php/Release_notes/1.0
    https://inkscape.org/release/inkscape-1.0/
    https://inkscape.org/news/2020/05/04/introducing-inkscape-10/
  * d/watch: Update to point at the new source archive.
  * Update Marc Jeanmougin's upstream gpg key.
  * Refresh patches.
  * Bump debhelper compat level to 13.

  [ Gianfranco Costamagna ]
  * Increase test timeout to 3 minutes instead of 1, to avoid failures when
    a slow machine runs tests (such as riscv64 that is emulated in Ubuntu).

 -- Mattia Rizzolo <email address hidden> Thu, 07 May 2020 20:57:39 +0200

Changed in inkscape (Ubuntu Groovy):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers