No tutorials

Bug #1803021 reported by anatoly techtonik on 2018-11-13
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Max Gaukler
inkscape (Ubuntu)
Undecided
Mattia Rizzolo

Bug Description

When selecting `Help -> Tutorials` the error message is shown and no tutorial is loaded.

    Failed to load the requested file /usr/share/inkscape/tutorials/tutorial-basic.svg

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: inkscape 0.92.3-4
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13.1
Architecture: amd64
CurrentDesktop: i3
Date: Tue Nov 13 05:18:54 2018
InstallationDate: Installed on 2018-11-01 (11 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.3)
SourcePackage: inkscape
UpgradeStatus: No upgrade log present (probably fresh install)

anatoly techtonik (techtonik) wrote :
Mattia Rizzolo (mapreri) wrote :

They are in the separate inkscape-tutorials package, please install that and it will work. See LP: #238276

Changed in inkscape (Ubuntu):
status: New → Invalid
anatoly techtonik (techtonik) wrote :

This issue is about error message. Not a support request.

Mattia Rizzolo (mapreri) wrote :

Right, and the error message goes away once you install that package.

I don't plan to patch inkscape to change that string (and it wouldn't even be trivial, since it's shared by many other codepaths and it would also cause bad translations since nobody would be localizing that changed string).

anatoly techtonik (techtonik) wrote :

It is okay if you don't have time to patch the string, but closing this as invalid is like saying everybody else that they should not do this either. I can not appreciate such collaboration over UX. Sorry.

Mattia Rizzolo (mapreri) wrote :

Then let me change it to wontfix, which description is "Doesn't fit with the project plans, sorry." that literally matches my intentions.

Of course, if anybody wants to propose a patch is free to do it, especially if they make something that can at least partially be sent upstream as I really don't want to carry too big patches in the packaging.

Changed in inkscape (Ubuntu):
status: Invalid → Won't Fix
anatoly techtonik (techtonik) wrote :

Thanks! That's much better. =) As a minimal workaround, can you replace the text

    Failed to load the requested file /usr/share/inkscape/tutorials/tutorial-basic.svg

with check for file presence and the following text if check failed

    Inkscape Tutorials are shipped as a separate package, which
    saves 50Mb of Inkscape package size. Install `inkscape-tutorials`
    from Software Center or use `apt` from terminal:

       sudo apt install inkscape-tutorials

https://packages.ubuntu.com/cosmic/graphics/inkscape-tutorials

Mattia Rizzolo (mapreri) wrote :

That's not easy to do. Let me quote from my first reply:

> and it wouldn't even be trivial, since it's shared by many other
> codepaths and it would also cause bad translations since nobody woul
> be localizing that changed string).

i.e. that's a generic string used by many other functions, including the regular "open file".

anatoly techtonik (techtonik) wrote :

I see that translations is the primary concern even though the spurious error message in English is much worse than friendly explanation in English.

But I just wonder what is your C++-fu? Don't get me wrong - I am unable to write the patch myself, because my C++ skills are poor, and I am not saying that package maintainer of C++ project should have C++ skills. But if Inkscape was in Python, placing an exception handler into menu action handle doesn't seem like a lot of codepaths.

Mattia Rizzolo (mapreri) wrote :

Oh, that's handy, thank you Max.

You may wish to add a milestone for inkscape in this bug (I just added the task, but I don't have bug supervisor powers for inkscape (upstream) bugs), I'll see if I can backport it in the debian package for 0.92.x.

Changed in inkscape (Ubuntu):
status: Won't Fix → Triaged
Mattia Rizzolo (mapreri) on 2019-02-17
Changed in inkscape (Ubuntu):
status: Triaged → In Progress
assignee: nobody → Mattia Rizzolo (mapreri)
Max Gaukler (mgmax) on 2019-02-17
Changed in inkscape:
status: New → Fix Committed
Patrick Storz (ede123) wrote :

I guess this makes also sense to back-port to 0.92.x for us. Would you mind crating an MR Max (or just commit directly; I think you have permissions)?

Regarding bugs:
Have you heard already that we're migrating away from Launchpad and will do our issue tracking on GitLab going forward Mattia? While we can obviously try to keep Launchpad in order during the transition period we'll stop using it eventually on our side.

If you'd like I could also add you to the Inkscape bug team for the time being, just let me know.

Changed in inkscape:
milestone: none → 1.0
assignee: nobody → Max Gaukler (mgmax)
Mattia Rizzolo (mapreri) wrote :

I know, but the thing is that I haven't heard of any real transition plan, I just know that the issue tracker is open on gitlab and you welcome bugs there.

I understand the pain though, and I definitely do not plan on helping out with handling the ton of bugs that are stuck here, I'm way too scared by their number! :)
So I'll gently turn down your offer…

Mattia Rizzolo (mapreri) wrote :
Changed in inkscape (Ubuntu):
status: In Progress → Fix Committed
Patrick Storz (ede123) wrote :

> I know, but the thing is that I haven't heard of any real transition plan.

That's because we actually decided not to do a full transition of all bugs (you mention the huge number yourself - many of them are are likely not valid anymore).

A "Migration Game" is currently in the works that aims to motivate original reporters and other interested parties to re-test with current versions and re-file bugs that are still reproducible (more on that will be made public once it's officially launched).

Apart from that everybody is welcome to migrate bugs on their own schedule (e.g. bugs reported or affecting oneself).

There's no official decision yet what will happen with the rest of the bugs (some are still optimistic all of them could be migrated manually) but the most likely cases a) they're left for dead; b) they're closed; c) the whole tracker will be closed eventually.

> I understand the pain though, and I definitely do not plan on
> helping out with handling the ton of bugs that are stuck here,
> I'm way too scared by their number! :)

Oh, that was not my intention. The idea was mainly to give you the possibility to set milestones and/or close bugs that also affect Ubuntu and that you already watch anyway (i.e. to avoid having to ask somebody else to do it like above).

Max Gaukler (mgmax) wrote :

Backported to 0.92.x (will be released as 0.92.5). https://gitlab.com/inkscape/inkscape/merge_requests/533/

Patrick Storz (ede123) on 2019-02-17
Changed in inkscape:
milestone: 1.0 → 0.92.5
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.92.4-3

---------------
inkscape (0.92.4-3) unstable; urgency=medium

  * Add patch from upstream master branch to output a useful error if the
    tutorials aren't installed. LP: #1803021
  * d/control: switch Recommends from non-existent transfig to fig2dev.
    Closes: #925171

 -- Mattia Rizzolo <email address hidden> Wed, 20 Mar 2019 21:54:39 +0100

Changed in inkscape (Ubuntu):
status: Fix Committed → Fix Released
Max Gaukler (mgmax) wrote :

@Mattia Where would be the right place to report the underlying issue: "Installing inkscape/gimp/... does not install the help, contrary to what most users expect" ?

Mattia Rizzolo (mapreri) wrote :

But Inkscape never shipped the "help", that's online (at least here, clicking "help" → "Inkscape manual" opens a webpage). For the tutorials, in my opinion not installing them by default is a feature, as I'm very happy to do without some extra 55 MB.

In gimp, if I try to open the manual it offers a very nice window telling me that it's not installed and that I can either read it online or install the required package.

I.e. I fail to see any bug here.

If you are talking about the general tendency to not install such big documentation by default, you'd have to bring that up in the debian-devel@, as it's really something coming from Debian, rather than Ubuntu, and it wouldn't really make sense to report it as a bug.

anatoly techtonik (techtonik) wrote :

Thanks everyone for fixing the error message. It is better now. Although I would argue that adding 25% package size to help onboarding new users to Inkscape is nothing compared to the fact that many users will not be installing those docs, because they are not aware that these docs are not a plain text, but actual SVG files used to practice by doing. Anyway, this should be measured to draw any conclusions.

Max Gaukler (mgmax) on 2020-05-09
Changed in inkscape:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers