Inkscape doesn't render formulas with the Latex extension

Bug #1759483 reported by Till Sachau on 2018-03-28
26
This bug affects 5 people
Affects Status Importance Assigned to Milestone
inkscape (Ubuntu)
Undecided
Unassigned
pstoedit (Debian)
New
Unknown

Bug Description

Affects inkscape 0.92.3-1 on Bionic Beaver development version

On hitting 'Extensions -> Render -> Latex' the usual interface to insert a latex formula appears, but on hitting 'Apply' stops with the following error:

PostScript/PDF Interpreter finished. Return status 65280 executed command : /usr/bin/gs -I/home/till/.fonts -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS "/tmp/psinVP0LD1"

The interpreter seems to have failed, cannot proceed !

Full output (including a ghostscript warning) given below:

 *** WARNING - the DELAYBIND command has been deprecated, and will be

               removed in the next version. For now you can restore

               the behaviour by using -dREALLYDEALYBIND but if you

               require continued use of this command you should contact

               the Ghostscript developers. Commercial customers of

               Artifex should email their support contact, free users

               are encouraged to talk to us on the #ghostscript IRC

               channel on irc.freenode.net.

Unrecoverable error: undefined in DELAYBIND

PostScript/PDF Interpreter finished. Return status 65280 executed command : /usr/bin/gs -I/home/till/.fonts -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS "/tmp/psinVP0LD1"

The interpreter seems to have failed, cannot proceed !

Traceback (most recent call last):
  File "eqtexsvg.py", line 160, in <module>
    e.affect()
  File "/usr/share/inkscape/extensions/inkex.py", line 283, in affect
    self.effect()
  File "eqtexsvg.py", line 154, in effect
    svg_open(self, svg_file)
  File "eqtexsvg.py", line 81, in svg_open
    doc = inkex.etree.parse(filename)
  File "src/lxml/etree.pyx", line 3425, in lxml.etree.parse
  File "src/lxml/parser.pxi", line 1839, in lxml.etree._parseDocument
  File "src/lxml/parser.pxi", line 1865, in lxml.etree._parseDocumentFromURL
  File "src/lxml/parser.pxi", line 1769, in lxml.etree._parseDocFromFile
  File "src/lxml/parser.pxi", line 1162, in lxml.etree._BaseParser._parseDocFromFile
  File "src/lxml/parser.pxi", line 600, in lxml.etree._ParserContext._handleParseResultDoc
  File "src/lxml/parser.pxi", line 710, in lxml.etree._handleParseResult
  File "src/lxml/parser.pxi", line 639, in lxml.etree._raiseParseError
  File "/tmp/inkscape-cf8rEb/eq.svg", line 1
lxml.etree.XMLSyntaxError: Document is empty, line 1, column 1

Till Sachau (perpff) on 2018-03-28
tags: added: bionic
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Changed in pstoedit (Debian):
status: Unknown → New
Changed in pstoedit (Debian):
status: New → Fix Released
geez (geez) wrote :

I'm on Debian testing and installed the update from unstable:

Package pstoedit:
p A 3.70-5+b1 testing
i A 3.71-1 unstable

However it does not fix the issue for me, with the same error. Anyone else seeing this?

geez (geez) wrote :

Note the command mentioned in the debian thread:

pstoedit -f plot-svg /tmp/drawing.pdf /tmp/drawing.svg

Also still crashes.

Tommi Mikkola (tommi-mikkola) wrote :

As a temporary workaround, downgrading libgs9-common, libgs9 and ghostscript packages to version 9.21 from the Artful repositories helps.

Changed in pstoedit (Debian):
status: Fix Released → New
Norbert (nrbrtx) wrote :

Upcoming Ubuntu 19.10 is also affected:

Error: /undefined in .makeoperator

Operand stack:

   false rectfill rectfill --nostringval--

Execution stack:

   %interp_exit .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval-- false 1 %stopped_push 2044 1 3 %oparray_pop 2043 1 3 %oparray_pop 2024 1 3 %oparray_pop 1884 1 3 %oparray_pop --nostringval-- %errorexec_pop .runexec2 --nostringval-- --nostringval-- --nostringval-- 2 %stopped_push --nostringval-- --nostringval-- --nostringval--

Dictionary stack:

   --dict:1233/1684(G)-- --dict:0/20(G)-- --dict:217/300(L)-- --dict:1233/1684(G)--

Current allocation mode is global

Current file position is 14859

GPL Ghostscript 9.26: Unrecoverable error, exit code 1

PostScript/PDF Interpreter finished. Return status 256 executed command : gs -q -dDELAYBIND -dWRITESYSTEMDICT -dNODISPLAY -dNOEPS "/tmp/psin5ffcyd"

The interpreter seems to have failed, cannot proceed !

Traceback (most recent call last):
  File "eqtexsvg.py", line 160, in <module>
    e.affect()
  File "/usr/share/inkscape/extensions/inkex.py", line 283, in affect
    self.effect()
  File "eqtexsvg.py", line 154, in effect
    svg_open(self, svg_file)
  File "eqtexsvg.py", line 81, in svg_open
    doc = inkex.etree.parse(filename)
  File "src/lxml/etree.pyx", line 3435, in lxml.etree.parse
  File "src/lxml/parser.pxi", line 1840, in lxml.etree._parseDocument
  File "src/lxml/parser.pxi", line 1866, in lxml.etree._parseDocumentFromURL
  File "src/lxml/parser.pxi", line 1770, in lxml.etree._parseDocFromFile
  File "src/lxml/parser.pxi", line 1163, in lxml.etree._BaseParser._parseDocFromFile
  File "src/lxml/parser.pxi", line 601, in lxml.etree._ParserContext._handleParseResultDoc
  File "src/lxml/parser.pxi", line 711, in lxml.etree._handleParseResult
  File "src/lxml/parser.pxi", line 640, in lxml.etree._raiseParseError
  File "/tmp/inkscape-Xt9Whh/eq.svg", line 1
lxml.etree.XMLSyntaxError: Document is empty, line 1, column 1

tags: added: cosmic disco eoan
tags: removed: bionic
Norbert (nrbrtx) wrote :

It works on bionic.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.