In the Text and Font dialog, Ctrl+Z (Undo) destroys text

Bug #167262 reported by Bug Importer on 2006-01-30
Affects Status Importance Assigned to Milestone
inkscape (Debian)
inkscape (Ubuntu)

Bug Description


When typing text directly into the "Text and Font"
dialog (Shift+Ctrl+T, Text tab), pressing the Ctrl+Z
key or Edit menu > Undo, removes the text, with no
possiblity of recovery. The Redo action (Shift+Ctrl+Z)
does not recover the text. Even if Redo did recover
the text, it would be easy to lose the text if more
text were typed after the undo.


Enter text into a separate text editing application,
then copy and paste the text in. This avoids
accidental loss of text.

Proposed Solutions:

Disable Undo while the "Text and Font" dialog (Text tab
) text entry dialog, has keyboard focus. Or, if Undo
is pressed, alert the user of the loss of data with a
Yes/No dialog.

Rwst (rwst) wrote :

Confirmed on OpenSuSE 10.

But: you can just enter the text on canvas (also multiline),
with full Undo/Redo functionality.

Prokoudine (prokoudine) wrote :

Originator: NO

Confirmed on current SVN trunk, Ubuntu 7.10

Ryan Lerch (ryanlerch) on 2007-12-12
Changed in inkscape:
status: New → Confirmed
Slythfox (slythfox) wrote :

It seems to be fixed. (0.46pre2 for Win32)

tags: added: undo
~suv (suv-lp) wrote :

Still reproduced with Inkscape 0.46+devel r22465 on OS X 10.5.8

related: bug #426183

tags: removed: linux
Changed in inkscape (Ubuntu):
status: New → Triaged
Changed in inkscape:
status: Confirmed → Triaged
Changed in inkscape (Ubuntu):
importance: Undecided → Low
Changed in inkscape (Debian):
status: Unknown → New
Changed in inkscape (Debian):
status: New → Confirmed
John Smith (john-smithi) wrote :

Undo / Redo (and shortcuts) now have no affect in the Text dialogs text entry.

Changed in inkscape:
status: Triaged → Fix Released
Alex Valavanis (valavanisalex) wrote :

@John - please could you confirm when undo was disabled? Should this actually be "Fix Committed" for 0.49?

Alex Valavanis (valavanisalex) wrote :

Can anyone please confirm when this was fixed?

jazzynico (jazzynico) wrote :

Is it fixed actually? As far as I understand the original description, the bug is still present with r13438. I compared it with 0.46 and saw the same behavior.
Could someone else confirm?

Alex Valavanis (valavanisalex) wrote :

Reverting fixed status pending confirmation

Changed in inkscape:
status: Fix Released → Triaged
ScislaC (scislac) wrote :

It's actually even a little more broken than that... if you type text directly on canvas and then go and type more text in the text field in the T&F dialog, if you don't hit apply and hit undo it will delete the new text in the dialog plus the last letter typed on canvas. So it kind of does a "double undo" in that it does it in both places simultaneously, or at least that is how it appears.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.