inkscape crashed with SIGSEGV in sp_event_context_item_handler()

Bug #1194452 reported by David Callé on 2013-06-25
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
Undecided
Unassigned
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

Steps to reproduce:
1) Create a new document
2) Create a text zone with some text
3) Click somewhere else in the document
3) Double click on the text zone to edit it

ProblemType: Crash
DistroRelease: Ubuntu 13.10
Package: inkscape 0.48.4-0.1ubuntu3
ProcVersionSignature: Ubuntu 3.10.0-0.6-generic 3.10.0-rc7
Uname: Linux 3.10.0-0-generic x86_64
ApportVersion: 2.10.2-0ubuntu2
Architecture: amd64
Date: Tue Jun 25 13:09:25 2013
ExecutablePath: /usr/bin/inkscape
InstallationDate: Installed on 2013-06-25 (0 days ago)
InstallationMedia: Ubuntu 13.10 "Saucy Salamander" - Alpha amd64 (20130624)
MarkForUpload: True
ProcCmdline: inkscape /home/username/verrieres.svg
SegvAnalysis:
 Segfault happened at: 0x633f7d <_Z29sp_event_context_item_handlerP14SPEventContextP6SPItemP9_GdkEvent+93>: mov 0x90(%rdi),%rdi
 PC (0x00633f7d) ok
 source "0x90(%rdi)" (0x00000090) not located in a known VMA region (needed readable region)!
 destination "%rdi" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: inkscape
Stacktrace:
 #0 0x0000000000633f7d in sp_event_context_item_handler(SPEventContext*, SPItem*, _GdkEvent*) ()
 No symbol table info available.
 Cannot access memory at address 0x7fff80845ad8
StacktraceTop: sp_event_context_item_handler(SPEventContext*, SPItem*, _GdkEvent*) ()
ThreadStacktrace:
 .
 Thread 3 (LWP 11608):
 #0 0x00007fcfee3413cd in ?? ()
 No symbol table info available.
 .
Title: inkscape crashed with SIGSEGV in sp_event_context_item_handler()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

David Callé (davidc3) wrote :
information type: Private → Public

Stacktrace:
 #0 sp_event_context_item_handler (event_context=0x0, event_context@entry=<error reading variable: Cannot access memory at address 0x7fff80845ad8>, item=0x4f275f0, item@entry=<error reading variable: Cannot access memory at address 0x7fff80845ad8>, event=0x622dec0, event@entry=<error reading variable: Cannot access memory at address 0x7fff80845ad8>) at event-context.cpp:958
 No locals.
 Cannot access memory at address 0x7fff80845ad8
StacktraceTop: sp_event_context_item_handler (event_context=0x0, event_context@entry=<error reading variable: Cannot access memory at address 0x7fff80845ad8>, item=0x4f275f0, item@entry=<error reading variable: Cannot access memory at address 0x7fff80845ad8>, event=0x622dec0, event@entry=<error reading variable: Cannot access memory at address 0x7fff80845ad8>) at event-context.cpp:958
ThreadStacktrace:
 .
 Thread 3 (LWP 11608):
 #0 0x00007fcfee3413cd in ?? ()
 No symbol table info available.
 .

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
tags: added: crash text
Martin Owens (doctormo) wrote :

Tested with latest version of inkscape (trunk) and no error is found. I expect it's been fixed. Should we push for a fix for 0.48?

Changed in inkscape:
status: New → Invalid
su_v (suv-lp) wrote :

Crash not reproduced based on the provided steps (assuming "text zone" is referring to "Flowed text" - it remains unclear to me whether the reporter switched tools in-between or not, though either way the crash was not reproducible in my tests), with
- Inkscape 0.48.3.1, 0.48.4 and 0.48+devel r12388 on OS X 10.7.5 (tested with builds using either of the two available GTK+ backends on this platform, with various versions of the dependencies)
- Inkscape 0.48.4 on Ubuntu 13.04 (VM, 64bit)
- Inkscape 0.48.3.1 and 0.48+devel r12383 on Ubuntu 12.10 (VM, 64bit)
- Inkscape 0.48+devel r12388 (PPA) on Ubuntu 12.04 (VM, 64bit)
(all tests have been done with default (new) preferences for each launch)

su_v (suv-lp) wrote :

Martin Owens wrote:
> (…) I expect it's been fixed. Should we push for a fix for 0.48?

@Martin - just curious (because I fail to understand): how do you know what exactly to push (aka backport (?)), if you "expect" a so far not reproduced nor confirmed crash to be fixed in a code base which has seen quite a huge amount of changes wrt to the stable release branch? Could you attach the proposed backported patch for <lp:inkscape/0.48.x>?

> status: New → Invalid

Why? If this is a legitimate bug report for Inkscape 0.48.4, why close it as 'Invalid'? If not (i.e. there is no actual bug in the stable release 0.48.4 based on the provided data in this report) - then why proposing to push (aka backport (?)) some undeclared changes from trunk to fix an apparently invalid issue in 0.48.4?

jazzynico (jazzynico) wrote :

The fact that the bug can't be reproduced by bug triagers doesn't mean it's fixed!
We could close it 'invalid' if the reporter confirms that the issue doesn't occur anymore on the same computer, or if it can't be reproduced after a significantly longer testing period.
But for now, I suggest we revert the status to 'new'.

Changed in inkscape:
status: Invalid → New
Beluga (buovjaga) wrote :

David: Is this still happening with 0.91 or 0.92?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers