inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()

Bug #1163241 reported by Melissa Draper on 2013-04-02
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Inkscape
High
Kris
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

Summary is the same as #837744 but I was not doing the action described in that report.

I had selected several nodes and was using shift+down to move them when the crash happened.

ProblemType: Crash
DistroRelease: Ubuntu 13.04
Package: inkscape 0.48.4-0.1ubuntu2
ProcVersionSignature: Ubuntu 3.8.0-14.24-generic 3.8.4
Uname: Linux 3.8.0-14-generic x86_64
ApportVersion: 2.9.2-0ubuntu5
Architecture: amd64
Date: Tue Apr 2 23:54:06 2013
ExecutablePath: /usr/bin/inkscape
InstallationDate: Installed on 2013-03-28 (4 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha amd64 (20130326)
MarkForUpload: True
ProcCmdline: inkscape /home/username/hand.svg
ProcEnviron:
 LANGUAGE=en_NZ:en
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_NZ.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x6a8467 <_ZN8Inkscape11Preferences8_getNodeERKN4Glib7ustringEb+71>: mov (%rdi),%rax
 PC (0x006a8467) ok
 source "(%rdi)" (0x0000006e) not located in a known VMA region (needed readable region)!
 destination "%rax" ok
SegvReason: reading NULL VMA
Signal: 11
SourcePackage: inkscape
StacktraceTop:
 ?? ()
 sp_action_set_name(SPAction*, Glib::ustring) ()
 Inkscape::Verb::name(SPDocument*, Glib::ustring) ()
 Inkscape::EventLog::updateUndoVerbs() ()
 Inkscape::EventLog::notifyUndoCommitEvent(Inkscape::Event*) ()
Title: inkscape crashed with SIGSEGV in sp_action_set_name()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

Melissa Draper (melissa) wrote :

StacktraceTop:
 Inkscape::Preferences::_getNode (this=this@entry=0x2a8cb70, pref_key=..., create=create@entry=false) at preferences.cpp:632
 Inkscape::Preferences::_getRawValue (this=0x2a8cb70, path=..., result=@0x7fff600f7de8: 0x7f17b4193bc3 <std::basic_string<char, std::char_traits<char>, std::allocator<char> >::basic_string(char const*, std::allocator<char> const&)+67> "H\213\\$\020H\211E") at preferences.cpp:683
 Inkscape::Preferences::getEntry (this=<optimized out>, pref_path=...) at preferences.cpp:407
 Inkscape::Preferences::getBool (this=<optimized out>, pref_path=..., def=false) at preferences.h:284
 (anonymous namespace)::ink_node_tool_root_handler (event_context=0x86a33e0, event=0x9492730) at ui/tool/node-tool.cpp:462

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
summary: - inkscape crashed with SIGSEGV in sp_action_set_name()
+ inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
tags: removed: need-amd64-retrace
Adolfo Jayme (fitojb) on 2013-05-27
information type: Private → Public
su_v (suv-lp) wrote :

Likely the same as bug #937835, bug #983843, and bug #1049277.

Maybe these reports should be unlinked as duplicate of
- Bug #941317 “inkscape crashed with SIGSEGV in getObject()”
  <https://bugs.launchpad.net/inkscape/+bug/937835>
since bug #937835 itself is fixed in Inkscape 0.48.4.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inkscape (Ubuntu):
status: New → Confirmed
Kris (kris-degussem) on 2013-12-23
Changed in inkscape:
importance: Undecided → High
Kris (kris-degussem) on 2013-12-31
Changed in inkscape:
milestone: none → 0.91
status: New → Triaged
Kris (kris-degussem) wrote :

No information available to help provoke this bug, nor to check whether it is fixed ...
The added null check in this patch should prevent this crash though.

The attachment "1163241.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
jazzynico (jazzynico) on 2014-01-08
Changed in inkscape:
status: Triaged → In Progress
assignee: nobody → Kris (kris-degussem)
tags: added: backport-proposed crash
Kris (kris-degussem) wrote :

Patch in comment 8 committed to trunk in r12902

Changed in inkscape:
status: In Progress → Fix Committed
Changed in inkscape (Ubuntu):
status: Confirmed → Triaged
tags: added: patch-accepted-upstream
removed: patch
jazzynico (jazzynico) wrote :

Fix backported to the 0.48.x branch, revision 10009.

Changed in inkscape:
milestone: 0.91 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.5-2ubuntu1

---------------
inkscape (0.48.5-2ubuntu1) utopic; urgency=medium

  * Merge with Debian Unstable (LP: #1358863). Fixes several Ubuntu bugs:
    - Illustrator CS SVG won't load: namespace URIs in entities (LP: #166371)
    - inkscape crashed with SIGSEGV in
      sp_dtw_color_profile_event() (LP: #966441)
    - inkscape crashed with SIGSEGV (LP: #1051017)
    - inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
      (LP: #1163241)
    - save a copy reverts to save as (LP: #529843)
    - Extension to braille not working on Xubuntu 12.10 (LP: #1090865)
  * Remaining changes:
    - debian/control:
      + Set Ubuntu Developer as maintainer,
      + build-depend on dh-translation to handle Ubuntu translation,
      + demote pstoedit from Recommends to Suggests (because it's in universe),
    - debian/patches/0006_add_unity_quicklist_support.patch: add.
    - debian/patches/series: update.
    - debian/rules:
      + add dh_translation to handle Ubuntu translation
  * Drop debian/patches/librevenge.patch (superseded by
      debian/patches/0006-Update_to_new_libwpg.patch)

inkscape (0.48.5-2) unstable; urgency=medium

  * debian/patches/: patchset updated
    - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
      Thanks to Rene Engelhard (rene) for the patch.
  * debian/control: build-dependencies updated
    - librevenge-dev added
    - libwpd-dev (>= 0.9.0) dropped
    - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
  * debian/: dh-autoreconf usage applied

inkscape (0.48.5-1) unstable; urgency=medium

  [ Luca Bruno ]
  * debian/rules: fix FTBFS on alpha (Closes: #738155)

  [ Mattia Rizzolo ]
  * debian/patches/: patchset updated against v0.48.5
    - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
    - 0005-Fix_FTBFS_due_to_tests.patch added

  [ Matteo F. Vescovi ]
  * Imported Upstream version 0.48.5
 -- Alex Valavanis <email address hidden> Tue, 19 Aug 2014 19:10:32 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers