inkscape crashed with SIGSEGV

Bug #1051017 reported by GreatDanton on 2012-09-14
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Inkscape
High
Kris
inkscape (Ubuntu)
Medium
Unassigned

Bug Description

I was drawing something in Inkscape, and after I saved my work and tried to close Inskcape crashed.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: inkscape 0.48.3.1-1ubuntu6
ProcVersionSignature: Ubuntu 3.5.0-14.17-generic 3.5.3
Uname: Linux 3.5.0-14-generic i686
ApportVersion: 2.5.1-0ubuntu7
Architecture: i386
CrashCounter: 1
Date: Fri Sep 14 19:52:38 2012
ExecutablePath: /usr/bin/inkscape
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha i386 (20120724.2)
ProcCmdline: inkscape
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SegvAnalysis:
 Segfault happened at: 0x82afdd8: mov (%ebx),%esi
 PC (0x082afdd8) ok
 source "(%ebx)" (0xaaaaaaaa) not located in a known VMA region (needed readable region)!
 destination "%esi" ok
SegvReason: reading unknown VMA
Signal: 11
SourcePackage: inkscape
Stacktrace:
 #0 0x082afdd8 in ?? ()
 No symbol table info available.
 Cannot access memory at address 0xbfd8680c
StacktraceTop: ?? ()
ThreadStacktrace:
 .
 Thread 4 (LWP 22457):
 #0 0xb77a7424 in ?? ()
 No symbol table info available.
 .
Title: inkscape crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo

Related branches

GreatDanton (pribosek-jan) wrote :
visibility: private → public

StacktraceTop: sp_ui_menu_item_set_name (name=<error reading variable: Cannot access memory at address 0xbfd86814>, data=<error reading variable: Cannot access memory at address 0xbfd86818>, data@entry=<error reading variable: Cannot access memory at address 0xbfd8680c>) at interface.cpp:1580
ThreadStacktrace:
 .
 Thread 4 (LWP 22457):
 #0 0xb77a7424 in ?? ()
 No symbol table info available.
 .

Changed in inkscape (Ubuntu):
importance: Undecided → Medium
tags: removed: need-i386-retrace
nightrow (jb-benoit) on 2012-12-05
Changed in inkscape:
importance: Undecided → Medium
Kris (kris-degussem) wrote :

There is a lack of information on how this bug popped up, so I can not reproduce the bug, nor check whether it is fixed. However, it is quite probable that the issue is due to a missing NULL check.

Changed in inkscape:
status: New → In Progress
assignee: nobody → Kris (kris-degussem)
milestone: none → 0.49
importance: Medium → High
Kris (kris-degussem) wrote :

Bug should be fixed with trunk revision 12175.

Changed in inkscape:
status: In Progress → Fix Committed
tags: added: backport-proposed
jazzynico (jazzynico) wrote :

Modified patch that build cleanly with 0.48.x.

The attachment "1051017-backported-0.48.x.diff" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
su_v (suv-lp) wrote :

Fix backported to lp:inkscape/0.48.x in revision 9998.

Changed in inkscape:
milestone: 0.49 → 0.48.5
tags: removed: backport-proposed
Changed in inkscape:
status: Fix Committed → Fix Released
Changed in inkscape (Ubuntu):
status: New → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package inkscape - 0.48.5-2ubuntu1

---------------
inkscape (0.48.5-2ubuntu1) utopic; urgency=medium

  * Merge with Debian Unstable (LP: #1358863). Fixes several Ubuntu bugs:
    - Illustrator CS SVG won't load: namespace URIs in entities (LP: #166371)
    - inkscape crashed with SIGSEGV in
      sp_dtw_color_profile_event() (LP: #966441)
    - inkscape crashed with SIGSEGV (LP: #1051017)
    - inkscape crashed with SIGSEGV in Inkscape::Preferences::_getNode()
      (LP: #1163241)
    - save a copy reverts to save as (LP: #529843)
    - Extension to braille not working on Xubuntu 12.10 (LP: #1090865)
  * Remaining changes:
    - debian/control:
      + Set Ubuntu Developer as maintainer,
      + build-depend on dh-translation to handle Ubuntu translation,
      + demote pstoedit from Recommends to Suggests (because it's in universe),
    - debian/patches/0006_add_unity_quicklist_support.patch: add.
    - debian/patches/series: update.
    - debian/rules:
      + add dh_translation to handle Ubuntu translation
  * Drop debian/patches/librevenge.patch (superseded by
      debian/patches/0006-Update_to_new_libwpg.patch)

inkscape (0.48.5-2) unstable; urgency=medium

  * debian/patches/: patchset updated
    - 0006-Update_to_new_libwpg.patch added (Closes: #753430)
      Thanks to Rene Engelhard (rene) for the patch.
  * debian/control: build-dependencies updated
    - librevenge-dev added
    - libwpd-dev (>= 0.9.0) dropped
    - libwpg-dev (>= 0.2.0) bumped to libwpg-dev (>= 0.3.0)
  * debian/: dh-autoreconf usage applied

inkscape (0.48.5-1) unstable; urgency=medium

  [ Luca Bruno ]
  * debian/rules: fix FTBFS on alpha (Closes: #738155)

  [ Mattia Rizzolo ]
  * debian/patches/: patchset updated against v0.48.5
    - 0004-Fix_FTBFS_on_gcc-4.8.patch refreshed
    - 0005-Fix_FreeType_include.patch dropped (applied upstream)
    - 0006-Fix_FTBFS_on_poppler-0.26.patch dropped (applied upstream)
    - 0005-Fix_FTBFS_due_to_tests.patch added

  [ Matteo F. Vescovi ]
  * Imported Upstream version 0.48.5
 -- Alex Valavanis <email address hidden> Tue, 19 Aug 2014 19:10:32 +0100

Changed in inkscape (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers