I keep getting an error with initramfs every time it tries to load a new initrd image

Bug #98911 reported by Xipietotec
46
This bug affects 3 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Fix Released
Undecided
Unassigned

Bug Description

Binary package hint: initramfs-tools

Setting up initramfs-tools (0.85eubuntu7) ...
update-initramfs: Generating /boot/initrd.img-2.6.20-13-generic
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.

It's been doing this since I dist-upgraded and had to replace the -386 kernels with the -generic kernels (my dist-upgrade went horribly bad and I had to chroot into it from the live cd)...this doesn't prevent me from booting or anything, but I have no idea what it means.

Revision history for this message
Xipietotec (nahuatl) wrote :

It appears to have gotten worse:

Setting up linux-restricted-modules-common (2.6.20.4-13.14) ...

Setting up linux-restricted-modules-2.6.20-13-generic (2.6.20.4-13.14) ...

Setting up mdadm (2.5.6-7ubuntu5) ...
update-initramfs: Generating /boot/initrd.img-2.6.20-13-generic
cp: cannot stat `/etc/udev/rules.d/25-dmsetup.rules': No such file or directory
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
cpio: ./etc/udev/rules.d/*-lvm.rules: No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.20-12-generic
cp: cannot stat `/etc/udev/rules.d/25-dmsetup.rules': No such file or directory
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
cpio: ./etc/udev/rules.d/*-lvm.rules: No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.17-11-386
cp: cannot stat `/etc/udev/rules.d/25-dmsetup.rules': No such file or directory
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
cpio: ./etc/udev/rules.d/*-lvm.rules: No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.17-10-386
cp: cannot stat `/etc/udev/rules.d/25-dmsetup.rules': No such file or directory
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
cpio: ./etc/udev/rules.d/*-lvm.rules: No such file or directory
update-initramfs: Generating /boot/initrd.img-2.6.15-27-386
W: udev hook script requires at least kernel version 2.6.17
W: not generating requested initramfs for kernel 2.6.15-27-386
update-initramfs: Generating /boot/initrd.img-2.6.15-26-386
W: udev hook script requires at least kernel version 2.6.17
W: not generating requested initramfs for kernel 2.6.15-26-386
update-initramfs: Generating /boot/initrd.img-2.6.15-23-386
W: udev hook script requires at least kernel version 2.6.17
W: not generating requested initramfs for kernel 2.6.15-23-386
 * Starting MD monitoring service mdadm --monitor [ OK ]
 * Assembling MD array mdarrays... [ OK

Revision history for this message
Daniel Dehennin (launchpad-baby-gnu) wrote :

I have this problem with my feisty.

I have no md array and the initramfs hook complains about that.

Booting does not work, initramdik created by yaird are OK.

I think a test should be done to see if md are used, and it should honor the /etc/default/mdadm configuration file:
INITRDSTART='none' should by pass the problem.

Here is a verbose output of update-initramfs:

Calling hook mdadm
Adding binary /sbin/mdadm
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/md-mod.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/linear.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/multipath.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/raid0.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/raid1.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/xor.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/raid456.ko
Adding module /lib/modules/2.6.20-14-generic/kernel/drivers/md/raid10.ko
W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.

Revision history for this message
Christoffer Karvonen (xopher) wrote :

I got this problem today too, and I'm hoping for a fix. Any ideas?

Setting up initramfs-tools (0.85eubuntu9) ...
update-initramfs: Generating /boot/initrd.img-2.6.20-14-generic
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.

Setting up console-setup (1.13ubuntu13) ...
Installing new version of config file /etc/init.d/console-setup ...
 * Saving console font and keymap for next boot... [ OK ]
update-initramfs: Generating /boot/initrd.img-2.6.20-14-generic
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.

Setting up usplash-theme-ubuntu (0.14) ...
update-initramfs: Generating /boot/initrd.img-2.6.20-14-generic
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.

Revision history for this message
Daniel Dehennin (launchpad-baby-gnu) wrote :

Maybe this bug report should be re-assigned to mdadm ? It seems to be related to the mdadm initramfs hook.

Regards.

Revision history for this message
Henrik Hjelte (henrik-evahjelte) wrote :

This bug is blocking my upgrade to Feisty, and I have no idea how to fix it except maybe add a raid array. Why is this bug still unconfirmed and undecided?

Revision history for this message
adam brennan (acet) wrote :

This is a very serious problem that has affected me badly.
Since upgrading to Feisty i have lost the ability to run ANY usb devices - my external hard drive, ipod etc

i reinstalled mdadm to see if that did anything and this is what i got:

The following NEW packages will be installed:
  mdadm
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/231kB of archives.
After unpacking 680kB of additional disk space will be used.
Preconfiguring packages ...
Selecting previously deselected package mdadm.
(Reading database ... 158439 files and directories currently installed.)
Unpacking mdadm (from .../mdadm_2.5.6-7ubuntu5_i386.deb) ...
Setting up mdadm (2.5.6-7ubuntu5) ...
update-initramfs: Generating /boot/initrd.img-2.6.20-15-386
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
update-initramfs: Generating /boot/initrd.img-2.6.17-11-386
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
 * Starting MD monitoring service mdadm --monitor [ OK ]
 * Assembling MD array mdarrays... [ OK ]

tried to reinstall initramfs-tools aswell but to no avail.

At the boot up i see a message when its loading the file system saying something like "usbfs not recognised"

This problem is really damaging to my use of Ubuntu!

Revision history for this message
Victor Chahuneau (vchahun) wrote :

Same problem
- unable to finish the upgrade to Feisty: kernel 2.6.20 not activated
- getting stuck every time I want to install a package that requires kernel dependancies
- having to wait for every time failing configuration each time I want to install anything
- no clue about what is mdadm is used for
... quite annoying, even though the previous kernel keeps working well (no USB problems)

I created a duplicate: Bug #108675 before being redirected to this

*** Precision: affects also the -386 kernels, not only -generic ***

Details (similar):

$ sudo dpkg --configure -a
Paramétrage de linux-image-2.6.20-15-386 (2.6.20-15.27) ...
Running depmod.
update-initramfs: Generating /boot/initrd.img-2.6.20-15-386
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
The provided postinst hook script [/sbin/update-grub] could not be run.
[...]

$ sudo update-initramfs -u -v
[...]
Calling hook mdadm
Adding binary /sbin/mdadm
Adding module /lib/modules/2.6.20-15-386/kernel/drivers/md/multipath.ko
W: mdadm: unchecked configuration file: /etc/mdadm/mdadm.conf
W: mdadm: please read /usr/share/doc/mdadm/README.upgrading-2.5.3.gz .
W: mdadm: no arrays defined in configuration file.
W: mdadm: falling back to emergency procedure in initramfs.
[...]

Please hurry up, even though using Linux has always been sometimes a synonym for patience ...

Changed in initramfs-tools:
status: Unconfirmed → Confirmed
Revision history for this message
Nathan Willis (n8) wrote :

Same problem here. dist-upgrading from edgy to feisty fails hard; this is serious.

*apt-get --reinstall install ___ fails to help
*apt-get -f install fails to help
*dpkg --configure -a fails to help

What to do?

Revision history for this message
Daniel Dehennin (launchpad-baby-gnu) wrote : Re: [Bug 98911] Re: I keep getting an error with initramfs every time it tries to load a new initrd image

Le 4984 Septembre 1993, Nathan Willis a tapoté:
> What to do?

The only workaround I found is to boot on the live CD.
Then mount the root device under /mnt/:

$ sudo bash
# mount /dev/hdXY /mnt

Mount /proc /dev and /sys

# mount --bind /proc /mnt/proc
# mount --bind /dev /mnt/dev
# mount --bind /sys /mnt/sys

Chroot to there:
# chroot /mnt

By defaut I do not have bash, which I prefer
# /bin/bash

You must mount everything:
# mount -a

Then install yaird.
# apt-get install yaird

Then create the initramfs with yaird
# yaird -o /boot/initrd.img-<version> <version>

You may delete the old initrd first.

# umount -a

Exit from the chroot, umount /mnt/proc /mnt/dev /mnt/sys /mnt
Reboot.

Hope it will help.
--
Daniel Dehennin

Revision history for this message
Sinistrad (launchpad-net-cowsgomoo) wrote :

Seems like lots of folk don't have any MD devices and don't plan to.
Removing the mdadm package will stop the errors and allow an initrd to be built OK. And since it's only necessary when accessing MD devs, it won't cause problems if you don't use that feature.

Revision history for this message
Sense Egbert Hofstede (sense) wrote :

If you don' t use RAID, you can solve it by removing mdadm. I successfully restarted the system after an upgrade to feisty without mdadm.

Revision history for this message
Victor Chahuneau (vchahun) wrote :

Temporary solution detailed:
if you don't use RAID, then
- remove the mdadm package

If necesserary (it was for me):
- remove the mdadm service (install sysv-rc-conf and use it to unselect mdadm + mdadm-raid)
- reinstall grub (it had been remove during the upgrade, probably, and needed to run update-grub)

- end with "sudo dpkg --configure -a"

Revision history for this message
TylerOderkirk (tylerod-erkirk) wrote :

While upgrading from Edgy to Feisty, I also saw lots of "falling back to emergency procedure in initramfs" error messages scroll by. Before I rebooted, I applied Victor's "temporary solution" from above (https://bugs.launchpad.net/ubuntu/+source/initramfs-tools/+bug/98911/comments/12) and my machine booted up just fine. I do not use RAID.

Here are the specific commands:

------snip
sudo apt-get remove mdadm
sudo apt-get install sysv-rc-conf
sudo sysv-rc-conf # Press space to "uncheck" each item on the mdadm and mdadm-radi lines)
sudo apt-get remove grub
sudo apt-get install grub
sudo update-grub
sudo dpkg --configure -a
------snap

Thanks Victor.

-Tyler

Revision history for this message
Paganini (nebanks) wrote :

What about those of us that do use RAID? I have a file / web server in my basement running a RAID0 (concatenating 4 9GB hard disks). The upgrade process from Edgy to Feisty succeeded, but I got the above error while rebuilding the initramfs, so I am afraid to reboot it with the new kernel until there's a real fix for it.

Revision history for this message
Thomas Hotz (thotz-deactivatedaccount) wrote :

This bug is quite old. Does this still happen in supported Ubuntu versions? Thank you for helping us!

Revision history for this message
Daniel Dehennin (launchpad-baby-gnu) wrote :

I do not have this issue with either precise or trusty.

Regards.

Revision history for this message
Andy Whitcroft (apw) wrote :

I believe that is bug report is now stale. Please reopen if not. Thanks.

Changed in initramfs-tools (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers