Module "cciss" not loaded at boot

Bug #89931 reported by xcheboox on 2007-03-05
4
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Undecided
Unassigned
Dapper
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Feisty (7.04 Herd 5) won't boot after installation on a HP Smart Array 462. It can't find the root-partition /dev/cciss/..... because the cciss-module isn't loaded.

Making a new initramfs including cciss works fine.

Martin Pitt (pitti) wrote :

Kernel team, can you please check whether this affects dapper as well? If so, this would make a good target for the point release.

Should also be fixed in gutsy, of course.

Changed in initramfs-tools:
assignee: nobody → ubuntu-kernel-team
assignee: nobody → ubuntu-kernel-team
Martin Pitt (pitti) wrote :

Kyle confirmed that this is easy to do.

Changed in initramfs-tools:
status: New → Triaged
Ben Collins (ben-collins) wrote :

cciss is already included in the initrd by initramfs-tools. Need more info to find the real problem. May be similar to cpqarray issue.

Martin Pitt (pitti) wrote :

Seems this does not affect Dapper then.

Changed in initramfs-tools:
milestone: ubuntu-6.06.2 → dapper-updates
status: Triaged → Incomplete
milestone: dapper-updates → none
status: Incomplete → Invalid
Martin Pitt (pitti) wrote :

This seems to be a trivial fix we should get into Gutsy.

Changed in initramfs-tools:
milestone: none → ubuntu-8.04-beta
Martin Pitt (pitti) wrote :

Trivial fix and low-hanging fruit for Hardy, good for servers.

Changed in initramfs-tools:
status: New → Triaged
Ben Collins (ben-collins) wrote :

The cciss module is definitely in the initrd in hardy:

$ zcat /boot/initrd.img-2.6.24-12-generic | cpio -t | grep cciss
lib/modules/2.6.24-12-generic/kernel/drivers/block/cciss.ko
42160 blocks

Changed in initramfs-tools:
status: Triaged → Fix Released

Per a decision made by the Ubuntu Kernel Team, bugs will longer be assigned to the ubuntu-kernel-team in Launchpad as part of the bug triage process. The ubuntu-kernel-team is being unassigned from this bug report. Refer to https://wiki.ubuntu.com/KernelTeamBugPolicies for more information. Thanks.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers