screen goes blank before showing password prompt (inteldrmfb, cryptsetup)

Bug #869119 reported by Felix Geyer on 2011-10-06
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
Medium
Steve Langasek
Oneiric
Medium
Steve Langasek
Precise
Medium
Steve Langasek

Bug Description

SRU justification: late-cycle regression that causes users who have encrypted root filesystems configured to be unable to see the password prompt with certain hardware, unless they switch VTs to toggle the video mode.

TEST CASE:
1) install a system with an encrypted root filesystem using the 11.10 alternate or server ISO.
2) verify that on affected, KMS-capable hardware, the passphrase prompt is not displayed at boot, but that it is displayed if you hit Alt+F6 followed by Alt+F7.
3) install initramfs-tools 0.99ubuntu8 from oneiric-proposed
4) reboot 10 times on the affected machine, and verify that the passphrase prompt is correctly shown in each case.
5) verify that with this version of initramfs-tools installed and cryptsetup and nvidia-current packages installed on nvidia-capable hardware, that there is no regression in the display of the plymouth splash screen at boot time vs. the previous version of initramfs-tools.

When booting the plymouth splash screen is shown for a second and then the screen goes blank.
I have an encrypted the root partition so this makes it a bit difficult to input the password.
Entering the password after some time when the screen is blank works fine though.

Switching the VT with ctrl+F6, ctrl+F7 shows the plymouth password promt again but it's very distorted.

Possibly a duplicate of bug #816267

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: plymouth 0.8.2-2ubuntu28
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Thu Oct 6 14:14:21 2011
DefaultPlymouth: /lib/plymouth/themes/kubuntu-logo/kubuntu-logo.plymouth
InstallationMedia: Kubuntu 10.04 LTS "Lucid Lynx" - Release amd64 (20100427)
MachineType: Dell Inc. Vostro 1320
ProcCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-12-generic root=/dev/mapper/root ro quiet splash vt.handoff=7
ProcEnviron:
 LC_TIME=de_DE.UTF-8
 LANGUAGE=
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/zsh
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-3.0.0-12-generic root=/dev/mapper/root ro quiet splash vt.handoff=7
SourcePackage: plymouth
TextPlymouth: /lib/plymouth/themes/kubuntu-text/kubuntu-text.plymouth
UpgradeStatus: Upgraded to oneiric on 2011-07-04 (93 days ago)
dmi.bios.date: 03/05/2010
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A08
dmi.board.name: 0T052J
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: N/A
dmi.modalias: dmi:bvnDellInc.:bvrA08:bd03/05/2010:svnDellInc.:pnVostro1320:pvrNull:rvnDellInc.:rn0T052J:rvr:cvnDellInc.:ct8:cvrN/A:
dmi.product.name: Vostro 1320
dmi.product.version: Null
dmi.sys.vendor: Dell Inc.

Felix Geyer (debfx) wrote :
Steve Langasek (vorlon) wrote :

Hi Felix,

A few things for you to try:

 - does hitting 'esc' once instead of Alt+F6/Alt+F7 fix the issue?
 - does hiting 'esc' *twice* fix the issue?
 - does hitting Alt+F7 *without* hitting Alt+F6 fix the issue?
 - what do you see if you boot without the 'quiet' option (but still with the 'splash' option)?

Finally, please add the options 'drm.debug=0x4' and 'plymouth:debug=file:/var/log/plymouth-debug.log' to your kernel commandline, and attach the resulting plymouth and kernel log files.

Changed in plymouth (Ubuntu):
status: New → Incomplete
Steve Langasek (vorlon) on 2011-10-06
Changed in plymouth (Ubuntu):
importance: Undecided → Medium
summary: - screen goes blank before showing password prompt
+ screen goes blank before showing password prompt (inteldrmfb,
+ cryptsetup)
Felix Geyer (debfx) wrote :

> - does hitting 'esc' once instead of Alt+F6/Alt+F7 fix the issue?

That shows a non-themed password promt without problems.

> - does hiting 'esc' *twice* fix the issue?

Sort of, that shows plymouth but the screen is very distorted.

> - does hitting Alt+F7 *without* hitting Alt+F6 fix the issue?

No, the screen remains black.

> - what do you see if you boot without the 'quiet' option (but still with the 'splash' option)?

That doesn't seem to change much but I can't read the text on the plymouth screen anyway.

Felix Geyer (debfx) wrote :
Felix Geyer (debfx) wrote :
Changed in plymouth (Ubuntu):
status: Incomplete → New
Steve Langasek (vorlon) wrote :

Ah, from the log I see that vesafb is first being loaded and then unloaded.

Since you're using cryptsetup, this all happens in the initramfs. So I think there's something wrong with the recently-added vesafb fallback in initramfs-tools - we should never be loading vesafb here.

affects: plymouth (Ubuntu) → initramfs-tools (Ubuntu)
Changed in initramfs-tools (Ubuntu):
status: New → Triaged
assignee: nobody → Steve Langasek (vorlon)
tags: added: rls-mgr-o-tracking
Colin Watson (cjwatson) on 2011-10-07
tags: added: regression-release
Steve Langasek (vorlon) wrote :

Felix, could you try adding a 'sleep 1' at line 90 of /usr/share/initramfs-tools/scripts/init-top/framebuffer and rerun update-initramfs -u, to check if this addresses the issue for you?

Felix Geyer (debfx) wrote :

Yes, that seems to fix the problem.
I've booted the machine multiple times and plymouth always shows up fine.

Steve Langasek (vorlon) on 2011-10-11
Changed in initramfs-tools (Ubuntu Oneiric):
milestone: none → oneiric-updates
Steve Langasek (vorlon) on 2011-10-11
Changed in initramfs-tools (Ubuntu Oneiric):
status: Triaged → In Progress
Changed in initramfs-tools (Ubuntu Precise):
status: New → In Progress
importance: Undecided → Medium
assignee: nobody → Steve Langasek (vorlon)
milestone: none → precise-alpha-1
description: updated
Steve Langasek (vorlon) on 2011-10-11
description: updated
description: updated

Hello Felix, or anyone else affected,

Accepted initramfs-tools into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in initramfs-tools (Ubuntu Oneiric):
status: In Progress → Fix Committed
tags: added: verification-needed
Felix Geyer (debfx) wrote :

The updated package works fine.

tags: added: verification-done
removed: verification-needed
Steve Langasek (vorlon) wrote :

As noted in the test case in the description, we also need to check that this doesn't regress for users on systems where vesafb is needed.

tags: added: verification-needed
removed: verification-done
Steve Langasek (vorlon) wrote :

I can confirm that this doesn't regress for the vesafb case on my test hardware.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package initramfs-tools - 0.99ubuntu8

---------------
initramfs-tools (0.99ubuntu8) oneiric-proposed; urgency=low

  * Too optimistic in thinking that the DRM driver will always be loaded
    in time for scripts/init-top/framebuffer to load; some users find that
    vesafb gets loaded first anyway, scrambling their console state in the
    initramfs. Add a one-second sleep before checking if we should fall back
    to vesafb, which seems to be long enough to work around this.
    LP: #869119.
 -- Steve Langasek <email address hidden> Mon, 10 Oct 2011 19:28:38 -0700

Changed in initramfs-tools (Ubuntu Precise):
status: In Progress → Fix Released
Changed in initramfs-tools (Ubuntu Oneiric):
status: Fix Committed → Fix Released
shclim (shclim) wrote :

This is happening to me on my 12.10 install. i.e., after boot I get a blank purple screen then followed by a blank black screen before the monitor goes into stand-by. If I switch the VT from F2 back to F7 the plymouth screen then appears fine and I can see the password box.

private_lock (private-lock) wrote :

 - does hitting 'esc' once instead of Alt+F6/Alt+F7 fix the issue?
Yes - I get a text-only password prompt

 - does hiting 'esc' *twice* fix the issue?
Yes - I see the graphical password prompt (= GPP)

 - does hitting Alt+F7 *without* hitting Alt+F6 fix the issue?
No - screen switches to powersave (no backlight) but accepts password typed blindly

 - what do you see if you boot without the 'quiet' option (but still with the 'splash' option)?
Depends on how, I remove the quiet:
a) If I trigger the grub boot menu, I always correctly get the GPP invariant of quiet or not quiet
b) Removing quiet from /etc/default/grub and running update-grub still leaves me with the screen in powersave

This machine is a notebook, originally installed with either oneric or natty alternate CD and updated up to quantal without reformating the hard-disk since.

private_lock (private-lock) wrote :

Comment 7 'sleep 1' does *not* fix the blank screen for me.

I assume, that the released fix from October 2011 already made it into quantal, so I haven't tried anything else so far.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers