Ubuntu

Comment 5 for bug 810221

Today I just tested plymouth_0.8.2-2ubuntu25_i386.deb, finding the video cutoff bug worse than ever, with video not restarting until X starts, cutting off at root filesystem mount.
Last night I did some digging while trying to fix another bug. I tried both the previous ubuntu 0.8.2 version and the ricotz 0.8.4 version and played with how it was called in the initramfs. The 0.4.8 version normally worked except for text rendering-until I tried changing the plymouth script in /usr/share/initramfs-tools/scripts/init-top to call plymouthd with no arguments, or with all except the --pid-file= argument. I then tried 0.8.2 but calling plymouth in init-top with the arguments used in the older Ricotz 0.8.4 version, and video worked. Using ricotz's 0.8.4 natty version with the current initramfs scripts led to NO video ouput after the passphrase prompt. I suspect but am not sure that future /run migration changes might invert this.
In short, calling plymouth (any version) with --pid-file=/run/initramfs/plymouth.pid or with no pid file argument causes the video to cut off. Calling it with --pid-file=/dev/.initramfs/plymouth.pid causes the video to continue as normal, except for no text rendering.
I have attached a tarball with the fix that worked for me. As always, open any tarball you see here into a directory before putting the files in place, as a normal safety precaution-that way you can find them again if you need to remove them! It contains the initramfs scripts for init-top and init-bottom that call Plymouth, the versions that work right now but may not in the future.
I am filing a separate report on the no text bug, as I have some screen photo logs that might help there.