boot fails: does not detect hda any more (port conflict?)

Bug #76872 reported by Martin Pitt on 2006-12-22
26
Affects Status Importance Assigned to Milestone
initramfs-tools (Ubuntu)
High
Ben Collins
Nominated for Dapper by towsonu2003
linux-source-2.6.20 (Ubuntu)
Undecided
Unassigned
Nominated for Dapper by towsonu2003

Bug Description

Binary package hint: linux-source-2.6.20

After today's dist-upgrade the kernel (2.6.20-2.2) does not boot any more because it cannot find the root fs (/dev/hda2). However, the only boot-related package upgrade today was udev, the very same kernel already booted fine for me this morning.

Booting current feisty with 2.6.17 works fine, dmesg says:
[ 28.035156] hda: max request size: 128KiB
[ 28.045570] hda: Host Protected Area detected.
[ 28.045573] current capacity is 25408559 sectors (13009 MB)
[ 28.045574] native capacity is 25410672 sectors (13010 MB)
[ 28.080730] hda: task_no_data_intr: status=0x51 { DriveReady SeekComplete Error }
[ 28.080734] hda: task_no_data_intr: error=0x04 { DriveStatusError }
[ 28.080738] ide: failed opcode was: 0xf9
[ 28.080749] hda: 25408559 sectors (13009 MB) w/512KiB Cache, CHS=25206/16/63, UDMA(66)
[ 28.080755] hda: cache flushes not supported
[ 28.080798] hda: hda1 hda2
[ 28.108631] hdc: max request size: 512KiB

The task_no_data_intr error messages always appear and seem to be harmless. It detects hda1 and hda2 just fine (just as 2.6.20-2.2 did this morning).

Now, when I boot 2.6.20, I get:

ide0: I/O resource 0x3F6-0x3F6 not free.
hda: ERROR, PORTS ALREADY IN USE
ide0 at 0x1f0-0x1f7,0x3f6 on irq14
ide1: I/O resource 0x376-0x376 not free.
ide1: ports already in use, skipping probe
register_blkdev: cannot get major 3 for ide0

a little later, the partitions on hdc (1 to 4) are detected just fine, but not hda's. Thus booting gets stuck in the initramfs because the root partition doesn't exist.

Martin Pitt (pitti) wrote :

This is the output of
$ grep '2006-12-22.*status installed' /var/log/dpkg.log | cut -f 5 -d\ |sort -u > /tmp/upgraded-packages.txt

just in case someone spots another package that could be responsible for this breakage.

Martin Pitt (pitti) wrote :
Martin Pitt (pitti) wrote :

Shamelessly bumping severity since failing to boot is pretty much a showstopper.

Changed in linux-source-2.6.20:
importance: Undecided → High
Martin Pitt (pitti) wrote :

<BenC> pitti: I bet it's initramfs-tools
<BenC> pitti: Edit: /usr/share/initramfs-tools/scripts/local-top/udev_helper
<BenC> comment out the modprobe for ide-generic at the end, and run "sudo update-initramfs -u"

That helped indeed. Thanks, Ben!

Luka Renko (lure) wrote :

I can confirm this bug on HP nw8240 with latest initramfs-tools update.
Workaround from Ben works.
Note: I was able to boot older (2.6.19-7) kernel even with latest initramfs tools.

Changed in initramfs-tools:
status: Unconfirmed → Confirmed
Mads Chr. Olesen (shiyee) wrote :

I can also confirm bug and that the fix works.

Allcolor-g (allcolor) wrote :

I've the problem on the 2.6.20 generic but not on the 386 version. I'll test the fix to see if it works.

Scott Robinson (scott-ubuntu) wrote :

Also, another work-around less invasive workaround is to add "ide0=noprobe ide1=noprobe" to your kernel command-line at the GRUB screen.

Changed in linux-source-2.6.20:
status: Unconfirmed → Rejected
Ben Collins (ben-collins) wrote :

0.85eubuntu1 should fix this now.

Changed in initramfs-tools:
assignee: nobody → ben-collins
status: Confirmed → Fix Released

Work's fine with 0.85eubuntu1

towsonu2003 (towsonu2003) wrote :

I'm having this problem (with Dapper) and (although the workaround doesn't work) I was wondering whether a backport can be considered for Dapper...

Peter Cherriman (pjcherriman) wrote :

towsonu2003, I not sure if you have the same problem as me.
But I had a similar problem installing the 2.6.20-generic kernel from feisty on a dapper machine
See https://bugs.launchpad.net/ubuntu/+source/linux-source-2.6.15/+bug/26998/comments/13
in bug report 26998

tags: added: iso-testing
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers