Logitech Cordless Desktop MX 5000 bluetooth desktop used to work but doesn't now

Bug #67321 reported by Joel Ebel
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned
initramfs-tools (Ubuntu)
Undecided
Unassigned

Bug Description

I've got a logitech cordless desktop MX 5000, which can appear as either a bluetooth device or just a USB hub with two HID devices attached. I installed ubuntu edgy from the beta CD, and the keyboard and mouse just worked. Presumably in HID mode, since I didn't do anything to set it up. Now, with the RC, I booted the live CD, and I can't use my keyboard and mouse. I had to go find a PS/2 keyboard to plug in to do anything. I still see the USB HID devices, but for some reason they don't work. I had to start hidd and connect to the mouse and keyboard before they would work. However, this is a big problem for anyone without a wired keyboard sitting around. I don't know why these devices didn't work in their USB HID mode. This is probably something that should be looked into so people with bluetooth keyboards can install ubuntu.

I filed this under the kernel package, but it's also possible that bluez has something to do with this too.

Revision history for this message
Dutch (straykat) wrote :

Just installed 32bit Kubuntu 6.10 using my Logitech MX 5000 (USB BlueTooth). I used the Alternate installer & the MX 5000 was detected throughout the installation. One first restart keyboard & mouse failed on log in. Borrowed normal PS/2 keyboard & mouse to log in. Opened all repositories & updated (no updates yet) then installed & configured nvidia driver & set up auto login.
Rebooted with MX 5000 keyboard & mouse. KDE desktop came up but no keyboard & mouse. Did notice that BlueTooth icon flashing in KDE Panel when keyboard used or mouse moved. Rebooted using PS/2 keyboard & mouse & went to System Settings -> BlueTooth. Came up with error -> DCOP error when calling services ().
Will install 64bit Kubuntu 6.10 with my MX 5000 using the Alternate installer & see how that goes. Will add to this bug report on completion.

StrayKat

Revision history for this message
Dutch (straykat) wrote :

Further to my entry above; just installed 64bit Kubuntu 6.10 using the Alternate installer. The installer detected my MX 5000 but at first reboot keyboard & mouse failed at login same at 32bit.
I didn't bother with rebooting with a borrowed PS/2 mouse & keyboard cause broken is broken.
I am now in the dark side (my kids Windows HD) till a bug fix or I buy a new keyboard & mouse.

StrayKat

Revision history for this message
Joel Ebel (jbebel) wrote :

While this is still a bug that it won't operate in USB HID mode, you can get the MX 5000 working using bluetooth. I did it by editing /etc/defaults/bluetooth to enable HIDD, restarting the bluetooth service and running hidd --connect [bluetooth ID] The bluetooth id is found on the back of the keyboard and mouse, or you can find it with hidd --search I think. Or perhaps something with hcitool. In any case, the keyboard and mouse work fine once bluetooth is set up, but it's a problem that something recently broke them. They used to work a few weeks ago in the edgy beta.

Revision history for this message
Dutch (straykat) wrote :

Thanks for the heads up on hidd. Will give it a go when I do the 64 bit version again. Got the 32bit going (after reading up in the wiki) by uninstalling all bluez packages. I don't think I have any Bluetooth support (& don't need it) but have my MX 5000 working :-)

StrayKat

Revision history for this message
Dutch (straykat) wrote :

Installed a 64bit edgy again last night & on the first restart used recovery. Followed the bluetooth set up from the wiki: https://help.ubuntu.com/community/BluetoothSetup
But system failed to detect my MX 5000 keyboard & mouse. Again uninstalled the bluez packages & keyboard & mouse were detected & working. This means someone with the Logitech MX 5000 keyboard & mouse can only get it working by not having bluetooth support.

Revision history for this message
Amedee Van Gasse (amedee) wrote :

I can confirm the problem. I also have a Logitech MX 5000.
I think the problem is a duplicate of https://bugs.launchpad.net/ubuntu/+source/bluez-utils/+bug/32415

There are two possible situations:

1. Your mouse&keyboard work.
This means they are in legacy HID mode. That means Linux thinks they are plain old USB devices, not bluetooth.
If you have a mobile phone and let it scan, it won't find your bluetooth dongle.

2. Your mouse&keyboard don't work.
This means you are now in HCI mode, which means bluetooth works.
Your mobile phone will be able to find your bluetooth dongle, but you won't be able to enter the passcode because keyboard&mouse don't work.

You can go from HID to HCI by typing the following command:
hid2hci
(quite unexpected!)

You can go from HCI to HID by unplugging your bluetooth dongle for a second. Or by typing hid2hci --hid, if you had a working keyboard.

When you boot, you start in HID mode. BIOS doesn't know about Bluetooth. That is why you can use the keyboard in Grub.
When your gdm or kdm or xdm comes up, you have a few seconds when the keyboard still works. This is just enough for me to type my username, if I'm fast enough.
After a few seconds, "something in the background" (I don't know what) switches your bluetooth from HID to HCI, and the keyboard stops working.
To get it working again, unplug the dongle (you are now back in HID mode).

This showstopper is almost a year old now, and still unconfirmed. Someone in one of the duplicate bug reports suggested sponsoring one of the bluetooth devs: donate money via paypal so they can buy a bluetooth rig and fix this bug.
The problem could be related to the Broadcomm chipset in the Bluetooth dongle.

Revision history for this message
Konstantinos Kostarellis (kostacooker) wrote :

I can confirm the bug with the MX 5000 and I think the bug #32415 is slightly different as #32415 is basicly about the PowerPC plattform ...

I'd like to see this showstopper too .. hopefully some good solution comes along where you still can use the bluetooth stack somehow ... at least on a second bluetooth device.

Revision history for this message
Samuel Cochran (sj26) wrote :

The fix to this appears to be "Turn on HIDD". I changed "HIDD_ENABLED" to "1" in /etc/defaults/bluetooth, then "sudo /etc/init.d/bluetooth restart", and everything works. Can it be turned on by default? Or was this changed in the previous version for some good reason?

Revision history for this message
snaggapuss (snaggapuss27) wrote :

ok after hrs of internet searchs trying to get my mx5000 and mx1000 to work i hit on this site
https://help.ubuntu.com/community/BluetoothInputDevices?action=show&redirect=BluetoothMouse,
I had done all the editing in sudo , putting in 1 instead of 0 changing this and changing that nothing worked. then I followed the somple instruction here and got the whole thing working in less that 2 minutes

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers